トップページ⇒tech
937コメント455KB

( ゚Д゚)ノ Delギコ猫のプログラミング相談室

レス数が900を超えています。1000を超えると表示できなくなるよ。
0001DelギコNGNG
      ∧∧  / ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄
 @' ― (,,゚Д゚) < Delphiのことなら聞いてヨシ
   し― し-J   \___________
0887Delギコ01/09/01 15:42ID:pHMQXkv2
    ∧ ∧  /
    (,,゚Д゚)<  難しい話おおいな
     |つ つ  \
   @   |  
    ∪ ∪  ツイテ ケナイ ガ リヨウサセテ モーラオッ
0888デフォルトの名無しさん01/09/01 19:32ID:74THsOQE
>>887
ZLIBやファイル分割の事?
そんなに難しい話だとは思わないけど、そんな俺にとって
CGIスレやLispスレなんかで話されている事は全く意味不明だ。

やっぱり育った畑でかなりスキルが違うよね…
0889デフォルトの名無しさん01/09/01 19:35ID:.iLG.i7Q
>>888
スキルの違いではなく,単に興味の対象が異なるだけだろうよ。
某 Delphi-ML だって ZLIB は興味の対象外だしな。
0890Delギコ01/09/01 19:52ID:TgdqYMp.
>>879のコードが肝ですのね。

                ∧ ∧   / ̄ ̄ ̄ ̄ ̄
                (゚Д゚ ,,)<  なるほど!
             _φ_⊂)__ \_____
           /旦/三/ /|
        | ̄ ̄ ̄ ̄ ̄|  |
        |千葉ピーナッツ|/
          ̄ ̄ ̄ ̄ ̄

ファイル分割とかは要らないのでパスしておこう。
Zlibを使ってみなければ。

早くD6届かないかニャー
0891Delフサギコ01/09/01 20:01ID:TgdqYMp.
>>872で逝ってるような
一般のZIP解凍ツール用のヘッダも付けてくれる関数が
欲しいのお。

        ∫
   ∧,,∧ ∬       / ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄
   ミ,,゚Д゚ノ,っ━~  < 暑い夏の優雅な一時……プハァ
_と~,,,  ~,,,ノ_. ∀  \_________
    .ミ,,,/~),  .| ┷┳━
 ̄ ̄ ̄ .し'J ̄ ̄|... ┃
 ̄ ̄ ̄ ̄ ̄ ̄ ̄   .┻
0892デフォルトの名無しさん01/09/01 20:31ID:74THsOQE
http://www.ziyu.net/%7Erent/bbs/bbs.cgi?room=delphi6
に英語版のZIPフォーマットドキュメントはってみた。
0893デフォルトの名無しさん01/09/01 20:36ID:pc/GW0EI
URL 春だけで良いのでは?

それは別にして,PKZIP のファイルフォーマット紹介してどうすんの?
gzip の話をしているのに。
0894デフォルトの名無しさん01/09/01 20:51ID:6Z/rX4Ao
ファイル分割関数欲しかったので感謝感謝。
お礼に俺の作ったヒドイXOR暗号関数でもどうぞ。
遅いと思うので適度に高速化してくれい
たぶんバグは・・・・あるかも

procedure XorStream(InStream,OutStream:TStream;XORPass:String);
var i,l:Integer;
chr :PChar;
bt :byte;
begin

chr:=PChar(XorPass);
l:=Length(Xorpass)-1;

for i:=0 to InSTream.Size-1 do begin
InStream.Read(bt,SizeOf(bt));

bt:=bt xor Ord(chr[i mod l]);

OutStream.Write(bt,SizeOf(bt));
end;

end;
0895デフォルトの名無しさん01/09/01 21:16ID:qjIN5xds
>>893
してるのはpkzipの話だろ?

っつーか、Delphi付属のは使ったこと無いけど
Cのzlibならgzipはそのまま読み書き出来るし…。
0896デフォルトの名無しさん01/09/01 21:23ID:74THsOQE
pkzip と zip って何が違うの?
0897デフォルトの名無しさん01/09/01 21:31ID:pc/GW0EI
pkzip と zip は同じだけど gzip は別。
ちょっとは調べろ。
0898デフォルトの名無しさん01/09/01 21:33ID:NMqSeTJw
>>895
ここで話されているのは zlib のエンジンを使った gzip の話でしょ?

Windows 版の WinZip が gzip を展開できるから間違って憶えていない?
089989501/09/01 21:41ID:qjIN5xds
>>898
かなり前の方でギコナビの人( >>647 )がふったのはgzipの話だけど、
今の >>870 からの流れはどー読んでも zip の方だろ?

pkzip2.x も gzip も zlib も、圧縮は同じdeflationアルゴリズムだってことは知ってるよな?
0900デフォルトの名無しさん01/09/01 21:42ID:74THsOQE
ああ、すまん。これね↓
ぜんぜん知らなかったよ
http://wdic.asuka.net/?title=gzip

UNIX 系の OS で, 半ば標準とも呼べる圧縮ソフトウェアの名称. gzip の
圧縮アルゴリズムは PKZIP 等と同じ "Deflate/Inflate compression" ア
ルゴリズム(LZ77 + シャノン・ファノ法)である.
・もともとの標準圧縮である compress は圧縮アルゴリズム(LZW)に特許が
あり, 自由に改良して使うようなことができなかった. そこで, GNU は独
自に圧縮ソフトウェアを開発した. それが GNUZip, つまり gzip である.
しかも gzip は compress より格段に圧縮率が高かったために, 普及度が
高いソフトウェアとなった.
・gzip はアーカイブ機能のない単一ファイルのみの圧縮なので tar で複数
ファイルを1本にアーカイブしてから圧縮を行ない, 拡張子を .tar.gz な
どとするのが普通.
・なお, 名は似ているが, パソコンの PKZIP とはファイル形式が異なる別
物である. gzip のファイル形式は RFC 1952 により規定されている.
0901デフォルトの名無しさん01/09/01 21:46ID:NMqSeTJw
で,「pkzip と zip は同じだけど gzip は別」ということでよろしいかな?

>>899
deflation「アルゴリズム」なぞは存在しない。
LZ およびその変形を使っているといいたいのであれば LHarc も「同じ」アルゴリズムだ。
ちなみに bzip2 は全く別だよ。

ここで話題にしているのはストリーム圧縮とは切り離したアーカイブファイルフォーマットの
相違の話。
090289901/09/01 21:58ID:qjIN5xds
>>901
えーと、だからなぁ、バイト列を「圧縮」する部分はpkzipもgzipも同じアルゴリズムなの。
「Lzss+Huffmanだから同じ」とかいうレベルではなく、完全に同じ。
Lha for unix と Unlha32.dll が同じ程度に同じ。

んだから、圧縮部分はzlibで行って、あと適当にヘッダをフッタをくっつければ
Lhasaで解凍できるようなzip書庫が完成するわけ。
そーゆー関数があれば便利だねー、って話じゃないの?
0903デフォルトの名無しさん01/09/01 23:23ID:X6XJCtLo
ごめん、混乱してきた。
zlib, pkzip, zip, gzip この4つの単語があたまのなかで回転してるんだが。

ZIP : Fhil Katz により開発された圧縮アルゴリズム.

PKZIP : MS-DOS で利用された圧縮ファイルの規格で、圧縮にはZIP方式を用いて、
複数のファイルをまとめられるよう対応させた規格ってことか?

GZIP : ZIP 圧縮方式を用いたUNIX版圧縮ファイルの規格?

ZLIB : 圧縮ライブラリで、現在は ZIP 方式が採用されているが、
将来変更される可能性があるって奴か。
090489901/09/02 00:05ID:sAGvjp0g
俺はこういう意味で使ってるつもり。
違ってたら突っ込んでくれ。>893さん、901さん
# つーかそんなことより、話がだんだんDelphiからかけ離れてきた気が
# するんだが、うざかったら言ってくれ。>ALL

-------------
・deflate: P.K.氏によって開発された「圧縮アルゴリズム」。

・zlib: deflate方式専用「圧縮ライブラリ」。

・pkzip: P.K.氏開発の「アーカイバ」。
    または、そのアーカイバで作れる「書庫」の形式。
    最新版は、deflate圧縮法で圧縮を行っている。(zlibは使ってないと思う)

・infozip: pkzip(有料)と完全互換なフリーの「アーカイバ」を作ろうと頑張ってるプロジェクト。
    彼らの作ったアーカイバは、当然deflate方式で圧縮を行っている。
    (zlib使う版をコンパイルすることも使わない版をコンパイルすることも可能)

・zip: 基本的にpkzipと同じ意味。「アーカイバ」または「書庫形式」。

・gzip: zlibを用いた「圧縮ソフト」。
   または、そのアーカイバで作れる「圧縮ファイル」の形式。
   複数のファイルをまとめる機能はない。
   圧縮法はzipと同じだけど、出力するファイルのフォーマットは違う。
--------------
0905デフォルトの名無しさん01/09/02 00:58ID:6P0Gxh8k
緊急なのれす!
デルファイ6にアップグレードしたら
マッチズマスク関数使えなくなったのです!ワイルドカードのみでも良いので、簡易正規表現対応の
マッチ関数を誰か教えてください!

#ところで、バージョンアップって和製英語なの?
0906デフォルトの名無しさん01/09/02 01:10ID:yhjI958.
http://www.geocities.co.jp/SiliconValley-Oakland/1680/zsaru/zsaru15.html
0907っlll@p8ppuoppp01/09/02 01:25ID:AApa0kh.


★★★援助交際学園★★★


本気でセックスフレンドを探してる女の子


お金に困っている女子中高校生


男性登録者も募集

http://000.zive.net/e.html
(援助交際学園)

l
0908名無しさん01/09/02 01:27ID:TwlrpNBk
>>868
/ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄
| 867ワラタけど、さすがに巨大過ぎ(ワラ
| 簡単だけど、説明つけたーヨ
| 言語、直リン先問わず自由に使ってちょんまげ
| とりあえず3000行まではオッケーに設定
| URLわからなくなったら http://www2.to/source で直行します
\___  _________
      ∨
♪   ∧ ∧ ♪
    (,,゚Д゚).  ♪
     |つ[|lllll]).
   〜|  |
    U U
0909名無しさん01/09/02 02:06ID:TwlrpNBk
>>904
Delphi-MLじゃないからイインジャネーノ?
少なくとも知識が増えたから漏れ的にはオッケー
0910デフォルトの名無しさん01/09/02 02:23ID:CnaAYxN.
>>909
2ch で増やした知識なぞゴミ。
0911デフォルトの名無しさん01/09/02 03:04ID:Ydpovi0w
>>910
ゴミになるか宝になるかは自分次第。
0912デフォルトの名無しさん01/09/02 12:33ID:G96xcqig
今991がいいこといった。感動した!宍戸錠のほおの手術も報われた!
0913デフォルトの名無しさん01/09/02 15:28ID:/FBmIq02
>912
お前が警察呼んだら救急車が来そうだな
0914Delギコ01/09/02 17:07ID:oukomFDw
      ∧∧   / ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄
 @' ― (,,゚Д゚)つ < >>908 こんなAAもアルデヨ
   し― ∪     \___________


              ∧            ∧
              / ・           / ';,
             /  ';          /  ';
             /   ;______/   ;
          /                  \
         /    /          \      \
        /´       |____|           |
        |  /////    |     |    /////     |
       |         |     |             |
        |         |    |             |
        |        ';    /             /
         \        \/          .. /
           ヽ               ........:::::::<

     _    
    | ∧ ∧
    | (;゚Д゚)
    | ⊂ | 
    | ⊂__ノ@
    | |
      ∧
/ ̄ ̄ ̄   ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄
 ZIPの話全然わからん。
 ライセンスがらみの話はややこしいの。
 ま・いっかー。
0915Delギコ01/09/02 17:13ID:oukomFDw
聞いてアロエリーナ ちょっと言いにくいんだけど
聞いてアロエリーナ

 気が付けば900超えてるの。
 なかなか人気のスレでうれしーの。

聞いてくれてあーりがと アロエリーナ♪
\                   /
   ̄ ̄ ̄|/ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄
    
  | ∧ ∧
  | (*゚Д゚)
  | ⊂ |
  | ⊂__ノ@
  | |      Ψ
  ̄ ̄ ̄ ̄     □ 
         ̄ ̄ ̄ ̄ ̄ ̄
0916Delギコ01/09/02 17:14ID:oukomFDw
 ほとんどアンタのAAだけどな。
\_ ______________/
   |/
           | ∧ ∧
           | (゚Д゚;) バレテタ?
           | ⊂ |
           | ⊂__ノ@
   Ψ       | |
   □     ̄ ̄ ̄ ̄ ̄ ̄
 ̄ ̄ ̄ ̄ ̄ ̄
 シカモ コピペ バッカ
0917デフォルトの名無しさん01/09/02 18:00ID:SHIZw3Bc
そろそろデルの話しましょうよ…
さっそくだけど、TListViewのカラムヘッダって
オーナードロー対応してないんですかね?
ソート時に小さい三角形を描画したいんだけども。
0918デフォルトの名無しさん01/09/02 18:45ID:1B.EZ816
zlib(RFC1950)とgzip(RFC1952)は、どちらも圧縮メソッドとして
deflate(RFC1951)を使っているが、ヘッダ等のフォーマットが違う。
Delphiのzlibライブラリはzlibフォーマットはサポートするが、
gzipフォーマットはサポートしない。
0919名無しさん01/09/02 20:19ID:TwlrpNBk
>>917
| ファイル名      | 拡張子 ▼ | 日付

ワラ
0920デフォルトの名無しさん01/09/02 23:53ID:QCAC7Pys
>>919 ワロタ。でもオーナードローより楽だな(w

それはともかくそろそろ次スレきぼん。
誘導もヨロシコ。
092191701/09/03 00:29ID:9VeIz7PY
>>919
いや、いままさにその方法で実現しているんですけど
見栄えよくするために描画したかった…
092280301/09/03 00:34ID:9VeIz7PY
カナーリ昔の話になるんだけども、803で言ってるのはつまりこういうこと。

TSaveDialog の OverwritePrompt を True にすると、
同名ファイルが存在するときに警告が出るよね?
仮に、あるディレクトリに
hoge.txt
hoge.html
hoge.csv
の三つのファイルがあったとする。

フィルタから テキスト文書(*.txt) を選んで hoge と入れても、
確認プロンプトは出ないよね。 hoge.txt ではないから。

フィルタから HTMLドキュメント(*.html) を選んで hoge と入れても、
確認プロンプトは出ないよね。 hoge.html ではないから。

そういうことなのれす。
だから、ダイアログ無いのテキストエディタに入力した時点で
拡張子を補完し、上書き確認メッセージを出したかった。
0923デフォルトの名無しさん01/09/03 08:13ID:0ZWEOnC6
次スレいるか? Delphi以外も受け付けてるとはいえ
ほとんどDelphiの質問ばかりに見えるんだが。
Delphiスレならもう2つもあるぞ
0924デフォルトの名無しさん01/09/03 09:39ID:oDYd29Ko
混乱の元になるから、Delネコには家たててあげない。
Delphi相談室スレに居候させてもらいなさい。
0925デフォルトの名無しさん01/09/03 10:25ID:cEMWUvVk
Delギコは我が道を行ってくれ。
次スレきぼーん。
0926デフォルトの名無しさん01/09/03 10:43ID:MMfG58Tc
ちょっと最近Delphiスレ乱立だな。
中級っぽいのはDelギコに統一整理きぼーん。
0927Delギコ01/09/03 10:54ID:wHGoXFco
      ∧ ∧
     (,, ゚Д゚)         __________
     ノ ∪ ⊃      /
    て_つつ \     | おうち建設ちゅう
   /      /\   |  ゴルァと気合入れてがんばるぞ!
 /  メ   ./    ゞィ \_  __________
 \ メ /        \   `ヽ!
  | .\イ----‐‐‐〜 ~~|     ∧_∧ヘ
  |.   |           .|     (゚Д゚//
  !、  .|     .┌┬┬┼、__  (つ/と)
  \.キ|     .├┼┼┼┼|   | // 〜
    ヽ! :--‐‐└‐'''''''゙゙゙゙゙゙゙゙゙゙   し`∪
0928Delギコ01/09/03 11:13ID:wHGoXFco
  /l   ∧_l_ 新スレつくったぞい。
 [二=(,,゚Д゚)==
 ヽl  |つ ノ
      |  ヽ
     U⌒U

( ゚Д゚)ノ Delギコ猫のプログラミング相談室part2
http://piza2.2ch.net/test/read.cgi?bbs=tech&key=999482946
0929雲黒斉01/09/03 22:51ID:Bqdp8nhU
こんばんは、Delphi初心者の雲黒斉です。
Delギコさん教えてください。

質問その1
Delphiを立ち上げたときに、現在作成中のプログラムを自動的にloadする方法は?

質問その2
CloseFileすると自動的に紙送りされてしまいますが、されない方法は?

質問その3
Formをそのままプリンタ-に出力する方法は?
0930デフォルトの名無しさん01/09/03 22:57ID:fdEwavAE
>>929
なぜ新スレがあるのにここに書き込んだのか教えてください。
しかもなぜageたのかも教えてください。お願いします
0931雲黒斉01/09/03 23:40ID:Bqdp8nhU
深い意味はありません。最初に目に入ったからです。
0932Delギッコーイカ01/09/03 23:50ID:7WmdGYpw
    /\       ________
  /ギッコー   /
/____\ <  >>929名前からして逝ってよしか?
  | ゚Д゚|    \
 ノ| || || || |し      ̄ ̄ ̄ ̄ ̄

マジメに質問したいなら
板の雰囲気くらい読んで理解してから
質問したらどうだ?

その2は意味不明だし。
  されない方法は紙をプリンタに差し込まないことだ。
0933_01/09/04 00:10ID:lU/sQbkw
失礼いたしました、雲黒斉改め_です。
質問その2については
頻繁に画面出力、プリンタ-出力を繰り返すプログラム(コンソ-ル)を作っているのですが、
連続紙を使っているので一々紙送りされるともったいないのです。
0934デフォルトの名無しさん01/09/04 00:12ID:STUdf/vA
だからageんなっつーの!!
0935名無しさん01/09/04 00:29ID:m9mxC.IA
>>933
2スレに逝かない限り、絶対に誰も答えてくれないと思うぞ
0936デフォルトの名無しさん01/09/04 08:12ID:QjlESLvE
>>932
意味もなく最初に目に入ったからという理由で、
ageてまで新スレにかきこまずに質問するのは、
他に意図があるからとしか思えません。
そんなあなたには誰も答えないと思います。
0937Delギッコーイカ01/09/04 10:05ID:rI/kNmo6
>>929
    /\       ________
  /ギッコー   /
/____\ <  >>つづきやるなら次のスレでな
  | ゚Д゚|    \ でないともう答えんよ
 ノ| || || || |し      ̄ ̄

その3だけはとりあえずわかる。(というか調べた)
http://www.sakaki.keiaikai.or.jp/cgi-bin/convroom/webconv.exe/read2?No=12223&Response_Root=12219

その2はサンプルコードをageないと誰にもわからん
常識的にCloseFileして紙送りなどされんと思うが
コンソールでプリンタ出力などしたことないので知らん
プリンタ依存しそうだな。

その1はDelphiIDEのことを言ってるのか?
環境オプショの設定タブ、自動保存の設定&保存の対象を
設定してみレ。

ああ、折れってなんて新設なんだろう。うっとり。ほれぼれ。
レス数が900を超えています。1000を超えると表示できなくなるよ。