トップページnetwork
14コメント7KB

sendmail

■ このスレッドは過去ログ倉庫に格納されています
0001DNSで困ってた人NGNG
メールサーバの事ですが
Linux+sendmailでメールサーバ建てようと思ってます。
POP3サーバも必要なんでしょうか?
sendmailってPOP3もOKなんでしょうか?
それともqmail+pop3(?)の方がいいのでしょうか
こういう事ってなかなか探してもみつからないので・・

思いっきりタコな質問ですが、誰かおしえてくれませんか?

0002FiveNGNG
コメントがつきませんね・・・。

> POP3サーバも必要なんでしょうか?
クライアントが POP3 でメールを取得するなら必要です。

> sendmailってPOP3もOKなんでしょうか?
sendmail には POP3 サーバー機能は含まれていません。
sendmail が POP3 サーバーにメールを deliver できるかどうかなら、
それは当然できるという回答になります。どうやるかは POP3 Server の
実装に依存します。
# NT 用の sendmail Pro にはついていますが、これと混同したのかな?

よって別途 POP3 Server をインストールする必要があります。
普通は qpopper を使うでしょう。

> それともqmail+pop3(?)の方がいいのでしょうか
sendmail が苦手で UUCP とか BITNET とか変わった(?)機能が不要であれば
qmail の方がインストール・設定・メンテナンス・セキュリティの確保が
容易でしょう。
qmail 関連の雑誌記事等については、ネットワーク必読書スレッドを読みましょう。
http://mentai.2ch.net/test/read.cgi?bbs=network&key=954649325
0003FiveNGNG
誤解を招きそうなので補足。

>UUCP とか BITNET とか変わった(?)機能が
UUCP とか BITNET とかの、SMTP とは別のメールシステム(アーキテクチャ)との
相互運用が不要な場合・・・という意味です。
0004>1NGNG
最新号のASCIIネットワークプロさんを読むべし
0005DNSで困ってた人NGNG
ありがとうございます

ついでにwwwサーバ+メールサーバ(sendmail+qpoperとかqmail+qpoper)で
PIII-600 mem128+OCNエコノミーだとどのぐらいまで
ユーザー数とか、、、いけるもんなんでしょうか
なんとも答えにくいと思いますが、
これぐらいのマシンでこのぐらいのユーザーが妥当とか・・
0006FiveNGNG
POP のユーザーは OCN 経由で 1 さんのネットワーク外からアクセスするのでしょうか?
それとも、基本的に内部(LAN 側)からのアクセスでしょうか?
後者だと仮定して話を進めます。

OCN の帯域が十分かどうかは、外部とやりとりするメールの数と平均メールサイズで
決まります。とはいえ、128kbps であれば 1 日に 1350MB のメールを受信するか
送信しない限り帯域が飽和することはないので、心配する必要はないでしょう。
# 実効スループットが 1/2 だとしても、675MB。多い日でも安心。

サーバーの性能が十分かどうかは同時アクセスユーザー数とメールボックスに
保存しているメールの数に依存します。平均メールサイズが 4KB だとしても、
それが 10000 通たまっていたらそれはサーバーパフォーマンスに悪影響を
及ぼします(こういうユーザーは実在します)。
ただ OCN Economy を引くような規模であれば、ユーザー数は 100 人未満であり、
同時アクセス数もたいしたことがないと思われるので、そう気にする必要はないと
思います。
0007FiveNGNG
むしろ気をつけるべきは、ユーザーがメールをサーバーに溜め込んで、サーバーの
ディスクをパンクさせることです。またサーバーのディスクがクラッシュして
ユーザーのメールが永遠に失われることです。前者についてはディスクの空き容量を
常に監視するスクリプトを書いて、後者についてはディスクの二重化(ミラーリング)
などによって対処しましょう。
# メールは日々追加・削除されるので、バックアップはあまり意味がありません。
 バックアップはユーザーの責任事項として、それを周知徹底したほうが管理が
 簡単になります。

ちなみに、ディスクの飽和ですが、以下の点に気をつける必要があります。
・最大メールボックスサイズ(/var/mail にある各ユーザーごとのファイルサイズの
 中で一番大きいもの)を上回る空き容量を確保しましょう。qpopper はメールを
 処理するときに、すべてのファイルをいったん .pop.<username> というファイルに
 コピーします。もし空き容量が十分でない場合、このコピー作業が失敗して
 エラーを MUA (Mail Client) に返します。
・/tmp の空きサイズを超える大きさのメールが届いた場合、sendmail はメールの
 受信に失敗します。詳細は以下のメールを参照。
 http://home.jp.freebsd.org/cgi-bin/showmail/FreeBSD-users-jp/24069
0008DNSで困ってた人NGNG
FIVEさん何度もありがとうございます

とりあえずsendmail+qpoperの設定がんばってみます
0009DNSで困ってた人NGNG
sendmailの設定ですが
ASCIIネットワークプロをとりあえず買ってやってみましたが

sendmail -btで
0 [email protected]とすると
メッセージの下のほうに
$# error $@ 5 . 4 . 3 $:Source Routing Rejectedとでます
これって何が原因でしょう?
また、エラーメッセージとかわかるページとかありますでしょうか?
できれば日本語がいいんですが・・よろしくおねがいします
0010DNSで困ってた人NGNG
何度もすみません
エラーは消えました。メールも送信できます。
が、受信できません・・・
自分宛 [email protected]に送信すると。
root宛にReturned mail:..とPostmaster notify:....の
二つのメールが来ます。
メールには The following addresses had permanent fatal errors
が出ます。
なにが悪いのかわかりません・・・
0011ns.15.toNGNG
0012 ns.15.to NGNG
 
0013210.225.52.214NGNG
 
0014classic.noc.ntt.co.jpNGNG
■ このスレッドは過去ログ倉庫に格納されています