トップページnetwork
42コメント21KB

DNS@`bindの設定

■ このスレッドは過去ログ倉庫に格納されています
0001名無しさんNGNG
bindの設定で困っています。
OCN Tech Page
http://www.ocn.ad.jp/setup/dns/unix/unix.html)
のIP等をおきかえて設定したのですが、うまくいきません。
ocnページにはhostsファイルの設定がないのですが無くてもいいのでしょうか?
私が買った本にはhostsファイルで設定しています。
現在は購入した本の設定でやっています。

nslookupでみるとはじめに
Can't find server name for address 192.168.1.10とでます
192.168.1.10で引いても同じエラーが出ます。
グローバルとローカルIP両方とも引けません
www.hoge.comは引けるのですが、、、

誰かお助けください
0002うひひNGNG
>1
中央区築地4丁目のとしこさーんって呼ぶより

ママはおかぁさーん!って呼んだほうが良いでしょ。
知らないおばさんなら何でもいいけど家族くらいは
おとうさん、おにいちゃんって呼びたいよね

hostsは最低loopbackはモチロンのこと
localのマシンは書いてあげて寂しがるから。

今時ホコ天で派手に踊っても誰も相手にしてくれないでしょ
バカ扱いされる
今はクラブでパラパラでも踊らナイト
流行には敏感でいてね

BINDはもう8.x使わないとダメよ。書式も違うから
だから
http://www.ocn.ad.jp/setup/dns/unix/bind8-j.html
ココよ。
本に古いこと書いてあっても信じちゃダメよ。
0003名無しさんNGNG
1ですー
bind は8つかってます----
0004>1NGNG
別のスレッドでもあったけど、ここで僕も勉強したよ
http://www.net-top.co.jp
ここのツボってとこ
0005うひひNGNG
>1
だからマシンに8.x組んでるのが普通なの
君の示したURLは4.xの設定なんだからそれで書いたらダメなのよ
ちゃんと8.xのページにいって設定してね。

hostsってhost.confと違うからね。両方きちんと書かないとダメ
nslookupでローカル解決できてないのはhostsだな。

BINDのツボは'.'だよだいたいそれ見直せば吉
00061ですNGNG
うひひさん、4さん
ありがとうございます
http://www.net-top.co.jp
行ってみます。
0007名無しさんNGNG
http://www.net-top.co.jpのツボ!その3にあった
http://www.nanet.co.jp/rlytest/relaytest.html
yahoo.co.jpの第三者中継の調査やってみたら

問題あり:不正な中継を受け付けます。

(210.140.200.116)
ORBS database...登録されています。
VIX realtime block list...登録されていません。

と出たよ。
yahooのメールってやばいの?
00081ですNGNG
あの・・・おかげでDNSの設定がうまくいったんですが
sendmailの設定もいじくったりしてたらDNSが動かなくなりました
こういうことはありますか?
0009>1NGNG
どこをどうしたのか?書いてくれないと答えようがありません
00101ですNGNG
sendmailのsendmail.defとかcfとか つぼをみていろいろ
いじってからなぜかDNSがうまく動かなくなりました
/var/namedをlsでみるとlsの表示結果が縦横に表示されるのが
縦だけにひょうじされたり・・・ DNSははじめからやり直してみます。


0011>10NGNG
よくわかんないけど /var/log のmaillogやmessagesにヒントない?
エラーとか、
DNS動かなくなったって、正引き・逆引き出来なくなったの?
それとも、一切動かなくなったの?
う〜〜ん 疑問
00121ですNGNG
だめです・・
/var/log/messagesの中に
No default TTL set using SOA minimum instead
no NS RRs found at zone top
(IN)rejected fue to errors (serial 2000061006)
〜〜
が出ます・・
0013ん?NGNG
それってSOAレコードの記述が間違っているのでは?
sendmailとは関係しないと思うんだけど。
0014FiveNGNG
最初の行は、デフォルト TTL がないので最小設定にしたよ、ってことで
致命的なエラーではないですが、次の「NS のリソースレコードがない」
ってのが致命的なんですね。

"example.com" があなたのドメインだとして、ちゃんと
@ IN NS hoge.example.com.
# 末尾の "." に注意。
または
@ IN NS hoge
という行がありますか?。一番ありそうなのは
@ IN NS hoge.example.com
として、補完されて hoge.example.com.example.com になっているとか
いうパターン。
00151ですNGNG
みなさんありがとうございます
でも まだ、だめです・・
/var/log/messages

No default TTL st using SOA minimum instead
〜IN(primary)is incalid - rejecting
database naming error
no SOA RR found
rejected due to errors
等がでます。

/var/named/example.com.zone(ゾーンファイル)
@ IN SOA dns.example.com. root.dns.example.com.(
2000061012 28800 14400 3600000 86400)
IN NS dns.example.com.
IN NS ocndns.(OCNのDNSserver)
IN A 111.222.333.444(DNSサーバIP)
IN MX 10 dns.example.com.
localhost IN A 127.0.0.1
loghost IN CNAME localhost
router IN A 111.222.333.443(るーたIP)
dns IN A 111.222.333.444
IN MX 10 dns.example.com.
www IN A 111.222.333.444
IN MX 10 dns.example.com.
server IN CNAME dns
mail IN CNAME dns
server2 IN CNAME www
ftp IN CNAME www
----いじょう
逆引きゾーンの方もほぼ同じ感じです。

上のほうでsendmailの設定とありますが、
今はすべてフォーマットしなおして設定しています・・・
0016>15NGNG
うーーん よくわからんぞ
取りあえず named.bootかnamed.conf見せて
0017FiveNGNG
うーん、同じゾーンファイルで動きましたが・・・。
SOA がないって言われていますが、上記 Zone ファイルの内容はドメイン名以外は
完全に未編集状態ですか?。それとも何か編集してます?。

もしかしてうっかり
@ IN SOA dns.example.com. root.dns.example.com. (
2000061012    ; Serial
 :
86400       ; Minimum)
とかして、最後の閉じ括弧がコメントになってしまっているとかありませんか?
これをやると SOA が見つからない、というエラーになります。
# なぜそう思うかというと、やったことがあるからです。(^^;
00181ですNGNG
named.conf
options {
directory "/var/named";
};
zone "."{
type hint;
file "named.ca";
};
zone "dns.exmple.com" {
type master;
file "dns.example.zone";
);
zone "444.333.222.111.in-addr.arpa"{
type master;
file "111.222.333.444.zone";
};
zone "0.0.127.in-addr.arpa"{
type master;
file "named.local";
};
-----いじょう
もうしわけありません よろしくおねがいします。
00191ですNGNG
FIVEさんへ
>86400       ; Minimum)
86400) ;Minimum
になってます;_;
泣きたくなってきた・・
00201ですNGNG
ping で www.example.comで返ってくるんですけど
nslookupでwww.example.comをすると
server:localhost
address:127.0.0.1
***localhost can't find www.example.com:server failed
と出ます
それと/var/namedをls -alすると
example.com.zoneとnamed.localが
#example.com.zone#->[email protected]
#named.local#->[email protected] と青色で表示されますが、
111.222.333.444.zoneは同じようになっていません。
なにか関係あるんでしょうか
0021FiveNGNG
名前解決は DNS に限った話ではないですから。
/etc/hosts に書いてあったりしませんか?

あと、zone ファイルは何で編集していますか?
全角スペースが入っているとかありませんか?
それから SOA を
@ IN SOA dns.example.com. root.dns.example.com. (
2000061012 28800 14400 3600000 86400)
と 1 行にまとめて書いてエラーメッセージはどう変わりますか?
0022FiveNGNG
ああ、なるほど。

もし、この内容で
> zone "dns.exmple.com" {
> type master;
> file "dns.example.zone";
> );
これはまずいです。
> @ IN SOA dns.example.com. root.dns.example.com.(
> 2000061012 28800 14400 3600000 86400)
> IN NS dns.example.com.

zone "example.com" としないとゾーンの情報がないというエラーになります。
それとも 2ch 用に書き換える際のミス?
0023FiveNGNG
ああ勘違い。

ゾーンの情報がないというエラーにはならないです。
単にドメイン名が dns.example.com になって www.dns.example.com とかでしか
アクセスできないだけです。エラーの原因は別ですねぇ。
00241ですNGNG
/etc/hosts
127.0.0.1 localhost localhost.localdomain
192.168.1.10 zzz.example.com zzz

111.222.333.444 dns.example.com dns mail
111.222.333.444 www.example.com www ftp
999.999.999.999 ocndns
---------- end
です。
emacsで編集しています
全角スペースは入っていないとおもいます。
えとemacsで入力するときに@`@`@`xxx locked by root@...(s.q.p.?
とでますが 関係ありますか?

1行にまとめましたが、エラーは変わりません
00251ですNGNG
なんかrootディレクトリに@`saves0999@`example.com~って
鬼のように(999〜12xx)ファイルできてます・・・
なんか私やったのかな・・;_;
002616ですNGNG
Fiveさん。どうかなぁ。よくわからなくなってきたゾ。
1さん、ご苦労だけど、もう一度DNS設定しなおしてみては??
取りあえず完璧にDNSを動作させましょう!!
上の内容から見ると DNS の設定は問題ないと思うけど?
topさんの内容をカット&ペーストして動かしてみたけど
(当然、変えるところは変えてね)
問題なく動いてるよ。 よくわかんないゾ
0027FiveNGNG
>25
それは Emacs が作成するバックアップファイルです。
消していいでしょう。
# 私は vi で編集。(^^; 客先に行ったときに Emacs ない場合も多いのよね・・。

あと、named.conf でゾーン名を "example.com" というか本当の名前に
なっているか確認してみましょう。先頭に "dns" がついていたら削除して
kill -HUP `cat /var/run/named.pid` で再起動して、messages に出てくる
エラーメッセージを教えてください。

>26
自分ももうよく分からないです。(^^;
何で動かないんでしょうねぇ。
00281ですNGNG
16さんありがとうございます。
もう一度、最初からやりなおしてみます。
できるまで ねないつもりです;;
00291ですNGNG
FIVEさん ありがとうございます
Kill -HUP〜
でもエラーメッセージはかわりません。
dns stop->startでも同じです。
とりあえず 全部けしてやりなおします 
0030>28NGNG
16です。
あー情熱感じるね。頑張って下さい!!
一生懸命ハマッて勉強して下さい。
そして、その技術を同じ問題で苦しんでいる人に教えてあげてね。
>1 君だったら大丈夫! きっと立ち上げることできるよ。
頑張れ!!

*取りあえず、見たまま素直にやってみよう!!
0031うひひNGNG
>1
しばらく週末恒例キャバクラの旅に出ていた。まだうまく行かないようだが
大先生が出てきたから、もう心配ないだろう。

OCNの設定ページを綺麗にコピーしてエディターで自動で編集して
入れると幸せになれるはず。

最初から最後まで絶対に手打ちスナよ消すコトは認めるが
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
編集置き換えコマンドで所定の部分を綺麗に換える
pdns.example.com---------uhihi.wahaha.co.jp
192.168.69.32/28---------210.68.22.58/28
という具合だ説明文もすべて含めて先頭行から一括変更かけて
プリントしてヨーク確認してな。

あとは部分的に切り分けて本来の所に置く。
このときコメントなんかは消してしまって良いよ
EUC-sjis問題も有ろうしな。

SOAのSerial番号と改行に注意する事。
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
君が思うより1行は長いからな表示が段違いなだけだからな

設定トラの巻き持ってるだろうから参照してな。
P.S.
面白く脚色できなかったのがポリシーに反する(ウヒヒ
00321ですNGNG
16さんありがとうございます!!!
うひひさん わかりました なるべくコピするようにします!

とりあえず、社長が眠そうでかわいそうだったので;]
家に帰ってきました リモートでなんとかするゾ!
0033KKNGNG
もう解決しているかもしてませんが、もし出来てなかったら
参考にしてください。
JFのページの解説が一番わかりやすいと思います。
http://www.linux.or.jp/JF/JFdocs/DNS-HOWTO.html
このページはコピーアンドペーストできるので、それを
自分の環境にして作ればきっとうまくいくと思います。

>nslookupでみるとはじめに
>Can't find server name for address 192.168.1.10とでます
>192.168.1.10で引いても同じエラーが出ます。
>グローバルとローカルIP両方とも引けません
>www.hoge.comは引けるのですが、、、

逆引きファイルが正しくないように思うのですが・・・・
ではがんばってください。


0034>1NGNG
16です。
解決しましたか?どこが悪かったのか、
もしわかったら僕にも教えて下さい。
00351ですNGNG
だめです・・
/var/log/messagesに
SOA ")" error(1)
Unknown type 84000).
等とでちゃいます。
そのあたりいろいろみてるんですけど・・・
00361ですNGNG
うちのPC、グラフィックカードがXに対応していないので
コピペはwindowsでコピしてftpしてます。
それもだめなのかな
00371ですNGNG
/var/log/messagesです

starting. named 8.2 Wed Mar 31 10:57:12 EST 1999 ^[email protected]:/usr/src/bs/BUILD/bind-8.2/src/bin/named
cache zone "" (IN) loaded (serial 0)
Zone "dns.example.co.jp" (file example.co.jp.zone): No default TTL set using SOA minimum instead
mail name "root.dns.example.co.jp.(2000061112.dns.example.co.jp" (owner "dns.example.co.jp") IN (primary) is invalid - rejecting
example.co.jp.zone:1: database naming error
example.co.jp.zone:1: Database error (bad name "root.dns.example.co.jp.(2000061112.dns.example.co.jp")
example.co.jp.zone:19: data "www.example.co.jp" outside zone "dns.example.co.jp" (ignored)
Zone "dns.example.co.jp" (file example.co.jp.zone): no SOA RR found
master zone "dns.example.co.jp" (IN) rejected due to errors (serial 0)
Zone "444.333.222.111.in-addr.arpa" (file 111.222.333.444.zone): No default TTL set using SOA minimum instead
mail name "root.dns.example.co.jp.(2000061112.444.333.222.111.in-addr.arpa" (owner "444.333.222.111.in-addr.arpa") IN (primary) is invalid - rejecting
111.222.333.444.zone:1: database naming error
111.222.333.444.zone:1: Database error (bad name "root.dns.example.co.jp.(2000061112.444.333.222.111.in-addr.arpa")
Zone "444.333.222.111.in-addr.arpa" (file 111.222.333.444.zone): no SOA RR found
master zone "444.333.222.111.in-addr.arpa" (IN) rejected due to errors (serial 0)
Zone "0.0.127.in-addr.arpa" (file named.local): No default TTL set using SOA minimum instead
mail name "root.dns.example.co.jp.(2000061112.0.0.127.in-addr.arpa" (owner "0.0.127.in-addr.arpa") IN (primary) is invalid - rejecting
named.local:1: database naming error
named.local:1: Database error (bad name "root.dns.example.co.jp.(2000061112.0.0.127.in-addr.arpa")
Zone "0.0.127.in-addr.arpa" (file named.local): no SOA RR found
master zone "0.0.127.in-addr.arpa" (IN) rejected due to errors (serial 0)
listening on [127.0.0.1].53 (lo)
listening on [local IP].53 (eth0)
Forwarding source address is [0.0.0.0].1027
lx named: named startup succeeded

お助けください・・
0038は、はいぃ?NGNG
えーとですね。
zoneファイルとrevファイル、それぞれ載せてください。

で、444.333.222.111 って実際その値設定してんですか?
それってドットのとこは1バイトなんで0〜255なんですけ
ど。ま、それはそれとして。
00391ですNGNG
設定完了しました
設定内容は上に載せているものと同じです
すべてコピーペーストで置き換えしたら
あっさり完了しました

以上報告まで みなさんありがとうございました
0040>1NGNG
16です。ひっとしてWinから移すときに CRコードが入ってたのでは・
それだったら、、、でもemacsで見るんだから気づくよね・・うーーん
よくわかりません。
でも、おめでとう!!
0041FiveNGNG
これ見て思ったこと。
> mail name "root.dns.example.co.jp.(2000061112.dns.example.co.jp" (owner "dns.example.co.jp") IN
> (primary) is invalid - rejecting
> mail name "root.dns.example.co.jp.(2000061112.444.333.222.111.in-addr.arpa" (owner
> "444.333.222.111.in-addr.arpa") IN (primary) is invalid - rejecting

ひょっとして、
@ IN SOA dns.example.co.jp. root.dns.example.co.jp.(
2000061012 ....
という風に、"(" の前にスペースがなかったんじゃないかな。
0042LatticeNGNG
>Fiveさん 16です
そろそろ"固定ハン"にしよう。
鋭いよねぇ。私もFiveさんの色々な書き込み見ていますが、よく勉強
なさってます。うちの会社の技術者に"爪の垢"を少し頂けますか?
いや、気づかなかった・・ 老兵去るのみ・・ 失礼しました。
■ このスレッドは過去ログ倉庫に格納されています