トップページ⇒tech
984コメント322KB

TOMCAT

■ このスレッドは過去ログ倉庫に格納されています
0001デフォルトの名無しさんNGNG
JavaServletを使いたいと思いTOMCATをインストール
しようと思ったんすけど、うまく動きません。ネットで
調べまくって手順も大丈夫なはずなんだけど。

環境
Win2000Pro、Tomcat3.2.3
自宅のWin98SEで同じようにやったら動いた。

Win2000では

C:\tomcat\bin>tomcat run
Including all jars in c:\tomcat\lib in your CLASSPATH.

Using CLASSPATH: c:\tomcat\classes;c:\tomcat\lib\ant.jar;c:\tomcat\lib\jasper.ja
r;c:\tomcat\lib\jaxp.jar;c:\tomcat\lib\parser.jar;c:\tomcat\lib\servlet.jar;c:\t
omcat\lib\webserver.jar;c:\tomcat\classes;c:\tomcat\lib\ant.jar;c:\tomcat\lib\ja
sper.jar;c:\tomcat\lib\jaxp.jar;c:\tomcat\lib\parser.jar;c:\tomcat\lib\servlet.j
ar;c:\tomcat\lib\webserver.jar;c:\tomcat\lib\servlet.jar;c:\jdk1.3\lib\tools.jar
;c:\jdk1.3\lib\tools.jar

Exception in thread "main" java.lang.NoSuchMethodError
at org.apache.tomcat.startup.Tomcat.getConfigFile(Tomcat.java:116)
at org.apache.tomcat.startup.Tomcat.execute(Tomcat.java:141)
at org.apache.tomcat.startup.Tomcat.main(Tomcat.java:163)
C:\tomcat\bin>

こういうエラーが出ます。パスもJAVA_HOME、TOMCAT_HOME通した。
クラスパスも通ってるはず。なでしょう?
0680_NGNG
http://homepage.mac.com/hiroyuki43/jaz09.html
0681直リンNGNG
http://homepage.mac.com/yuuka20/
0682デフォルトの名無しさんNGNG
>>679
docBase="hoge"
の部分を
絶対パスからにしてみてください

例
docBase="C:\AV\liblary\COCOLO\hoge"

ちなみに、「\」は「/」に変えたほうがいいんだったか?わすれた
0683675NGNG
>>682
やってみましたが、結果は同じNotFoundでした。
http://localhost:8080/hoge/ ではTomcatで正常に表示できるので
Apache側の設定の問題な気がしますが・・・
0684デフォルトの名無しさんNGNG
おれあんまり+Apache
ってやったことなかたんだけど
たしか、Apachの方でどこそこのURLのリクエストが来たら
このフォルダ見にいけよ(このばあい/hoge)
って言う指定必要なんじゃない?
examplesでもやったと思うけど・・・
0685デフォルトの名無しさんNGNG
>>683
Tomcat → Apapche の順番で起動しないとうまく連携出来ない罠があるが。
0686デフォルトの名無しさんNGNG
>>683
@IT ApacheとTomcatの連携
http://www.atmarkit.co.jp/fjava/rensai2/jspservlet03/jspsevlet03_5.html
0687デフォルトの名無しさんNGNG
アパプチェΣ(・∀・)
0688デフォルトの名無しさんNGNG
>>687
そんな細かい事に突っ込まない!
しかし、漏れと同じアフォが 286 件もあるぞ(w
http://www.google.com/search?q=Apapche&ie=UTF-8&oe=UTF-8&hl=ja&btnG=Google+%E6%A4%9C%E7%B4%A2&lr=
0689デフォルトの名無しさんNGNG
むかしさぁ
「びっくり日本新記録」
って言う番組でアパッチけんって言うタレントが
でてたが、あいつはそもそもなんだったんだ?
お笑い?俳優?
ちなみに、轟次郎はあの番組で素人で参加して
あの番組の常連になっていつのまにかタレント活動始めた
「記録・・・それは儚い・・・」
0690デフォルトの名無しさんNGNG
>>689
>でてたが、あいつはそもそもなんだったんだ?

Webサーバでつよ。
0691ごめんよNGNG
>>688さんにチョトワロタ(・∀・)
0692675NGNG
>>686
examplesは表示できるんです。
他のHP見てもexamplesを表示するところまでしか書いてないのがほとんど。

おまえら本当にApacheとTomcatでWebサーバ立ち上げてるのかと小一時間・・・
0693デフォルトの名無しさんNGNG
>>wokers2.propertiesに
>>[url:/hogehoge/*] を指定してあります。

[url:/hoge/*] じゃねーのかよ
0694675NGNG
原因がわかりました。

[url:/hogehoge/*]
~~~

首吊って以下略
0695デフォルトの名無しさんNGNG
>>675 >>692
>wokers2.propertiesに
>[url:/hogehoge/*] を指定してあります。

    ↑

[url:/hoge/*] の間違いか?
0696デフォルトの名無しさんNGNG
[url:/hoge/*]

だと思われ。
0697デフォルトの名無しさんNGNG
>>693-696

[uri:/hoge/*] だな。
  ^
0698デフォルトの名無しさんNGNG
>> 695-696

君も首吊って以下略
0699デフォルトの名無しさんNGNG
URI = Uniform Resource Identifier
http://www.iana.org/assignments/uri-schemes
0700デフォルトの名無しさんNGNG
>>693-696
それなりに判っている香具師が何人も見て見落としてしまう。
こういうのが本稼動後のバグになるわけや。
0701デフォルトの名無しさんNGNG
>>693 >>695 >>696
藻前らケコーン汁。
0702デフォルトの名無しさんNGNG
嫌じゃ!
0703デフォルトの名無しさんNGNG
win2000でTOMCATをバックグラウンドで走らせたいんですが
なぜか
コントロールパネルーサービスから起動すると
エラーがでしまうので、
start tomcatスクリプトからやっているんですけど、
こいつをバックグラウンドで動かす事ってできますかね?

というか、なんでエラーが・・・・
Tomcat/4.1.24-LE-jdk14
使ってるんですが・・・
0704デフォルトの名無しさんNGNG
ちなみに
JDKのバージョンは
1.4.1.3です

同じようにうまくいかなかった人は
ぜひ参考にしてください。

0705デフォルトの名無しさんNGNG
漏れもエラー出たことあるけど、その時のエラーメッセージが君のエラーメッセージと違うから多分関係ないな。
0706デフォルトの名無しさんNGNG
>>705
俺もあるぞ。でも同じエラーか解らんからな・・・。違うエラーだったら迷惑だろうしスレの無駄だしね。
0707デフォルトの名無しさんNGNG
>>704
そもそもエラーメッセージを載せない時点で×。
「同じようにうまくいかなかった人は」といっても同じようにうまくいかない
とはどのような状況なのかわかるはずもない。
しかも、Java2 SDK Standard Edition には1.4.1.3なんてバージョンはない。
0708デフォルトの名無しさんNGNG
>>703
既出だぞ。前のレスを探せ。
0709デフォルトの名無しさんNGNG
1.4.1.3=1.4.1.03
ならあるけど
0710デフォルトの名無しさんNGNG
>>703
>>539 見れ。
0711デフォルトの名無しさんNGNG
>>709
そんなのも無いぞ。
あるのは1.4.1_03
0712デフォルトの名無しさんNGNG
>711 みたいな サブイ 奴、職場に居ると扱いに困るよねぇ。あぁ、はいはい、みたいな。
0713デフォルトの名無しさんNGNG
HPってなんですか? ってタイプだな。
0714デフォルトの名無しさんNGNG
友達も少ないタイプだな。
0715デフォルトの名無しさんNGNG
>>713
プリンタとか作ってたけど最近はコンピュータばっかりだな。
0716デフォルトの名無しさんNGNG
>>715
HPは電子計測器メーカだったなり。
0717デフォルトの名無しさんNGNG
>>711
そんなものも無いぞ。
あるのは、J2SE v 1.4.1_03
0718デフォルトの名無しさんNGNG
>>716
ぼるきてぃさん、ありがとう。PC用語位です。
0719デフォルトの名無しさんNGNG
みんなであるないを論議しているのはこれか?
Java(TM) 2 Platform, Standard Edition (J2SE) v 1.4.1_03
http://java.sun.com/j2se/1.4.1/
0720デフォルトの名無しさんNGNG
>>719
女神様、漏れの論議しているのは金の。。(ry

ところで、Jakarta は NT Service でそのままでは実行出来ない
Tomcat 4.1.24 を何故リリースしたのだ?

つか、リリースノートに何か書いていたっけ?
0721デフォルトの名無しさんNGNG
あなたが池につき落としたのは
金のドラ猫ですか?
それとも銀のドラ猫ですか?
0722デフォルトの名無しさんNGNG
青いドラ猫です。
0723デフォルトの名無しさんNGNG
正直なあなたには
耳がリボンの小生意気な
黄色い猫をあげましょう。
0724デフォルトの名無しさんNGNG
(゚�听)
0725デフォルトの名無しさんNGNG
ドラミちゃんって小生意気なの?
0726デフォルトの名無しさんNGNG
Tomcat 4.1.24 が何で NT Service で動かないのか教えれ!
0727デフォルトの名無しさんNGNG
>>726
お前がバカだからでしょう。
0728デフォルトの名無しさんNGNG
>>727
ヴァカちゃいまんねん。アフォでんねん。
それはええから誰か教えるなり。
0729デフォルトの名無しさんNGNG
>>725
娘と映画を見に行ったら結構小生意気だったよ(w
0730デフォルトの名無しさんNGNG
>>725
超かわいい。ドラミちゃんとなら朝までヤれる
0731デフォルトの名無しさんNGNG
でもティムポつっこんだら感電しそうなんだが。
0732デフォルトの名無しさんNGNG
質問です。
例えば D:\tomcat\webapps\outside\test\index.jsp ってのがあります。
これのURLは http://localhost:8080/outside/test/index.jsp になるわけですが、
URLに http://localhost:8080/outside/ と入力すると、outsideフォルダのディレクトリ
一覧が表示されてしまいます。これを回避する方法はあるのでしょうか。
現在はoutsideフォルダにindex.htmlを置いて表示されないようにしていますが、
なんか裏技っぽいので…
0733デフォルトの名無しさんNGNG
>>732
confディレクトリのweb.xmlをよ〜く調べてみ。
とくに"DefaultServlet"あたりがキーワードかな。
それから、君の方法は裏技でもなんでもないよ。
ほかのファイル名がよかったら
<welcome-file-list>に追加しておけばよい
0734デフォルトの名無しさんNGNG
>>732
conf/web.xmlの下記の部分をコメントアウトすればいい
<servlet-mapping>
<servlet-name>default</servlet-name>
<url-pattern>/</url-pattern>
</servlet-mapping>
0735デフォルトの名無しさんNGNG
>>734
すいません。それやると http://localhost:8080/outside/test/index.jsp まで404に
なってしまいます。

>>733
734さんと言ってることは同じですよね?
index.htmlを置くのは普通の技なんですか…フォルダが多いと大変ですね…
0736735NGNG
<init-param>
 <param-name>listings</param-name>
 <param-value>false</param-value> ← ここをfalseにする。
</init-param>

出来ました。
0737デフォルトの名無しさんNGNG
Tomcat にゃ〜ぁぁご♪
      Jetty Jetty Jetty ちゅー♪
0738デフォルトの名無しさんNGNG
TOMCATはApacheと組合さないとJSPがうごかない
0739デフォルトの名無しさんNGNG
>>738
んなわけねえだろ
0740デフォルトの名無しさんNGNG
>>737
Tom and Jerry なんて誰も知らないと思われ。
0741デフォルトの名無しさんNGNG
>>738
○ ApacheはTOMCATと組合さないとJSPがうごかない
0742デフォルトの名無しさんNGNG
>>741
それも間違い。
○ ApacheはTOMCATと組み合わせるとJSPを動かすことができる。

Tomcatに限らないよ。WebLogicでもOracleASでもWebSphereでも
J2EE対応アプリサーバならたいていのものなら。
0743デフォルトの名無しさんNGNG
実は>>740が一番若い罠
0744740NGNG
>>743
んなアフォな。
0745デフォルトの名無しさんNGNG
トム&ジェリー知らないのなんか乳児くらいだろ
0746737NGNG
トム猫&ジェティーなんだが。。
0747デフォルトの名無しさんNGNG
新トムとジェリーでは仲が良くなってて物足りなかったな。

どうでもいいが、トムとジェリーといえば静岡だ。
あと、ルパン3世な。
0748デフォルトの名無しさんNGNG
Jetty って知名度低いんか?
0749デフォルトの名無しさんNGNG
オス猫がどうかしたのか?
0750デフォルトの名無しさんNGNG
TOM★CAT 4.1.18から5.0.2Alphaに移行したら、%@ include=でインクルードする
ファイルに書いている日本語が全部????になってしまいますた。
インクルードするファイルに%@ page pageEncoding="Shift_JIS"などを書くと
「pageEncoding属性を二度書いてはいけません」
というエラーになるし、これって4.1で治ったはずじゃないの?
0751デフォルトの名無しさんNGNG
このイカれた時代へようこそ!
0752デフォルトの名無しさんNGNG
>>750
リリース版じゃ無いから仕方ないっぺ。
0753デフォルトの名無しさんNGNG
>> 750
心配するな、俺も同じ状況になったよ
UTF-8でファイル書いたら直るのかな?わからんけど・・・
でも、include使うと文字化けって別にTomcat5.0だけの話じゃないよな
Tilesとかはどうやってんのかな・・・?
0754デフォルトの名無しさんNGNG
>750

呼び出し元にはpageEncoding属性を書かなければ
いいだけちゃうん?
0755デフォルトの名無しさんNGNG
>>754
いやいや、それやると今度は
呼び出し元が化けるんです
何度もハマッタので実証済み
0756デフォルトの名無しさんNGNG
メス猫いないのかな
0757デフォルトの名無しさんNGNG
適切なスレがなかったので、申し訳ありませんがここに書き込みさせていただきます。
webLogicについてなのですが、新しく修正したwarファイルをデプロイし、webLogicを再起動させるのですが、時々warファイルの変更が反映されないことがあります。
ブラウザの設定は問題ありません。
どうやらweblogic側でwarが上手く展開されてないみたいなのですが、warをデプロイして再起動するだけでは、warは展開されないのでしょうか?
スレ違いで申し訳ありません。
0758デフォルトの名無しさんNGNG
↑すみません。適切なスレがありました。
申し訳ありませんでした。
0759デフォルトの名無しさんNGNG
僕はJetty!一千年の未来からやってきた!流星号応答せよ、流星号!
Jetty〜 Jetty〜 SuperJetty〜♪
0760デフォルトの名無しさんNGNG
>>759
Jettyは起動が速くていいね。




でもスレ違い。
0761デフォルトの名無しさんNGNG
Jetty単体ってどこで手に入るの?
+JBossしか知らん
0762デフォルトの名無しさんNGNG
           _,ノ‐''''''^¨¨¨⌒ ̄⌒^^''¬-、,_
        ._v-''¨`.,,vー─-、    .,,vー─-、  .¨'ーu_
      _ノ'″  ./′    ¨┐ ./     ゙'┐   .゙'┐
     ,/′   ./       .ミ .i′      .)     ゙\
    ,/′     |     ● | } _●,     |      \
   ./′    ._,,、-ミ.    .  /¨レ       .人,_      ミ
  .,ノ′  ._ノ'″  \_   ._,rlト冖へy   _/  ¨'‐u     .゙lr
 .,i′  /ー-v、.,,_   ¨^^¨´〔    〕.¨^^¨′  __.,、 ゙\.    {
 〕   ./′    .⌒'''''    \,,,,,,ノ′  v-ー'''¨′   ゙┐   }    __________
 |   ノ  .────ー      }      __,,.,、v--ー''  {   .]  /
 |  :|        .__,..      .!      `        .}  .} <   俺も昔はTOMCAT ブイブイいわしとったで
 }  .|   .--:;:冖^ ̄       .|      ¨¨¨¨¨¨゙フ¨¨′ .}  }  \
 .|  .}    .\_         .}        ._/    }  .:|     ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄
  ). .〕      .゙ミzu,_      }      _,ノ┘      }  /
  .{  ).    .,/'″  ¨゙(ァv、,_  .!  ._,,,,v‐'^′       ,ノ  ノ
   ミ. 7,   .i゙      〔  `¨¨^^⌒           ,ノ′,/
   ゙). ゙li. _ノi.     ノ                 .,r′.,ノ
    \ ゙>'′^ー、、、v‐′               .,r′ /
     .|/      }                ./′,/

0763デフォルトの名無しさんNGNG
>>761
ここ
http://jetty.mortbay.org/jetty/index.html
0764デフォルトの名無しさんNGNG
ちょっと前にレジンとかいうやつも使ったことあったのだか
そのころじぶんに「
0765デフォルトの名無しさんNGNG
Forteをインストールして、JSPを勉強しようと思っているのですが、
デフォルトで入っているTomcatが動いてくれません。コンパイルは通るのですが、実行すると「プロセス
を作成できません、有効な外部ブラウザが設定されていない」と出てしまいます。何かWebブラウザの設定とか必要なのでしょうか?
環境はJDK1.4、Forteの3.0CEなんですが・・・。設定に関してはどのページにも、このような例はなく、
困っています。もし、よろしければ伝授お願いします。


0766デフォルトの名無しさんNGNG
>>765
3.0は詳しく知らないけど設定項目があるはずだ
おれは、何もわかんない状態から
ヘルプみて理解したけど・・・
Forteのヘルプ見れば載ってるはずだ
0767デフォルトの名無しさんNGNG
>>765
死ね糞マルチ。
0768765NGNG
>>766
ありがとうございます。ちょっと考えてみます。
0769デフォルトの名無しさんNGNG
>>768
そういうのは、考えるよりあちこちいじって探すほうが速いと思うよ。
ドキュメントを探すのが最優先だが。
0770767NGNG
>>769
なるほど。勉強になります。最悪、またインストールし直せばいいですしね。
頑張ってみます。
0771デフォルトの名無しさんNGNG
まあいじりまくって壊れたらまたインストールを何回もやれば覚えるだろう

壊れたループ(インストール)
0772デフォルトの名無しさんNGNG
catalinaって何?
0773デフォルトの名無しさんNGNG
http://www.h4.dion.ne.jp/~old55/
0774名無しさん@MonalipseNGNG
>>772
これのこと
http://www.246.ne.jp/~miti-230/Catalina.html
…だと思うが自信はない。飛行機って詳しくないから。
0775754NGNG
>>755

呼び出し元のファイルエンコードを合わせればいいんじゃない?
つまり、例をあげると
1:呼び出し元のソースをEUCで保存
2:呼び出し先にpageEncoding="euc-jp"

俺はこれで文字化け解消したけど。
0776デフォルトの名無しさんNGNG
   ∧ ∧ ∧ ∧ ∧ ∧ ∧
  ( (-( -( - ( -д( -д)
  (つ(つ/つ//  二つ
ハァ─) .| /( ヽノ  ノヽっ ─・・・
   ∪∪とノ(/ ̄ ∪


                ∧
 ((  (\_ ∧ ∧ ∧ ∧ Д)っ
   ⊂`ヽ( -д-) _)д-) )  ノノ
  ヽ ⊂\  ⊂ )  _つ
スゥ──(/( /∪∪ヽ)ヽ) ノ ──
      ∪ ̄(/ ̄\)


        ∧ ∧
       (σ・∀・)σ  777ゲッツ!!
        \  \
       /    \
       ∪ ̄ ̄ ̄\)
0777デフォルトの名無しさんNGNG
777
0778 NGNG
JkLogLevelってwarnがデフォルトなんだけどさぁ。
思いっきりdebugレベルでログ取ってる気がするの俺だけ?
0779デフォルトの名無しさんNGNG
OS : WinXP(HE)
Server : Apache 2.0.45
Tomcat : 4.1.24
上記設定で組み立てているのですが、うまく動きません。(涙)

Apache側にはコネクタ(mod_webapp)をmodulesに入れています。
単体でチェック("-t"オプション)を行うと、入れているにも関わらず
認識(mod_webapp.soが無い)してくれません。
Tomcat側にはserver.xmlのHTTPサーバー機能をコメントにしています。
チェック(Startup起動)を行うと、”スタンドアロン”は起動しますが
"Tomcat-Apache"は起動しません。
("Tomcat-Apache"のJK Runで止まって、起動のメッセージが出ない)

知っている方居られましたら、対策を教えて下さい。
お願いします。 m(__)m
■ このスレッドは過去ログ倉庫に格納されています