トップページ⇒tech
984コメント322KB

TOMCAT

■ このスレッドは過去ログ倉庫に格納されています
0001デフォルトの名無しさんNGNG
JavaServletを使いたいと思いTOMCATをインストール
しようと思ったんすけど、うまく動きません。ネットで
調べまくって手順も大丈夫なはずなんだけど。

環境
Win2000Pro、Tomcat3.2.3
自宅のWin98SEで同じようにやったら動いた。

Win2000では

C:\tomcat\bin>tomcat run
Including all jars in c:\tomcat\lib in your CLASSPATH.

Using CLASSPATH: c:\tomcat\classes;c:\tomcat\lib\ant.jar;c:\tomcat\lib\jasper.ja
r;c:\tomcat\lib\jaxp.jar;c:\tomcat\lib\parser.jar;c:\tomcat\lib\servlet.jar;c:\t
omcat\lib\webserver.jar;c:\tomcat\classes;c:\tomcat\lib\ant.jar;c:\tomcat\lib\ja
sper.jar;c:\tomcat\lib\jaxp.jar;c:\tomcat\lib\parser.jar;c:\tomcat\lib\servlet.j
ar;c:\tomcat\lib\webserver.jar;c:\tomcat\lib\servlet.jar;c:\jdk1.3\lib\tools.jar
;c:\jdk1.3\lib\tools.jar

Exception in thread "main" java.lang.NoSuchMethodError
at org.apache.tomcat.startup.Tomcat.getConfigFile(Tomcat.java:116)
at org.apache.tomcat.startup.Tomcat.execute(Tomcat.java:141)
at org.apache.tomcat.startup.Tomcat.main(Tomcat.java:163)
C:\tomcat\bin>

こういうエラーが出ます。パスもJAVA_HOME、TOMCAT_HOME通した。
クラスパスも通ってるはず。なでしょう?
0655デフォルトの名無しさんNGNG
>>654
ヘッダ(だだ流し)
表(アホみたいな処理量)
フッタ(だだ流し)

とかじゃないの?
0656デフォルトの名無しさんNGNG
バッファリング云々はブラウザから見た時の話なのだろうか。
だったら勘違い臭いが。
0657デフォルトの名無しさんNGNG
小児用バッファリング
0658デフォルトの名無しさんNGNG
>>655-656
表だと </table> タグが出てくるまで描画しないわーなぁ。
確かにカン違い臭いものが。。
0659デフォルトの名無しさんNGNG
たいていのブラウザでは<table>タグは全部読み込んでからレイアウト計算してその後に描画だからね
0660デフォルトの名無しさんNGNG
>もちろんtomcatがスタンドアロンの時は、無駄なバッファリング無く、即出力が始まります。
の意味が分からん。どう調べたらそういう結論になったのか。
0661653NGNG
叩かれてるよしょぼ〜ん。
htmlじゃなくて音声や動画とかを送ってるんで、サイズがでかいんです。

例えばサーブレットから1Gバイトぐらいあるデータを出力すると、
スタンドアロンの時は、出力した分を随時クライアントに送信してるので、
クライアントも即座に受信ができるのだが、

apacheとの接続の時は、出力が終わるまで鯖がグオーーっと言って
(apacheだかconnectorだかが出力終了までバッファリングしてるのだと思う)、
それからやっと出力が始まるということです。

response.flush()?だったかは試したんだが、無駄だった。
0662動画直リンNGNG
http://homepage.mac.com/hitomi18/
0663_NGNG
http://homepage.mac.com/hiroyuki43/jaz09.html
0664653NGNG
レス来たと思ったら業者かYO!しょぼぼぼ〜ん
0665デフォルトの名無しさんNGNG
>>661
デカイね。ストリーミングビデオか?
Apache 1.3に戻せばいいのでねぇの?
Apache 2.0 を使わないと逝けない理由でもあるのか。

WebSphereなんかのアプ鯖でも未だApache 1.3系でそ。
0666デフォルトの名無しさんNGNG
うむ、まあそれはごもっともなんだが・・・。
mod_cgi?はその点うまく処理してるんで、それを参考にconnector書き換えるかなあ・・・
0667デフォルトの名無しさんNGNG
このスレの1の問題点

1. 単発質問スレを立てる
2. スレタイがいい加減
3. なでしょう?
0668デフォルトの名無しさんNGNG
先週Ja-Jakarta BBSにも書いたのですが、解決しないのでこちらにも質問します。

Tomcat4.0.6を使用しています。
UserTransactionを使おうと思い、以下のようなコードを書き、実行しました。

InitialContext ctx = new InitialContext();
UserTransaction ut = (UserTransaction)ctx.lookup("java:comp/UserTransaction");

するとlookupしたところで以下のような例外が発生します。

TyrexTransactionFactory: Cannot create Transaction, Exception
java.lang.NoClassDefFoundError: org/omg/CosTransactions/Inactive
at tyrex.server.TransactionServer.createTransactionDomain(TransactionServer.java:200)

その下には以下のスタックトレースが出ています。

javax.naming.NamingException: Exception creating Transaction: org/omg/CosTransactions/Inactive
at org.apache.naming.factory.TyrexTransactionFactory.getObjectInstance(TyrexTransactionFactory.java:126)

これは何か特別な設定やライブラリが必要なのでしょうか。
ここを見ると特別な事は書いてないようです。
http://www.ingrid.org/jajakarta/tomcat/tomcat-4.0/webapps/tomcat-docs-ja/jndi-resources-howto.html#User%20Transactions

よろしくお願いします。
0669デフォルトの名無しさんNGNG
たかがロケンロール!
0670デフォルトの名無しさんNGNG
HP-UXでApacheと連携してTomcat使ってます。

catalina.policyに

grant <配備したWebAppのコードベース> {
java.sql.SQLPermission "setLog";
}

と記してあるのに、配備したWebAppのクラス内部で

java.sql.DriverManager.setLogStream(...);

を実行するとAccessControlExceptionが投げられてしまう理由が分かる方、います?

なんかcatalina.shに-Djava.security.debugつけて調べてみると、codebase指定したポリシーは全て無視されてしまっているようなんですが。
0671_NGNG
http://homepage.mac.com/hiroyuki43/2ch.html
0672デフォルトの名無しさんNGNG
age
0673デフォルトの名無しさんNGNG
>>661
リバースプロキシのキャッシュが利いてるんじゃないの?

レスポンスに
response.setHeader("Cache-Control", "no-cache");
response.setHeader("Pragma", "no-cache");
response.setDateHeader("Expires", 0);
を指定すると中継サーバでキャッシュしなくなるはずだけど、静的で大容量なら
2 回目以降は禿げしく無駄なトラフィックだしな。Apache のキャッシュ制御を
調べてみれば?
0674デフォルトの名無しさんNGNG
>>673
リバースプロキシは使ってないです。キャッシュされないようにしてみましたが、無駄ですた。

で、コネクタ使わずに、apacheのProxyPassReverse使ってtomcatに接続してみたけど、同じ状況でした。

う〜ん、tomcatに接続するcgi書いたら、行けるかなあ・・・
0675デフォルトの名無しさんNGNG
Win+apache2+tomcat4+jk2でexamplesが動くところまではできたのですが
独自にディレクトリを作成してそこのjspファイルの表示がうまくいきません。

wokers2.propertiesに
[url:/hogehoge/*] を指定してあります。

http://localhost:8080/hoge/ とやると表示できるのですが
http://localhost/hoge/ では連携がうまくいってないのか、Apache側で404エラーがでます。

何を指定すればいいのでしょうか?
0676デフォルトの名無しさんNGNG
>>675
Tomcatのserver.xml
0677デフォルトの名無しさんNGNG
>>675
apache、2は知らないが
Apache1ならhttpd.confにjk2使う旨記述
↓これを書き足す
LoadModule jk2_module dllの場所
0678デフォルトの名無しさんNGNG
男の子も女の子もオススメサイトです!
http://homepage3.nifty.com/coco-nut
0679デフォルトの名無しさんNGNG
>>676
server.xmlには、examplesを参考にして

<Context path="/hoge" docBase="hoge" debug="0"/>

と書き足してありますが、ここがまずいのでしょうか?
0680_NGNG
http://homepage.mac.com/hiroyuki43/jaz09.html
0681直リンNGNG
http://homepage.mac.com/yuuka20/
0682デフォルトの名無しさんNGNG
>>679
docBase="hoge"
の部分を
絶対パスからにしてみてください

例
docBase="C:\AV\liblary\COCOLO\hoge"

ちなみに、「\」は「/」に変えたほうがいいんだったか?わすれた
0683675NGNG
>>682
やってみましたが、結果は同じNotFoundでした。
http://localhost:8080/hoge/ ではTomcatで正常に表示できるので
Apache側の設定の問題な気がしますが・・・
0684デフォルトの名無しさんNGNG
おれあんまり+Apache
ってやったことなかたんだけど
たしか、Apachの方でどこそこのURLのリクエストが来たら
このフォルダ見にいけよ(このばあい/hoge)
って言う指定必要なんじゃない?
examplesでもやったと思うけど・・・
0685デフォルトの名無しさんNGNG
>>683
Tomcat → Apapche の順番で起動しないとうまく連携出来ない罠があるが。
0686デフォルトの名無しさんNGNG
>>683
@IT ApacheとTomcatの連携
http://www.atmarkit.co.jp/fjava/rensai2/jspservlet03/jspsevlet03_5.html
0687デフォルトの名無しさんNGNG
アパプチェΣ(・∀・)
0688デフォルトの名無しさんNGNG
>>687
そんな細かい事に突っ込まない!
しかし、漏れと同じアフォが 286 件もあるぞ(w
http://www.google.com/search?q=Apapche&ie=UTF-8&oe=UTF-8&hl=ja&btnG=Google+%E6%A4%9C%E7%B4%A2&lr=
0689デフォルトの名無しさんNGNG
むかしさぁ
「びっくり日本新記録」
って言う番組でアパッチけんって言うタレントが
でてたが、あいつはそもそもなんだったんだ?
お笑い?俳優?
ちなみに、轟次郎はあの番組で素人で参加して
あの番組の常連になっていつのまにかタレント活動始めた
「記録・・・それは儚い・・・」
0690デフォルトの名無しさんNGNG
>>689
>でてたが、あいつはそもそもなんだったんだ?

Webサーバでつよ。
0691ごめんよNGNG
>>688さんにチョトワロタ(・∀・)
0692675NGNG
>>686
examplesは表示できるんです。
他のHP見てもexamplesを表示するところまでしか書いてないのがほとんど。

おまえら本当にApacheとTomcatでWebサーバ立ち上げてるのかと小一時間・・・
0693デフォルトの名無しさんNGNG
>>wokers2.propertiesに
>>[url:/hogehoge/*] を指定してあります。

[url:/hoge/*] じゃねーのかよ
0694675NGNG
原因がわかりました。

[url:/hogehoge/*]
~~~

首吊って以下略
0695デフォルトの名無しさんNGNG
>>675 >>692
>wokers2.propertiesに
>[url:/hogehoge/*] を指定してあります。

    ↑

[url:/hoge/*] の間違いか?
0696デフォルトの名無しさんNGNG
[url:/hoge/*]

だと思われ。
0697デフォルトの名無しさんNGNG
>>693-696

[uri:/hoge/*] だな。
  ^
0698デフォルトの名無しさんNGNG
>> 695-696

君も首吊って以下略
0699デフォルトの名無しさんNGNG
URI = Uniform Resource Identifier
http://www.iana.org/assignments/uri-schemes
0700デフォルトの名無しさんNGNG
>>693-696
それなりに判っている香具師が何人も見て見落としてしまう。
こういうのが本稼動後のバグになるわけや。
0701デフォルトの名無しさんNGNG
>>693 >>695 >>696
藻前らケコーン汁。
0702デフォルトの名無しさんNGNG
嫌じゃ!
0703デフォルトの名無しさんNGNG
win2000でTOMCATをバックグラウンドで走らせたいんですが
なぜか
コントロールパネルーサービスから起動すると
エラーがでしまうので、
start tomcatスクリプトからやっているんですけど、
こいつをバックグラウンドで動かす事ってできますかね?

というか、なんでエラーが・・・・
Tomcat/4.1.24-LE-jdk14
使ってるんですが・・・
0704デフォルトの名無しさんNGNG
ちなみに
JDKのバージョンは
1.4.1.3です

同じようにうまくいかなかった人は
ぜひ参考にしてください。

0705デフォルトの名無しさんNGNG
漏れもエラー出たことあるけど、その時のエラーメッセージが君のエラーメッセージと違うから多分関係ないな。
0706デフォルトの名無しさんNGNG
>>705
俺もあるぞ。でも同じエラーか解らんからな・・・。違うエラーだったら迷惑だろうしスレの無駄だしね。
0707デフォルトの名無しさんNGNG
>>704
そもそもエラーメッセージを載せない時点で×。
「同じようにうまくいかなかった人は」といっても同じようにうまくいかない
とはどのような状況なのかわかるはずもない。
しかも、Java2 SDK Standard Edition には1.4.1.3なんてバージョンはない。
0708デフォルトの名無しさんNGNG
>>703
既出だぞ。前のレスを探せ。
0709デフォルトの名無しさんNGNG
1.4.1.3=1.4.1.03
ならあるけど
0710デフォルトの名無しさんNGNG
>>703
>>539 見れ。
0711デフォルトの名無しさんNGNG
>>709
そんなのも無いぞ。
あるのは1.4.1_03
0712デフォルトの名無しさんNGNG
>711 みたいな サブイ 奴、職場に居ると扱いに困るよねぇ。あぁ、はいはい、みたいな。
0713デフォルトの名無しさんNGNG
HPってなんですか? ってタイプだな。
0714デフォルトの名無しさんNGNG
友達も少ないタイプだな。
0715デフォルトの名無しさんNGNG
>>713
プリンタとか作ってたけど最近はコンピュータばっかりだな。
0716デフォルトの名無しさんNGNG
>>715
HPは電子計測器メーカだったなり。
0717デフォルトの名無しさんNGNG
>>711
そんなものも無いぞ。
あるのは、J2SE v 1.4.1_03
0718デフォルトの名無しさんNGNG
>>716
ぼるきてぃさん、ありがとう。PC用語位です。
0719デフォルトの名無しさんNGNG
みんなであるないを論議しているのはこれか?
Java(TM) 2 Platform, Standard Edition (J2SE) v 1.4.1_03
http://java.sun.com/j2se/1.4.1/
0720デフォルトの名無しさんNGNG
>>719
女神様、漏れの論議しているのは金の。。(ry

ところで、Jakarta は NT Service でそのままでは実行出来ない
Tomcat 4.1.24 を何故リリースしたのだ?

つか、リリースノートに何か書いていたっけ?
0721デフォルトの名無しさんNGNG
あなたが池につき落としたのは
金のドラ猫ですか?
それとも銀のドラ猫ですか?
0722デフォルトの名無しさんNGNG
青いドラ猫です。
0723デフォルトの名無しさんNGNG
正直なあなたには
耳がリボンの小生意気な
黄色い猫をあげましょう。
0724デフォルトの名無しさんNGNG
(゚�听)
0725デフォルトの名無しさんNGNG
ドラミちゃんって小生意気なの?
0726デフォルトの名無しさんNGNG
Tomcat 4.1.24 が何で NT Service で動かないのか教えれ!
0727デフォルトの名無しさんNGNG
>>726
お前がバカだからでしょう。
0728デフォルトの名無しさんNGNG
>>727
ヴァカちゃいまんねん。アフォでんねん。
それはええから誰か教えるなり。
0729デフォルトの名無しさんNGNG
>>725
娘と映画を見に行ったら結構小生意気だったよ(w
0730デフォルトの名無しさんNGNG
>>725
超かわいい。ドラミちゃんとなら朝までヤれる
0731デフォルトの名無しさんNGNG
でもティムポつっこんだら感電しそうなんだが。
0732デフォルトの名無しさんNGNG
質問です。
例えば D:\tomcat\webapps\outside\test\index.jsp ってのがあります。
これのURLは http://localhost:8080/outside/test/index.jsp になるわけですが、
URLに http://localhost:8080/outside/ と入力すると、outsideフォルダのディレクトリ
一覧が表示されてしまいます。これを回避する方法はあるのでしょうか。
現在はoutsideフォルダにindex.htmlを置いて表示されないようにしていますが、
なんか裏技っぽいので…
0733デフォルトの名無しさんNGNG
>>732
confディレクトリのweb.xmlをよ〜く調べてみ。
とくに"DefaultServlet"あたりがキーワードかな。
それから、君の方法は裏技でもなんでもないよ。
ほかのファイル名がよかったら
<welcome-file-list>に追加しておけばよい
0734デフォルトの名無しさんNGNG
>>732
conf/web.xmlの下記の部分をコメントアウトすればいい
<servlet-mapping>
<servlet-name>default</servlet-name>
<url-pattern>/</url-pattern>
</servlet-mapping>
0735デフォルトの名無しさんNGNG
>>734
すいません。それやると http://localhost:8080/outside/test/index.jsp まで404に
なってしまいます。

>>733
734さんと言ってることは同じですよね?
index.htmlを置くのは普通の技なんですか…フォルダが多いと大変ですね…
0736735NGNG
<init-param>
 <param-name>listings</param-name>
 <param-value>false</param-value> ← ここをfalseにする。
</init-param>

出来ました。
0737デフォルトの名無しさんNGNG
Tomcat にゃ〜ぁぁご♪
      Jetty Jetty Jetty ちゅー♪
0738デフォルトの名無しさんNGNG
TOMCATはApacheと組合さないとJSPがうごかない
0739デフォルトの名無しさんNGNG
>>738
んなわけねえだろ
0740デフォルトの名無しさんNGNG
>>737
Tom and Jerry なんて誰も知らないと思われ。
0741デフォルトの名無しさんNGNG
>>738
○ ApacheはTOMCATと組合さないとJSPがうごかない
0742デフォルトの名無しさんNGNG
>>741
それも間違い。
○ ApacheはTOMCATと組み合わせるとJSPを動かすことができる。

Tomcatに限らないよ。WebLogicでもOracleASでもWebSphereでも
J2EE対応アプリサーバならたいていのものなら。
0743デフォルトの名無しさんNGNG
実は>>740が一番若い罠
0744740NGNG
>>743
んなアフォな。
0745デフォルトの名無しさんNGNG
トム&ジェリー知らないのなんか乳児くらいだろ
0746737NGNG
トム猫&ジェティーなんだが。。
0747デフォルトの名無しさんNGNG
新トムとジェリーでは仲が良くなってて物足りなかったな。

どうでもいいが、トムとジェリーといえば静岡だ。
あと、ルパン3世な。
0748デフォルトの名無しさんNGNG
Jetty って知名度低いんか?
0749デフォルトの名無しさんNGNG
オス猫がどうかしたのか?
0750デフォルトの名無しさんNGNG
TOM★CAT 4.1.18から5.0.2Alphaに移行したら、%@ include=でインクルードする
ファイルに書いている日本語が全部????になってしまいますた。
インクルードするファイルに%@ page pageEncoding="Shift_JIS"などを書くと
「pageEncoding属性を二度書いてはいけません」
というエラーになるし、これって4.1で治ったはずじゃないの?
0751デフォルトの名無しさんNGNG
このイカれた時代へようこそ!
0752デフォルトの名無しさんNGNG
>>750
リリース版じゃ無いから仕方ないっぺ。
0753デフォルトの名無しさんNGNG
>> 750
心配するな、俺も同じ状況になったよ
UTF-8でファイル書いたら直るのかな?わからんけど・・・
でも、include使うと文字化けって別にTomcat5.0だけの話じゃないよな
Tilesとかはどうやってんのかな・・・?
0754デフォルトの名無しさんNGNG
>750

呼び出し元にはpageEncoding属性を書かなければ
いいだけちゃうん?
■ このスレッドは過去ログ倉庫に格納されています