TOMCAT
■ このスレッドは過去ログ倉庫に格納されています
0001デフォルトの名無しさん
NGNGしようと思ったんすけど、うまく動きません。ネットで
調べまくって手順も大丈夫なはずなんだけど。
環境
Win2000Pro、Tomcat3.2.3
自宅のWin98SEで同じようにやったら動いた。
Win2000では
C:\tomcat\bin>tomcat run
Including all jars in c:\tomcat\lib in your CLASSPATH.
Using CLASSPATH: c:\tomcat\classes;c:\tomcat\lib\ant.jar;c:\tomcat\lib\jasper.ja
r;c:\tomcat\lib\jaxp.jar;c:\tomcat\lib\parser.jar;c:\tomcat\lib\servlet.jar;c:\t
omcat\lib\webserver.jar;c:\tomcat\classes;c:\tomcat\lib\ant.jar;c:\tomcat\lib\ja
sper.jar;c:\tomcat\lib\jaxp.jar;c:\tomcat\lib\parser.jar;c:\tomcat\lib\servlet.j
ar;c:\tomcat\lib\webserver.jar;c:\tomcat\lib\servlet.jar;c:\jdk1.3\lib\tools.jar
;c:\jdk1.3\lib\tools.jar
Exception in thread "main" java.lang.NoSuchMethodError
at org.apache.tomcat.startup.Tomcat.getConfigFile(Tomcat.java:116)
at org.apache.tomcat.startup.Tomcat.execute(Tomcat.java:141)
at org.apache.tomcat.startup.Tomcat.main(Tomcat.java:163)
C:\tomcat\bin>
こういうエラーが出ます。パスもJAVA_HOME、TOMCAT_HOME通した。
クラスパスも通ってるはず。なでしょう?
0653デフォルトの名無しさん
NGNGtomcatの出力が完了するまで応答が帰ってこなくて、
大きいデータを出力するとき困ってるんだけど、何とかならないの?
connectorはjk2とwebapp試しましたがダメでした。
もちろんtomcatがスタンドアロンの時は、無駄なバッファリング無く、即出力が始まります。
むかしapache1でwebappのときはいけてたんだけどねえ。
0654デフォルトの名無しさん
NGNGバッファリングが問題になるほど大きなHTMLって何?
0655デフォルトの名無しさん
NGNGヘッダ(だだ流し)
表(アホみたいな処理量)
フッタ(だだ流し)
とかじゃないの?
0656デフォルトの名無しさん
NGNGだったら勘違い臭いが。
0657デフォルトの名無しさん
NGNG0658デフォルトの名無しさん
NGNG表だと </table> タグが出てくるまで描画しないわーなぁ。
確かにカン違い臭いものが。。
0659デフォルトの名無しさん
NGNG0660デフォルトの名無しさん
NGNGの意味が分からん。どう調べたらそういう結論になったのか。
0661653
NGNGhtmlじゃなくて音声や動画とかを送ってるんで、サイズがでかいんです。
例えばサーブレットから1Gバイトぐらいあるデータを出力すると、
スタンドアロンの時は、出力した分を随時クライアントに送信してるので、
クライアントも即座に受信ができるのだが、
apacheとの接続の時は、出力が終わるまで鯖がグオーーっと言って
(apacheだかconnectorだかが出力終了までバッファリングしてるのだと思う)、
それからやっと出力が始まるということです。
response.flush()?だったかは試したんだが、無駄だった。
0662動画直リン
NGNG0664653
NGNG0665デフォルトの名無しさん
NGNGデカイね。ストリーミングビデオか?
Apache 1.3に戻せばいいのでねぇの?
Apache 2.0 を使わないと逝けない理由でもあるのか。
WebSphereなんかのアプ鯖でも未だApache 1.3系でそ。
0666デフォルトの名無しさん
NGNGmod_cgi?はその点うまく処理してるんで、それを参考にconnector書き換えるかなあ・・・
0667デフォルトの名無しさん
NGNG1. 単発質問スレを立てる
2. スレタイがいい加減
3. なでしょう?
0668デフォルトの名無しさん
NGNGTomcat4.0.6を使用しています。
UserTransactionを使おうと思い、以下のようなコードを書き、実行しました。
InitialContext ctx = new InitialContext();
UserTransaction ut = (UserTransaction)ctx.lookup("java:comp/UserTransaction");
するとlookupしたところで以下のような例外が発生します。
TyrexTransactionFactory: Cannot create Transaction, Exception
java.lang.NoClassDefFoundError: org/omg/CosTransactions/Inactive
at tyrex.server.TransactionServer.createTransactionDomain(TransactionServer.java:200)
その下には以下のスタックトレースが出ています。
javax.naming.NamingException: Exception creating Transaction: org/omg/CosTransactions/Inactive
at org.apache.naming.factory.TyrexTransactionFactory.getObjectInstance(TyrexTransactionFactory.java:126)
これは何か特別な設定やライブラリが必要なのでしょうか。
ここを見ると特別な事は書いてないようです。
http://www.ingrid.org/jajakarta/tomcat/tomcat-4.0/webapps/tomcat-docs-ja/jndi-resources-howto.html#User%20Transactions
よろしくお願いします。
0669デフォルトの名無しさん
NGNG0670デフォルトの名無しさん
NGNGcatalina.policyに
grant <配備したWebAppのコードベース> {
java.sql.SQLPermission "setLog";
}
と記してあるのに、配備したWebAppのクラス内部で
java.sql.DriverManager.setLogStream(...);
を実行するとAccessControlExceptionが投げられてしまう理由が分かる方、います?
なんかcatalina.shに-Djava.security.debugつけて調べてみると、codebase指定したポリシーは全て無視されてしまっているようなんですが。
0672デフォルトの名無しさん
NGNG0673デフォルトの名無しさん
NGNGリバースプロキシのキャッシュが利いてるんじゃないの?
レスポンスに
response.setHeader("Cache-Control", "no-cache");
response.setHeader("Pragma", "no-cache");
response.setDateHeader("Expires", 0);
を指定すると中継サーバでキャッシュしなくなるはずだけど、静的で大容量なら
2 回目以降は禿げしく無駄なトラフィックだしな。Apache のキャッシュ制御を
調べてみれば?
0674デフォルトの名無しさん
NGNGリバースプロキシは使ってないです。キャッシュされないようにしてみましたが、無駄ですた。
で、コネクタ使わずに、apacheのProxyPassReverse使ってtomcatに接続してみたけど、同じ状況でした。
う〜ん、tomcatに接続するcgi書いたら、行けるかなあ・・・
0675デフォルトの名無しさん
NGNG独自にディレクトリを作成してそこのjspファイルの表示がうまくいきません。
wokers2.propertiesに
[url:/hogehoge/*] を指定してあります。
http://localhost:8080/hoge/ とやると表示できるのですが
http://localhost/hoge/ では連携がうまくいってないのか、Apache側で404エラーがでます。
何を指定すればいいのでしょうか?
0676デフォルトの名無しさん
NGNGTomcatのserver.xml
0677デフォルトの名無しさん
NGNGapache、2は知らないが
Apache1ならhttpd.confにjk2使う旨記述
↓これを書き足す
LoadModule jk2_module dllの場所
0678デフォルトの名無しさん
NGNGhttp://homepage3.nifty.com/coco-nut
0679デフォルトの名無しさん
NGNGserver.xmlには、examplesを参考にして
<Context path="/hoge" docBase="hoge" debug="0"/>
と書き足してありますが、ここがまずいのでしょうか?
0681直リン
NGNG0682デフォルトの名無しさん
NGNGdocBase="hoge"
の部分を
絶対パスからにしてみてください
例
docBase="C:\AV\liblary\COCOLO\hoge"
ちなみに、「\」は「/」に変えたほうがいいんだったか?わすれた
0683675
NGNGやってみましたが、結果は同じNotFoundでした。
http://localhost:8080/hoge/ ではTomcatで正常に表示できるので
Apache側の設定の問題な気がしますが・・・
0684デフォルトの名無しさん
NGNGってやったことなかたんだけど
たしか、Apachの方でどこそこのURLのリクエストが来たら
このフォルダ見にいけよ(このばあい/hoge)
って言う指定必要なんじゃない?
examplesでもやったと思うけど・・・
0685デフォルトの名無しさん
NGNGTomcat → Apapche の順番で起動しないとうまく連携出来ない罠があるが。
0686デフォルトの名無しさん
NGNG@IT ApacheとTomcatの連携
http://www.atmarkit.co.jp/fjava/rensai2/jspservlet03/jspsevlet03_5.html
0687デフォルトの名無しさん
NGNG0688デフォルトの名無しさん
NGNGそんな細かい事に突っ込まない!
しかし、漏れと同じアフォが 286 件もあるぞ(w
http://www.google.com/search?q=Apapche&ie=UTF-8&oe=UTF-8&hl=ja&btnG=Google+%E6%A4%9C%E7%B4%A2&lr=
0689デフォルトの名無しさん
NGNG「びっくり日本新記録」
って言う番組でアパッチけんって言うタレントが
でてたが、あいつはそもそもなんだったんだ?
お笑い?俳優?
ちなみに、轟次郎はあの番組で素人で参加して
あの番組の常連になっていつのまにかタレント活動始めた
「記録・・・それは儚い・・・」
0690デフォルトの名無しさん
NGNG>でてたが、あいつはそもそもなんだったんだ?
Webサーバでつよ。
0692675
NGNGexamplesは表示できるんです。
他のHP見てもexamplesを表示するところまでしか書いてないのがほとんど。
おまえら本当にApacheとTomcatでWebサーバ立ち上げてるのかと小一時間・・・
0693デフォルトの名無しさん
NGNG>>[url:/hogehoge/*] を指定してあります。
[url:/hoge/*] じゃねーのかよ
0694675
NGNG[url:/hogehoge/*]
~~~
首吊って以下略
0695デフォルトの名無しさん
NGNG>wokers2.propertiesに
>[url:/hogehoge/*] を指定してあります。
↑
[url:/hoge/*] の間違いか?
0696デフォルトの名無しさん
NGNGだと思われ。
0697デフォルトの名無しさん
NGNG[uri:/hoge/*] だな。
^
0698デフォルトの名無しさん
NGNG君も首吊って以下略
0699デフォルトの名無しさん
NGNGhttp://www.iana.org/assignments/uri-schemes
0700デフォルトの名無しさん
NGNGそれなりに判っている香具師が何人も見て見落としてしまう。
こういうのが本稼動後のバグになるわけや。
0701デフォルトの名無しさん
NGNG藻前らケコーン汁。
0702デフォルトの名無しさん
NGNG0703デフォルトの名無しさん
NGNGなぜか
コントロールパネルーサービスから起動すると
エラーがでしまうので、
start tomcatスクリプトからやっているんですけど、
こいつをバックグラウンドで動かす事ってできますかね?
というか、なんでエラーが・・・・
Tomcat/4.1.24-LE-jdk14
使ってるんですが・・・
0704デフォルトの名無しさん
NGNGJDKのバージョンは
1.4.1.3です
同じようにうまくいかなかった人は
ぜひ参考にしてください。
0705デフォルトの名無しさん
NGNG0706デフォルトの名無しさん
NGNG俺もあるぞ。でも同じエラーか解らんからな・・・。違うエラーだったら迷惑だろうしスレの無駄だしね。
0707デフォルトの名無しさん
NGNGそもそもエラーメッセージを載せない時点で×。
「同じようにうまくいかなかった人は」といっても同じようにうまくいかない
とはどのような状況なのかわかるはずもない。
しかも、Java2 SDK Standard Edition には1.4.1.3なんてバージョンはない。
0708デフォルトの名無しさん
NGNG既出だぞ。前のレスを探せ。
0709デフォルトの名無しさん
NGNGならあるけど
0710デフォルトの名無しさん
NGNG>>539 見れ。
0711デフォルトの名無しさん
NGNGそんなのも無いぞ。
あるのは1.4.1_03
0712デフォルトの名無しさん
NGNG0713デフォルトの名無しさん
NGNG0714デフォルトの名無しさん
NGNG0715デフォルトの名無しさん
NGNGプリンタとか作ってたけど最近はコンピュータばっかりだな。
0716デフォルトの名無しさん
NGNGHPは電子計測器メーカだったなり。
0717デフォルトの名無しさん
NGNGそんなものも無いぞ。
あるのは、J2SE v 1.4.1_03
0718デフォルトの名無しさん
NGNGぼるきてぃさん、ありがとう。PC用語位です。
0719デフォルトの名無しさん
NGNGJava(TM) 2 Platform, Standard Edition (J2SE) v 1.4.1_03
http://java.sun.com/j2se/1.4.1/
0720デフォルトの名無しさん
NGNG女神様、漏れの論議しているのは金の。。(ry
ところで、Jakarta は NT Service でそのままでは実行出来ない
Tomcat 4.1.24 を何故リリースしたのだ?
つか、リリースノートに何か書いていたっけ?
0721デフォルトの名無しさん
NGNG金のドラ猫ですか?
それとも銀のドラ猫ですか?
0722デフォルトの名無しさん
NGNG0723デフォルトの名無しさん
NGNG耳がリボンの小生意気な
黄色い猫をあげましょう。
0724デフォルトの名無しさん
NGNG0725デフォルトの名無しさん
NGNG0726デフォルトの名無しさん
NGNG0727デフォルトの名無しさん
NGNGお前がバカだからでしょう。
0728デフォルトの名無しさん
NGNGヴァカちゃいまんねん。アフォでんねん。
それはええから誰か教えるなり。
0729デフォルトの名無しさん
NGNG娘と映画を見に行ったら結構小生意気だったよ(w
0730デフォルトの名無しさん
NGNG超かわいい。ドラミちゃんとなら朝までヤれる
0731デフォルトの名無しさん
NGNG0732デフォルトの名無しさん
NGNG例えば D:\tomcat\webapps\outside\test\index.jsp ってのがあります。
これのURLは http://localhost:8080/outside/test/index.jsp になるわけですが、
URLに http://localhost:8080/outside/ と入力すると、outsideフォルダのディレクトリ
一覧が表示されてしまいます。これを回避する方法はあるのでしょうか。
現在はoutsideフォルダにindex.htmlを置いて表示されないようにしていますが、
なんか裏技っぽいので…
0733デフォルトの名無しさん
NGNGconfディレクトリのweb.xmlをよ〜く調べてみ。
とくに"DefaultServlet"あたりがキーワードかな。
それから、君の方法は裏技でもなんでもないよ。
ほかのファイル名がよかったら
<welcome-file-list>に追加しておけばよい
0734デフォルトの名無しさん
NGNGconf/web.xmlの下記の部分をコメントアウトすればいい
<servlet-mapping>
<servlet-name>default</servlet-name>
<url-pattern>/</url-pattern>
</servlet-mapping>
0735デフォルトの名無しさん
NGNGすいません。それやると http://localhost:8080/outside/test/index.jsp まで404に
なってしまいます。
>>733
734さんと言ってることは同じですよね?
index.htmlを置くのは普通の技なんですか…フォルダが多いと大変ですね…
0736735
NGNG<param-name>listings</param-name>
<param-value>false</param-value> ← ここをfalseにする。
</init-param>
出来ました。
0737デフォルトの名無しさん
NGNGJetty Jetty Jetty ちゅー♪
0738デフォルトの名無しさん
NGNG0739デフォルトの名無しさん
NGNGんなわけねえだろ
0740デフォルトの名無しさん
NGNGTom and Jerry なんて誰も知らないと思われ。
0741デフォルトの名無しさん
NGNG○ ApacheはTOMCATと組合さないとJSPがうごかない
0742デフォルトの名無しさん
NGNGそれも間違い。
○ ApacheはTOMCATと組み合わせるとJSPを動かすことができる。
Tomcatに限らないよ。WebLogicでもOracleASでもWebSphereでも
J2EE対応アプリサーバならたいていのものなら。
0743デフォルトの名無しさん
NGNG0745デフォルトの名無しさん
NGNG0746737
NGNG0747デフォルトの名無しさん
NGNGどうでもいいが、トムとジェリーといえば静岡だ。
あと、ルパン3世な。
0748デフォルトの名無しさん
NGNG0749デフォルトの名無しさん
NGNG0750デフォルトの名無しさん
NGNGファイルに書いている日本語が全部????になってしまいますた。
インクルードするファイルに%@ page pageEncoding="Shift_JIS"などを書くと
「pageEncoding属性を二度書いてはいけません」
というエラーになるし、これって4.1で治ったはずじゃないの?
0751デフォルトの名無しさん
NGNG0752デフォルトの名無しさん
NGNGリリース版じゃ無いから仕方ないっぺ。
■ このスレッドは過去ログ倉庫に格納されています