TOMCAT
■ このスレッドは過去ログ倉庫に格納されています
0603デフォルトの名無しさん
NGNGWin2kで、Apache + perlを動かしているところへ、Tomcatも入れて
mod_jk2でApache+Tomcatの連携ができました。
たとえばhttp://localhost/examples/ でディレクトリ一覧が表示されるようになりました。
ここまではいいんですが、http://localhost/examples/jsp/index.html を
表示させようとしたらエラーになりました。
調べたところ、Apacheのhttpd.confの以下の部分が原因だと判明しました。
AddHandler server-parsed .html (ScriptAliasの設定のすぐ下に記述してあります)
これを消すと、問題なくApacheとTomcatの連携ができます(Tomcat側のhtmlが表示されるようになる)。
しかし、ScriptAlias内のhtmlが表示できなくなってしまいます(たとえば/cgi-bin/index.html などが表示できなくなる)。
これを残すと、逆の状態(/cgi-bin/index.html は表示できてTomcat側のhtmlが表示できない)
perlとTomcatの共存はできるのでしょうか?
できないならできないで諦めますし、もし解決策があれば教えていただきたいのですが
■ このスレッドは過去ログ倉庫に格納されています