トップページ⇒tech
984コメント322KB

TOMCAT

■ このスレッドは過去ログ倉庫に格納されています
0001デフォルトの名無しさんNGNG
JavaServletを使いたいと思いTOMCATをインストール
しようと思ったんすけど、うまく動きません。ネットで
調べまくって手順も大丈夫なはずなんだけど。

環境
Win2000Pro、Tomcat3.2.3
自宅のWin98SEで同じようにやったら動いた。

Win2000では

C:\tomcat\bin>tomcat run
Including all jars in c:\tomcat\lib in your CLASSPATH.

Using CLASSPATH: c:\tomcat\classes;c:\tomcat\lib\ant.jar;c:\tomcat\lib\jasper.ja
r;c:\tomcat\lib\jaxp.jar;c:\tomcat\lib\parser.jar;c:\tomcat\lib\servlet.jar;c:\t
omcat\lib\webserver.jar;c:\tomcat\classes;c:\tomcat\lib\ant.jar;c:\tomcat\lib\ja
sper.jar;c:\tomcat\lib\jaxp.jar;c:\tomcat\lib\parser.jar;c:\tomcat\lib\servlet.j
ar;c:\tomcat\lib\webserver.jar;c:\tomcat\lib\servlet.jar;c:\jdk1.3\lib\tools.jar
;c:\jdk1.3\lib\tools.jar

Exception in thread "main" java.lang.NoSuchMethodError
at org.apache.tomcat.startup.Tomcat.getConfigFile(Tomcat.java:116)
at org.apache.tomcat.startup.Tomcat.execute(Tomcat.java:141)
at org.apache.tomcat.startup.Tomcat.main(Tomcat.java:163)
C:\tomcat\bin>

こういうエラーが出ます。パスもJAVA_HOME、TOMCAT_HOME通した。
クラスパスも通ってるはず。なでしょう?
0451441NGNG
>>443
それも、TOMCATのserver.xmlで
Welcomeファイルの設定すればいいんでないの?
これとじゃダメ?
0452デフォルトの名無しさんNGNG
>>450
だからJSPに直接アクセスするようなつくりになっていないんだよ。
サーブレットからフォワードしてもらわないと動作しないJSPならば、
見えるところにおく必要はないから隠したいと。
strutsとかそうじゃない?
0453444NGNG
オレノも解決しておくれ
0454デフォルトの名無しさんNGNG
>>444
見れないっていうのは
エラーになるってこと?
それとも別のページに行くの?
0455431NGNG
>>452
正解。
Strutsを使わないのであれば、まあ意識する必要のないコトです。
0456デフォルトの名無しさんNGNG
★やっと見つけちゃった★ココだ★ココだ★
http://bbs.1oku.com/bbs/bbs.phtml?id=rantyan
0457443NGNG
>>451
うーん..
例えば、IISとかならディレクトリの参照権限を設定できるじゃないですか・・
そんな感じで参照権限の設定項目とかあれば嬉しいのですが。。
0458デフォルトの名無しさんNGNG
属性ってこと?
それはOSのほうでやるんじゃないの?
まあ、おれもさっぱりわからんので誰かヨロ
0459デフォルトの名無しさんNGNG
Redhat7.3+JDK1.4.0_03+Tomcat 4.1.18で
携帯電話向けのコンテンツ作ろうとしてるんだけど、
何か参考資料ない?

POSTされた機種依存文字やimodeの絵文字を表示しようとすると
化けちゃうんだけど…。
0460デフォルトの名無しさんNGNG
>>459
全部、Shift-JISで書いてもダメ?
imodeってShift-JISじゃなかったっけ?
0461デフォルトの名無しさんNGNG
コンパイルもエンコード指定
0462名無し~3.EXENGNG
>460
Shift-JISですね。
化けるというか??になってるから、たぶん内部でUTF-8に変換して死んでるんだろうけど。
ソースコードはWin上でSJISで作成後コンパイル>Redhatの鯖にアップしてる。

>461
とりあえずやってみます。

Win上で動いてるTomcatで同じことやるとちゃんと出来てるんだけど…。
0463459NGNG
敗北しますた。

手順は
・ソースコードはWin上・SJISで作成
・それをRedHat上にアップ
・javac -encoding "Shift-JIS" Hello.java という感じにコンパイル

ソースコードは
res.setContentType("text/html; charset=Shift-JIS");
PrintWriter out = res.getWriter();
out.println("�@こんにちは");
という感じで、日本語はちゃんと表示されているのですが
�@やimodeの絵文字は化けているようです。

0464459NGNG
事故レス。
文字コードにMS932使うようにしたら解決した。
何なんだいったい…。
0465デフォルトの名無しさんNGNG
Shift-JISでもいいのか?Shift_JISじゃない?
しかし、Shift_JISも1.4.1からMS932じゃなくなっているから、
Windows-31Jのほうが良いかも。
コンパイルはどっちでやってもいいと思う。
0466デフォルトの名無しさんNGNG
ピンピンチ!!!
Tomcat を 3.3 から 4.1 に上げたは良いんだが、ページのロード中にユーザが中止ボタン押したり
戻るボタン押したりで発生する java.net.SocketException: Connection reset + スタックトレース
のログで今まさに /var が埋め尽くされようとしています。server.xml の <Logger> タグの verbosity
はすべて "0" にしたんだがこれじゃだめなんかー。たすけてーヒー!!
0467デフォルトの名無しさんNGNG
もちつけ
0468デフォルトの名無しさんNGNG
>>450
DOCOMOかどっかにある、i-mode用外字フォントを使え。

#漏れが試した時(2年前か・・・)は、
#後半のデータが入ってなかったんで、
#スキャンしたイメージデータからフォント登録をしたよ
0469デフォルトの名無しさんNGNG
>>466
よーしよしよし
いいか
cronかなんかで毎日varの下を掃除するんだ
tmpwatch使うのもいいぞ
0470デフォルトの名無しさんNGNG
3 March 2003 - Tomcat 4.1.21 Beta Released
0471デフォルトの名無しさんNGNG
サーブレットでPOSTメソッドでリクエストをかけたらこんな
エラーが出てしまいました。なにか設定が必要ですか。
Apache Tomcat/4.0.6 - HTTP Status 405
0472デフォルトの名無しさんNGNG
doPost() 書いてる?
0473デフォルトの名無しさんNGNG
すんません。
今更ながら技評のJakarta徹底本をやっていて
tomcatのsample動く
apache連携OK
まで漕ぎ着けたものの
strutsのsampleが実行時エラー
で止まりました。

エラーはこんな感じ
java.lang.NoClassDefFoundError: org/apache/jasper/runtime/JspException
at org.apache.jasper.runtime.PageContextImpl.handlePageException(PageContextImpl.java:463)

どこから手をつけたもんでしょう?
環境
debian sarge
tomcat4 4.04-4 ここまでapt
struts 1.1rc1 これは野良

手順はほぼここを真似しましただ
http://www3.starcat.ne.jp/~matsu/feature/struts/prepare/struts.html
0474デフォルトの名無しさんNGNG
doPost() 書いてませんでした(恥
0475デフォルトの名無しさんNGNG
Tomcat 4.0.x or 4.1.xで
ログを吐かせないようにするにはどうすれば良いんでしょう?
毎日ものすごい量の無意味なログファイルが蓄積されて困ってます。
(標準出力 and エラー出力がcatalina.outに保存されるのは良いとして…)
0476デフォルトの名無しさんNGNG
>>1板違い

http://hobby.2ch.net/test/read.cgi/army/1044550615/
0477デフォルトの名無しさんNGNG
>>476猫違い(w
0478デフォルトの名無しさんNGNG
Apache 1.3.20 (Cobalt Qube3) と Tomcat 4.1.18 (RedHat Linux) を mod_jk
で接続しています。そんなにアクセスが無いときでも接続数上限 100 に達して
しまって、ひどいときは 1 時間に一回くらい無応答 & 再起動を行わなければ
いけません。どうも Apache-Tomcat 間の接続が残りっぱなしになっているよう
なのですが、どなたが解決策をご存知の方いらっしゃいませんか。
0479デフォルトの名無しさんNGNG
http://www.pink-angel.jp/betu/linkvp2/linkvp.html
★その目で確認すべし!!★超おすすめ★
0480デフォルトの名無しさんNGNG
>>476を見て、慌てて伝説板にTOMCATスレがないか探した自分って。。。
二番煎じ?
0481デフォルトの名無しさんNGNG
4.1.24 Stable 版リリースあげ
0482デフォルトの名無しさんNGNG
Servletからプロパティファイルを使いたいのだけど、
どこに置けばいいのでしょう?
0483デフォルトの名無しさんNGNG
>>457
そりゃIISじゃないだろ
OS側のアクセス権の設定だろ。

Unix系使ってる香具師は.htaccessもchmodも知らんのか
0484デフォルトの名無しさんNGNG
>>482
WEB-INF/classessにでも置いておけ
0485デフォルトの名無しさんNGNG
>>483
httpd.confで設定してないと.htaccess効かないような
0486デフォルトの名無しさんNGNG
イラクで餌を獲るのに失敗して堕ちたみたいだね・・・。
0487デフォルトの名無しさんNGNG
まあApacheも近隣農民にDos攻撃喰らって鯖ダウンしたみたいだし(w
0488デフォルトの名無しさんNGNG
JNDIリソース使って、DataSource経由でDBコネクション取ってきてるんですが、
web.xmlに resource-ref タグの定義って必要なんでしょうか?

定義しなくても問題なく動作してしまうようなので・・・。

0489デフォルトの名無しさんNGNG
winMEでメモリ192、モバイルCeleron550でTOMCATは動きますか?
0490デフォルトの名無しさんNGNG
うごくよ
0491デフォルトの名無しさんNGNG
オレ達、極悪非道のVF31トムキャッターズ!
スレは好調だけど闇雲ageてやるからな!!
 ̄ ̄∨ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄
  ∧_∧   ∧_∧    age
 (・∀・∩)(∩・∀・)       age
 (つ  丿 (   ⊂)   age
  ( ヽノ   ヽ/  )      age
  し(_)   (_)J
0492bloomNGNG
http://www2.leverage.jp/start/
0493デフォルトの名無しさんNGNG
TOM「キャッ♥」

……と。
0494山崎渉NGNG
(^^)
0495デフォルトの名無しさんNGNG
Win2K+JDK1.3.1+Tomcat3.2.4です。
webapp下にsampleとsample2という2つのアプリケーション(?)が存在していて
sample2はsampleのコピーです。sampleはそのままにsample2を試験改修用と
して使いたいのですが当然WEB-INF下には同じpackage名でclassファイルが
並んでいます。一方を修正したら他方に影響を及ぼすようなことはありますで
しょうか?一見影響無しに動いているようなのですが、なんとなく不安で…
0496デフォルトの名無しさんNGNG
>495
大丈夫だったと思う…。
sample と sample2 は別の Context なので、別のクラスローダが
読み込むわけだが、Java2 環境だと、クラスローダが違うと同じ名前でも
別のクラスとして認識されるのだ。

sample クラスローダと sample2 クラスローダは別の CLASSPATH
を持っている。どちらも、環境変数CLASSPATHをベースに、それぞれの
WEB-INF\classes を追加した形。
なので、別の Context のクラスは見ることが出来ないし、影響しない。

だと勝手に思いこんでるんだが、正しいのかな…。
0497495NGNG
ありがとうございます。
自分は問題なかったのですが、他の人で問題が出たりしていたようなので
マズイかと思っていました。環境変数CLASSPATHと聞いて確認してみたら
問題がでたほうは環境変数に一方のWEB-INF/classes以下が含まれて
いたので、それで混同されていたのかもしれません。(WEB-INF下で直に
コンパイルするときに面倒くさいからとのことでした…)
0498U ◆CZtFsGiu0c NGNG
>495
WEBーINF/classesにクラスパスが通っていたりしなければ大丈夫。
0499デフォルトの名無しさんNGNG
ファイル名とクラス名がちがうので死にそうな予感。
0500山崎渉NGNG
   ∧_∧
  (  ^^ )< ぬるぽ(^^)
0501デフォルトの名無しさんNGNG
最新のTomatを最新のApacheと連携させるために
バージョンの微妙な違いで躓いた人はいませんか?

Linux上で
tomcat-connectorsでmod_jk2の作成がうまくいかないことがありまして。

わざわざ最新のautoconf, automake, libtoolを入手するはめになりまして
0502デフォルトの名無しさんNGNG
>>501
ん?glibcのバージョンの違いで躓いた?
0503デフォルトの名無しさんNGNG
俺もバイナリでよこせコノヤローと思ったヘタレ
0504デフォルトの名無しさんNGNG
>>502
glibcのバージョン?
./configureやってからmakeしたときにlibtoolのエラーが出ていたようです。
ちょっと古いApachje2.0.5x,Tomcat4.1.xではそんなに苦労しなかったんですが・・・
ちょっと調べてみます。

0505デフォルトの名無しさんNGNG
RedHOT+Tomcat4.1.24で稼動環境を作っていたのですが、
あるとき起動しようとすると
突然こんなメッセージが出て起動しなくなってしまいました。

java.net.ConnectException: Connection refused
at java.net.PlainSocketImpl.socketConnect(Native Method)
at java.net.PlainSocketImpl.doConnect(PlainSocketImpl.java:305)
at java.net.PlainSocketImpl.connectToAddress(PlainSocketImpl.java:171)
at java.net.PlainSocketImpl.connect(PlainSocketImpl.java:158)
at java.net.Socket.connect(Socket.java:426)
at java.net.Socket.connect(Socket.java:376)
at java.net.Socket.<init>(Socket.java:291)
at java.net.Socket.<init>(Socket.java:119)
at org.apache.catalina.startup.Catalina.stop(Catalina.java:581)
at org.apache.catalina.startup.Catalina.execute(Catalina.java:402)
at org.apache.catalina.startup.Catalina.process(Catalina.java:180)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
at java.lang.reflect.Method.invoke(Method.java:324)
at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:203)

どなたか原因わかる方いませんか?
担当者から押し付けられて困ってますので
おねがいします。
0506デフォルトの名無しさんNGNG
WEB-INF フォルダーの下のファイルに直接アクセスしたいの
ですがどうしたらええのでしょう?

server.xml の Context で指定すればアクセス出来ますが
なんか違うような。。
0507デフォルトの名無しさんNGNG
>>506
「直接」って?
クライアント(ブラウザ)から?
アプリケーション内のJavaのクラスから?
0508デフォルトの名無しさんNGNG
>>507
ブラウザからでつ。
0509デフォルトの名無しさんNGNG
>>508
できません。J2EE(Servlet)の仕様です。
というか、クライアントから直接アクセスしたくないファイルは
/WEB-INFの下に置きましょう、という思想。
アプリケーション内のクラスを介してならできなくはないが、直接は無理。
0510デフォルトの名無しさんNGNG
>>509
某メーカのヴァカ Servlet が /WEB-INF の下に画像ファイルを
置いてアクセスしてるんでつ。
/WEB-INF のアクセス権限を替える事は出来ないのでつか?
server.xml で context 作れば出来るんでつが邪道だな。
0511デフォルトの名無しさんNGNG
>>510
権限(パーミッション)の問題じゃない。
Servletからならアクセスできる。
ブラウザから直接は無理。
0512デフォルトの名無しさんNGNG
どちらかというと直接見られないように配置された画像を
直接見ようとする試みが邪道なのでは…?
0513510NGNG
Servlet が生成している Html の画像の所がバッテンになっているので
img タグを見ると /WEB-INF の中を見てるんでつ。
もうアフォかヴァカかと。
0514デフォルトの名無しさんNGNG
>>513
本当、アフォかヴァカだ。
この際、どのメカーか晒せ!
F・N・H・Iのどれかだろ?
0515510NGNG
>>514
外資系でつ。
Tomcat の古いバージョンだと /WEB-INF の中が見えるとか。。
0516デフォルトの名無しさんNGNG
>>515
ああ、Tomcat3.x系だとそうだったかも・・・・
Servlet2.2以前の話ね。
application毎にServletコンテキストが分離してなかった頃じゃない?
0517:NGNG

☆^〜^★ 50音順で探せて楽して得する
http://sagatoku.fc2web.com/
   あなたの探し物きっとみつかるよ☆^〜^★

0518デフォルトの名無しさんNGNG
TomCatなんて古すぎだよ。時代は純国産のF-2だよ。F/A-18も悪くないが、
0519デフォルトの名無しさんNGNG
WebProg板でや(ry
0520デフォルトの名無しさんNGNG
test
0521動画直リンNGNG
http://homepage.mac.com/hitomi18/
0522デフォルトの名無しさんNGNG
>>518
何でこう、いつもいつも戦闘機ネタばかりなんだYO。
ここはム板だ。ここでTomcatといえば当然
「たかがロケンロ〜」だろ。秘孔でも疲れてろ。

・・・で、もまいら、JavaGroups使ったTomcatのクラスタリングに
挑戦した猛者はいませんか? 決してクラスター爆弾ではないぞ。
0523デフォルトの名無しさんNGNG
は?トムとジェリーだろ?
0524デフォルトの名無しさんNGNG
TOMCAT4.1をWindows2000のサービスで起動したいのですが、
wrapper.propertiesという設定ファイルが見つかりません。
どこにあるのでしょう?
0525デフォルトの名無しさんNGNG
あー、無いよね。Tomcat3系からもらってくれば?
というかインストール時にサービス起動選べばよかったのに…
0526デフォルトの名無しさんNGNG
>>524
zip でなく exe のインストーラで入れて味噌。
http://ring.asahi-net.or.jp/archives/net/apache/dist/jakarta/tomcat-4/binaries/tomcat-4.1.24.exe
0527526NGNG
Tomcat は、バージョン 0.1 違うと設定がかなり違うから
バージョン 4.1 のドキュメント見ないと駄目だね。
0528524NGNG
>525-527
ありがとー、インストーラでサービス起動できました。
ポートの変更もadminパスワードの設定も何も考えずにできました。
楽すぎて設定の仕方は身につきませんけど。
0529デフォルトの名無しさんNGNG
起動時に大量に流れるログを消したいんですが
どこら辺をいじれば良いのでしょうか?
0530デフォルトの名無しさんNGNG
>>529
「verbosityLevel」で調べてみるべし
0531デフォルトの名無しさんNGNG
嘘。ごめん、起動時のは知らないや。正直スマンカッタ
0532デフォルトの名無しさんNGNG
>>530
いえいえ、こんな時間にありがとうございました。
そこらへんも調べておきます。

なんか、デバックしずらくて・・・
0533532NGNG
すいません、単純にPJで利用しているLog4Jのパッケージ設定が甘かったようで
jakarta系のパッケージまでDebugモードになっていただけでした。

お恥ずかしい限りです…
0534デフォルトの名無しさんNGNG
TOMCAT起動時に
あらかじめ登録しているDBのコネクションを
自動的にやりたいんですけど
どうすればいいですかね?
AdminToolに、データソースの設定画面あるのは知っています
しかしできれば、指定したアプリだけに反映したいんです

いろいろ考えました
TOMCAT起動時に自分で上記の作業を行うサーブレットを叩いたり、
そのアプリ内のどのページ行っても、最初にそれを行うページを
キックしたり・・・
しかし、どうも納得いきません

0535130NGNG
>>534
文面がよくわからんけど、Connectionを作りたいならFilterを使うのが良いかも。
FilterでConnectionのオープン、requestへのセット、filterChainの呼び出し、クローズとやる。
0536デフォルトの名無しさんNGNG
↑130じゃないよ。間違えた。
0537デフォルトの名無しさんNGNG
init()内に接続初期化のコードを持ったサーブレットを
load-on-startup でコンテナの開始に同期させればいいんじゃないの
0538デフォルトの名無しさんNGNG
server.xmlに<Context>タグを記述してしまったアプリケーションって、もうどんなにあがいてもWARをwebapps直下に置くだけでは起動時の自動デプロイはやってくれないの?
0539デフォルトの名無しさんNGNG
TOMCAT 4.1.24 ってNTサービスでうごかね。
つか、うごかねの漏れだけ?
0540デフォルトの名無しさんNGNG
前のほうで誰か書いていたけど、exeの方をダウンロードして
インストール時にNTサービスで動かすつうチェックいれた?
0541デフォルトの名無しさんNGNG
質問です。
下記{環境}で、JK2 JNIワーカによるApache内部起動でTomcatを実行しています。
動作の方は何等問題は無いのだが、Windows2000のシャットダウン時にApacheが
エラーになります。ログオフ時も同様です。
各種設定内容は{参照}を参考に設定しています。
これは設定方法に誤りがあるのでしょうか?
またはApacheかTomcatに内部的な不具合が残っているのでしょうか?
ご存知であれば教えてください。
因みに、httpd.confのLoadModule jk2_module xxx行をコメントすると、
エラーが発生しません。
ひょっとしたらmod_jk2.dllが怪しいのかも?!わかりませんが???

{環境}
Windows2000
J2SDK1.4.1_02
Apache2.0.43
Tomcat4.1.24
mod_jk2-2.0.43.dll

{参照}
http://www.ytp.ne.jp/
http://www.gregoire.org/howto/Apache2_Jk2_TC4.1.x_JSDK1.4.x.html
または
http://www.google.co.jp/search?q=cache:TQKIOJYhp6gC:www.gregoire.org/howto/Apache2_Jk2_TC4.1.x_JSDK1.4.x.html+How+To+for+Apache2,+Tomcat4.1.x,+mod_jk2,+JSDK1.4+on&hl=ja&ie=UTF-8

0542デフォルトの名無しさんNGNG
>>522
猛者っつーかもうふつうにやられてそう。
http://www.theserverside.com/resources/article.jsp?l=Tomcat
http://cvs.apache.org/~fhanik/index.html
0543_NGNG
  ∧_∧
 ( ・∀・)/< こんなのみつけたっち♪ 
http://www.hiroyuki.zansu.com/hankaku/jaz03.html
http://hiroyuki.zansu.com/hankaku/jaz10.html
http://www.hiroyuki.zansu.com/hankaku/jaz08.html
http://hiroyuki.zansu.com/hankaku/jaz09.html
http://www.hiroyuki.zansu.com/hankaku/jaz06.html
http://hiroyuki.zansu.com/hankaku/jaz05.html
http://www.hiroyuki.zansu.com/hankaku/jaz01.html
http://hiroyuki.zansu.com/hankaku/jaz02.html
http://www.hiroyuki.zansu.com/hankaku/jaz07.html
http://hiroyuki.zansu.com/hankaku/jaz04.html
0544デフォルトの名無しさんNGNG
>>540
インストーラを使って入れているんだが、4.1.24は動かなくて
4.1.18だと動くんだな。
0545デフォルトの名無しさんNGNG
動かないってのは、jspのコンパイルができないことでつか?
0546デフォルトの名無しさんNGNG
Beanってキャッシュされちゃうの? クリアの仕方を教えてください。

JSPから自作のBeanを呼び出すテストをしてるんだけど。
Beanを変更して、BeanとJSPをコンパイルしなおしても、結果が反映されない。
環境は、Windows2000Pro Tomcat4.1.24 JDK1.4.1_02
サービスを再起動してもだめです。
[index.jsp]
<%@ page pageEncoding="Shift_JIS" %>
<%@ page contentType="text/html; charset=Shift_JIS" %>
<%@ page import="java.util.*"%>
<jsp:useBean id = "obj" scope = "request" class = "MyPackage.MyBean"/>
<html><head><title>Welcome</title></head>
<body>
<%
  String s = "";
  s = obj.getsTest();
  out.print (s);
%>
</body>
</html>

[MyBean.java]
package MyPackage;
public class MyBean {
  public MyBean(){
  }
  public String getsTest(){
    //ここを変えても反映されない。
    //return "AAAAAA";
    return "ZZZZZZ";
  }
}
0547デフォルトの名無しさんNGNG
>>546
ブラウザ閉じて開き直してもダメ?
Tomacatの最近のバージョンはサーバ停止するときに
セッションをファイル化して保存する。そして再起動したときに
それをメモリ上に復元するようになっている。
0548544NGNG
>>545
そうでつ。
0549546NGNG
すいません、サービスの停止開始だけでOKでしたぁ。
useBean scope = "request"にしてもサービスを再起動すれば
変更は反映されました。

(Eclipse使ってて、Project\binにコンパイルされるのを
WEB-INF\classesにコピーしてなかった。とほほ。
WEB-INF\classesに自動的にコピーするのは、Antとかいうのを使うのだろうか。)

サービスを再起動しなくても、反映されれば楽なのですが、、、
とにかく、お騒がせしました。
0550デフォルトの名無しさんNGNG
>>549
今同じようなことで悩んでるんだけど、Eclipseでbinの下に出来たBean用クラスを
classesの下にコピーしないとエラーになるのはわかったんだけど、一度コピーして
Tomcatを立ち上げてからEclipse上でBeanを変更した場合に、binからclassesに
コピーしなくてもBeanの変更が更新されているのはなぜだろう?

説明が苦手なので例をあげると、
1.getStr()でAAAを返すBeanをEclipseで作成、binからclassesにコピー
 JSPにはAAAが返る
2.getStr()でZZZを返すBeanをEcllipseで作成、binからclassesにコピーしない
 JSPにはなぜかZZZが返る

わかる人、教えてください。
■ このスレッドは過去ログ倉庫に格納されています