TOMCAT
■ このスレッドは過去ログ倉庫に格納されています
0001デフォルトの名無しさん
NGNGしようと思ったんすけど、うまく動きません。ネットで
調べまくって手順も大丈夫なはずなんだけど。
環境
Win2000Pro、Tomcat3.2.3
自宅のWin98SEで同じようにやったら動いた。
Win2000では
C:\tomcat\bin>tomcat run
Including all jars in c:\tomcat\lib in your CLASSPATH.
Using CLASSPATH: c:\tomcat\classes;c:\tomcat\lib\ant.jar;c:\tomcat\lib\jasper.ja
r;c:\tomcat\lib\jaxp.jar;c:\tomcat\lib\parser.jar;c:\tomcat\lib\servlet.jar;c:\t
omcat\lib\webserver.jar;c:\tomcat\classes;c:\tomcat\lib\ant.jar;c:\tomcat\lib\ja
sper.jar;c:\tomcat\lib\jaxp.jar;c:\tomcat\lib\parser.jar;c:\tomcat\lib\servlet.j
ar;c:\tomcat\lib\webserver.jar;c:\tomcat\lib\servlet.jar;c:\jdk1.3\lib\tools.jar
;c:\jdk1.3\lib\tools.jar
Exception in thread "main" java.lang.NoSuchMethodError
at org.apache.tomcat.startup.Tomcat.getConfigFile(Tomcat.java:116)
at org.apache.tomcat.startup.Tomcat.execute(Tomcat.java:141)
at org.apache.tomcat.startup.Tomcat.main(Tomcat.java:163)
C:\tomcat\bin>
こういうエラーが出ます。パスもJAVA_HOME、TOMCAT_HOME通した。
クラスパスも通ってるはず。なでしょう?
0247233
NGNGmod_jk って、4.0.4でも使える?
明日、試してみるつもりなんだけど‥‥‥
0248デフォルトの名無しさん
NGNGWebサーバーのルートにIndex.jspを
どうやっておけばいいの?
/test/index.jspとかはいけるんですが・・・
0249デフォルトの名無しさん
NGNG0250デフォルトの名無しさん
NGNG0251233
NGNGなんかデキちゃったよ(藁)
jakarta-tomcat-4.1.12.tar.gz と jakarta-tomcat-connectors-4.1.12-src.tar.gz
をダウンロードして、jakarta-tomcat-4.1.12.tar.gzを展開。
jakarta-tomcat-connectors-4.1.12-src.tar.gzも展開して、configureしたら、
makeが通って、mod_webapp.soがデキちゃったと‥‥‥
さぁ、これからこれを、Apacheに組み込んでみよ〜っと。
何が出るかな?何が出るかな?エラーかな?OKかな?どきどき‥‥‥
0252233
NGNGWebApp: Error 404
(File: /src/jakarta-tomcat-connectors-4.1.12-src/webapp/lib/wa_request.c Line: 205)
Web-application not yet deployed
だってさ。
これって.Apache+tomcat が起動はしてるって事なのか、それとも起動しても
いないのか‥‥‥
0253233
NGNGごめん!Apacheんとこ、コメントアウトしてあった!!
おお〜、起動したぞ!起動したぞ!Tomcat!
0254デフォルトの名無しさん
NGNG0255デフォルトの名無しさん
NGNGおめ
0256デフォルトの名無しさん
NGNGうむ、人柱ご苦労。
by THE 他力本願
0257デフォルトの名無しさん
NGNG0258勉強不足
NGNG何でなんでしょう?
ちなみに環境はWIN98、tomcat3.2.4、apacheと連結させています。
0259デフォルトの名無しさん
NGNGserver.xmlかweb.xmlが駄目くさい。
よく確認しる。
エクスプローラからstartup.batダブルクリックしてるでしょ?
じゃなくて、DOS窓開いて、tomcat\bin\にcdして、
startup.bat
って入力してごらん。
ほ〜ら、すぐに終了する原因が分かった!
0261デフォルトの名無しさん
NGNG多分それやっても無理。tomcat.bat start を直接実行しないことには。
0262勉強不足
NGNG>>260
DOS窓からやってるんですけどねぇ・・・・?Microsoft(R) Windows 98
(C)Copyright Microsoft Corp 1981-1999.
C:\>SET TOMCAT_HOME=C:\jakarta-tomcat-3.2.4
C:\>SET JAVA_HOME=C:\jdk1.3.1
C:\>
C:\>cd "c:\jakarta-tomcat-3.2.4"
C:\jakarta-tomcat-3.2.4>bin\startup
Unable to set CLASSPATH dynamically.
Note: To set the CLASSPATH dynamically on Win9x systems
only DOS 8.3 names may be used in TOMCAT_HOME!
Setting your CLASSPATH statically.
Using CLASSPATH: C:\jakarta-tomcat-3.2.4\classes;C:\jakarta-tomcat-3.2.4\lib\ant
.jar;C:\jakarta-tomcat-3.2.4\lib\jasper.jar;C:\jakarta-tomcat-3.2.4\lib\jaxp.jar
;C:\jakarta-tomcat-3.2.4\lib\servlet.jar;C:\jakarta-tomcat-3.2.4\lib\webserver.j
ar;C:\jdk1.3.1\lib\tools.jar
Starting Tomcat in new window
C:\jakarta-tomcat-3.2.4>
とゆう画面出てるのに、tomcatのDOS窓はチラッと出て閉じるんですよ。
0263デフォルトの名無しさん
NGNGbin\startup の代わりに bin\tomcat.bat run とか打ってみろ。
CATALINA_HOME の設定とかも必要かもしれんが。
0264デフォルトの名無しさん
NGNGすまん、catalina.bat だったかもしれん。
0265デフォルトの名無しさん
NGNG> Note: To set the CLASSPATH dynamically on Win9x systems
> only DOS 8.3 names may be used in TOMCAT_HOME!
このメッセージが気になるけど、Win9x+3.2.4だといつも出るの?>他の人
0266勉強不足
NGNGネットで調べたら、3.2.1だとインストール方法が全く違う・・・。
0267デフォルトの名無しさん
NGNG0268勉強不足
NGNGありがとうございました!!
>>365
クラスパスの設定法を
set TOMCAT_HOME=C:\JAKART~1.4
SET JAVA_HOME=C:\JDK13~1.1
の様にしたら解決しました。
どうやらそれが問題だった様です。ありがとうございました!!
0269デフォルトの名無しさん
NGNG( ゚д゚)ポカーン
( ゚д゚)ンポカーン
( ゚д゚)チンポカーン!!
0270デフォルトの名無しさん
NGNGTOMCAT4.1.12とApache1.3.27をCoyoteを使い連携させようと思うのですが、
Apache側の設定の仕方がわかりません。
(TOMCAT4.1はデフォルトで持っているんですよね?)
知っている方教えて下さい。おながいします。
0271デフォルトの名無しさん
NGNGバージョンは1.4です。
0272デフォルトの名無しさん
NGNG間違った、バージョン4です。
0273デフォルトの名無しさん
NGNG>>221
過去ログ嫁
0274デフォルトの名無しさん
NGNG0275デフォルトの名無しさん
NGNGユーザー登録とか、どうやんの?
0276デフォルトの名無しさん
NGNG0277275
NGNG分かんなかったら黙っててね。使ってみたいから聞いてんの。
0278デフォルトの名無しさん
NGNG0279デフォルトの名無しさん
NGNGドキュメントは読んだのか?
0280デフォルトの名無しさん
NGNGとりあえず、tomcat-users.xmlにrole="admin"のユーザを追記してからだな。
あとは見た目でいじれるでしょ。
0281277
NGNGどーも、サンクス! ログイン出来ました。
0282277
NGNG>>280 でした。
0283デフォルトの名無しさん
NGNG0284デフォルトの名無しさん
NGNG0285デフォルトの名無しさん
NGNGTomcat4.1.12で使って入門書の通りHelloWorldを実行したければ
conf/web.xmlをinvokerで検索してコメントアウトを解除せよ。
これにいきなりはまったよ・・・前途多難
0286デフォルトの名無しさん
NGNG0287デフォルトの名無しさん
NGNGそうなんだよね〜
初めてなんではまっちゃったよ・・・
0288デフォルトの名無しさん
NGNG0289デフォルトの名無しさん
NGNG0290デフォルトの名無しさん
NGNGWebApp Library Configurationを見ると
Application Name "examples"
Root URL Path "/examples/"
Local Deployment Path No local deployment path
Configuration Details "Application ID: -1"
Connection "conn" (details)
Deployed FALSE
ってなってて、ダメポいんですが
解決方法わかりませんか?
0291デフォルトの名無しさん
NGNG俺も Tomcat 4 + mod_app は何度も挑戦してすべて失敗に終わった。
mod_jk 使っとけ。
0293デフォルトの名無しさん
NGNG漏れもできたよ。(Apache1.3.27+Tomcat4.1.12+mod_webapp)
でも>>286を知らんくてしばらくなやんだが。
>>290
>>286のことはちゃんとおさえてるよね?
0294290
NGNGApache\error.logをみてみたら
[error] Connection "conn" cannot connect
[error] Cannot open connection "conn"
ってなってるな〜。
0295デフォルトの名無しさん
NGNGserver.xmlでコネクタが有効になってないのでは?
0296293
NGNG1. autoconf2.5xをインストール(autoconf25で入れたみた。configure --program-suffix=25)
2. Antをインストール
3. # export JAVA_HOME=JDKのホーム
4. http://www.apache.org/dist/apr/ からapr-0.9.1.tar.gzを落とす。
# pwd
/tmp
# tar zxvf apr-0.9.1.tar.gz
# cd apr-0.9.1
# ./buildconf
4. http://jakarta.apache.org/builds/jakarta-tomcat-4.0/release/v4.1.12/src/ からjakarta-tomcat-connectors-4.1.12-src.tar.gz を落とす。
# pwd
/tmp
# tar zxvf jakarta-tomcat-connectors-4.1.12-src.tar.gz
# cd jakarta-tomcat-connectors-4.1.12-src/webapp
# cp -p support/buildconf.sh support/buildconf25.sh
support/buildconf25.shのautoconfをautoconf25へ全置換
# support/buildconf25.sh
# ./configure --with-apr=/tmp/apr-0.9.1
# make
# cp -p apache-1.3/mod_webapp.so /etc/httpd/modules
5. /etc/httpd/conf/httpd.confにその辺のサイトにしたがって追記。
6. /etc/tomcat/server.xmlのコメントになってる<Service name="Tomcat-Apache">を活かす。
0297293
NGNG環境はApache 1.3.27/Tomcat4.1.12/mod_webapp。
手順の5とか6はぐぐること。
0298デフォルトの名無しさん
NGNGしているんだけど、tomcat 4 以降は、mod_webapp と mod_jk のどちらを
使えばいいの?(jakarta 側としては、今後どちらを使っていけばいいといっているの?)
あとmod_webapp の作り方は、過去ログや
http://www.t3.rim.or.jp/~yoko-k-h/java/servlet/engines/tomcat4.0.1.html
を見れば載ってるけど、tomcat 4 系列用の mod_jk.so はどうやって作ればいいの?
3系列のバイナリは
http://jakarta.apache.org/builds/jakarta-tomcat/release/v3.2.3/bin/linux/i386/
とかにあるけど、
4系列のディレクトリの下においてないし.....
最近の事情に詳しい方、教えてください。
0300デフォルトの名無しさん
NGNG(Tomcat単体でもWEBサーバーとして機能するが推奨されなかった)
この状況は今日もかわっていないか?そろそろ何らかの形で統合された?
0301デフォルトの名無しさん
NGNGjakarta-tomcat-connectors-4.1.12-src.tar.gzを落としたあと、
# tar zxvf jakarta-tomcat-connectors-4.1.12-src.tar.gz
# cd jakarta-tomcat-connectors-4.1.12-src/jk/native
# ./buildconf.sh
# ./configure --with-apxs=/usr/sbin/apxs
# make
# cp -p apache-1.3/mod_jk.so /etc/httpd/modules
あとは適当にmod_jk.confなり作れ。
しかし、>>296の環境にこれを追加しただけなのにマッピングされたパスが全部403になるや。
面倒だからそのままだけど。
0302293
NGNG理屈わかる人いたらフォローよろしく。
VineLinux2.6R1/Apache 1.3.27/Tomcat4.1.12/mod_webapp/Struts1.0.2
1.よくある解説サイトStruts付属のドキュメントにあるようにwarをwebappsディレクトリに入れてもデプロイされない。
8080経由でも404 Not Foundになる。(理由はちゃんと見てないが、catalina.outにエラーは出る)
これを回避するには明示的にserver.xmlに<Context>を追加すればよい。
<Context path="/struts-example" docBase="/var/tomcat4/webapps/struts-example.war" debug="0"
reloadable="false" crossContext="true">
</Context>
こんな感じ。追加する箇所は適当に判断。
2. <Context>を<Service name="Tomcat-Standalone">のほうへ追加すると8080からは見れるけどApache経由だと未デプロイになる。
(warではなく、ディレクトリをそのままwebappsにおいた場合はTomcat-Standalone側でもデプロイされていたのはなぜだろう?)
初期状態のserver.xmlには<Service name="Tomcat-Apache">の下に<Host>がないのでこれを追加しる。
そのあとで1.の<Context>を追加する。
ディレクトリをwarにまとめないままのときとwarにまとめたときで挙動が違ったので戸惑いますた。
0303293
NGNG理屈わかる人いたらフォローよろしく。
VineLinux2.6R1/Apache 1.3.27/Tomcat4.1.12/mod_webapp/Struts1.0.2
1.よくある解説サイトStruts付属のドキュメントにあるようにwarをwebappsディレクトリに入れてもデプロイされない。
8080経由でも404 Not Foundになる。(理由はちゃんと見てないが、catalina.outにエラーは出る)
これを回避するには明示的にserver.xmlに<Context>を追加すればよい。
<Context path="/struts-example" docBase="/var/tomcat4/webapps/struts-example.war" debug="0"
reloadable="false" crossContext="true">
</Context>
こんな感じ。追加する箇所は適当に判断。
2. <Context>を<Service name="Tomcat-Standalone">のほうへ追加すると8080からは見れるけどApache経由だと未デプロイになる。
(warではなく、ディレクトリをそのままwebappsにおいた場合はTomcat-Standalone側でもデプロイされていたのはなぜだろう?)
初期状態のserver.xmlには<Service name="Tomcat-Apache">の下に<Host>がないのでこれを追加しる。
そのあとで1.の<Context>を追加する。
ディレクトリをwarにまとめないままのときとwarにまとめたときで挙動が違ったので戸惑いますた。
0304293
NGNG0305デフォルトの名無しさん
NGNGみんなどうやって日本語表示やってます?
0306デフォルトの名無しさん
NGNGぜんぜんしらんけど、単にデフォルトエンコーディング使っていたのを
外部設定に変更しただけじゃないの?デフォルトがUTF-8で。
追加設定調べたらあるかもよ。
JavaソースコードをShift_JISで書くのやめるほうがよさそう
だが。配置時にAnt使ってnative2ascii通すだけだし。
0307デフォルトの名無しさん
NGNGApache、TOMCATそれぞれ色々バージョンもあるし、バグもあるみたいだし
設定も相当大変に思えるのですが、趣味でやってる人はどうやって覚えました?
私は趣味でクライアントサイド+携帯のJavaを2年程やっており、Javaそのものはそこそこわかっているつもりですが・・
0308デフォルトの名無しさん
NGNG本で覚えました
0309デフォルトの名無しさん
NGNG身体で覚えました
0310デフォルトの名無しさん
NGNG趣味でやってますけど、Apache 2.0.43+mod_jk2 2.0.1+Tomcat 4.1.12 を
インストールしてみると、すんなり動きましたよ。
0311デフォルトの名無しさん
NGNG0312デフォルトの名無しさん
NGNG<HTML><BODY><%= new java.util.Date()%></BODY></HTML>
を作ったところ以下のエラーがでます。これはなんでしょう?
ちなみにTOMCAT4ではうまくいったのですが・・
2002-11-27 01:00:38 - Ctx(/bbs) : Exception in R( /bbs + /test.jsp + null) - org.apache.jasper.JasperException: Unable to compile
at org.apache.tomcat.facade.JasperLiaison.javac(JspInterceptor.java:898)
at org.apache.tomcat.facade.JasperLiaison.processJspFile(JspInterceptor.java:733)
at org.apache.tomcat.facade.JspInterceptor.requestMap(JspInterceptor.java:506)
at org.apache.tomcat.core.ContextManager.processRequest(ContextManager.java:968)
at org.apache.tomcat.core.ContextManager.internalService(ContextManager.java:875)
at org.apache.tomcat.core.ContextManager.service(ContextManager.java:833)
at org.apache.tomcat.modules.server.Http10Interceptor.processConnection(Http10Interceptor.java:176)
at org.apache.tomcat.util.net.TcpWorkerThread.runIt(PoolTcpEndpoint.java:494)
at org.apache.tomcat.util.threads.ThreadPool$ControlRunnable.run(ThreadPool.java:516)
at java.lang.Thread.run(Thread.java:536)
0313デフォルトの名無しさん
NGNG0314デフォルトの名無しさん
NGNG0315デフォルトの名無しさん
NGNG0316デフォルトの名無しさん
NGNGhttp://jakarta.apache.org/tomcat/tomcat-4.1-doc/jndi-datasource-examples-howto.html
ありがとう、ここに詳しくありました。
4.1.12を使うことにします。
0317デフォルトの名無しさん
NGNG296さんの記述を参考にし、
./configure --with-apr=/tmp/apr-0.9.1
まではできたのですが、
makeでエラーが出てしまいます。
BUILD FAILED
file:/tmp/jakarta-tomcat-connectors-4.1.12-src/webapp/build.xml:198: java.lang.ClassNotFoundException: org.apache.tools.ant.taskdefs.optional.TraXLiaison
というものですが、antのクラスが見えてないのでしょうか?
antはパッケージでインストールしました。バージョンは1.5.1です。
0318デフォルトの名無しさん
NGNGインストールしてlocahost:8080にアクセス、
TOMCATのページが表示されたので成功だ!とおもいきや
[STOP TOMCAT]してもlocalhost:8080にアクセスできるじゃあありませんか・・
どうやってTOMCAT止めるんですか?
0319デフォルトの名無しさん
NGNGサービスとして組み込んでないか?
開発中アレやると大変なことに・・・。
0320デフォルトの名無しさん
NGNGどうやったら「サービスとして組み込む」ことになるのですか?
普通にインストールしただけのはずなのですが・・
途中 2000・XP only のチェックボックスをクリックしましたが、これが原因?
0321デフォルトの名無しさん
NGNG・・みたいですね、できました、ありがとうございます
0322デフォルトの名無しさん
NGNGなんでか、だれか知らない?
0323デフォルトの名無しさん
NGNGもう解決したようだが net stop "Apache Tomcat" だな。
0324296
NGNGexport ANT_HOME=Antのインストールディレクトリ
してからやってみましょう。
./configure --with-apr=/tmp/apr-0.9.1 --without--ant(記憶あいまい)
でもmakeはとおると思うけど、なんかはまった気がするんだよな。
--without-antは違うかもしれん。
./configure --helpでそれっぽいスイッチ探してください。
0326デフォルトの名無しさん
NGNGアパッチの方が良いのでしょうか?
0327名無しさん@Emacs
NGNGIISかapacheかより、winかwin以外かの方が重要
0328デフォルトの名無しさん
NGNG0329デフォルトの名無しさん
NGNG玄人指向?
0330デフォルトの名無しさん
NGNGデフォルトの文字コードは何になる?
0331330
NGNG0332デフォルトの名無しさん
NGNG受け取った値の文字コードは送り側に依存しますが?
0334デフォルトの名無しさん
NGNGされないと思うけど?
0335デフォルトの名無しさん
NGNG0336デフォルトの名無しさん
NGNGPropertiesクラスでそのpropertiesファイルを読み込めないのですが、
何か原因があるのでしょうか?
実際のソースはこんな感じです。
ClassLoader cl = ClassLoader.getSystemClassLoader();
prop = new Properties();
InputStream input = cl.getResourceAsStream(FILE_NAME);
if (input == null) {
throw new IOException("ないよ");
}
prop.load(cl.getResourceAsStream(FILE_NAME));
この取り方がいけないのかな?
環境はTomcat4.0.5、JDK1.4
環境変数はTOMCAT_HOME、JAVA_HOMEともに通してあります。
0337デフォルトの名無しさん
NGNGClassLoader.getSystemClassLoader()が間違い。
getClass().getResourceAsStream()や、
getClass().getClassLoader().getResourceAsStream()を使う。
この二つの違いはJDKのJavadocに書いてある。
または、Thread.currentThread().getContextClassLoader()で
現在のスレッドのコンテキストクラスローダを調べる。
ただし、この方法は確実じゃないから、getClass()に訊くが吉。
0339デフォルトの名無しさん
NGNG0340デフォルトの名無しさん
NGNG0341デフォルトの名無しさん
NGNG環境変数の設定にてこずっています。
環境変数のための領域が足りません
tomcat.bat not found at TOMCAT_INSTALL = C:jakarta-tomcat-3.3.1
と出ます。
これはTOMCAT_INSTALL にパスを通すでよいのでしょうか?
0342デフォルトの名無しさん
NGNGshell = C:\COMMAND.COM C:\ /P /E:2048
とか
0343デフォルトの名無しさん
NGNGダイアログで出てくる基本認証の代わりみたいなものですよね。
フォーム認証はログイン専用ページを用意しないといけないみたいですが、
トップページにログイン用のフォームがあって、ログインしなくても使えるけど、
ログインすると会員モードみたいな感じで認証を行いたいのですが、
こういうのって自分で実装しないとダメなんですか?
コンテナの認証を使うと楽な感じがして・・・
サーブレットでロールを操作できるといいのですが。
0344デフォルトの名無しさん
NGNG会員専用ページだけを認証ページとしてweb.xmlに登録すればいいじゃん。
0345デフォルトの名無しさん
NGNGヒントをいただけると助かるのですが・・・。
0346デフォルトの名無しさん
NGNGservletからPostgreSQLへjdbc接続しようとしています
Win上のtomcat4.0.6からは接続できているのですが(-securityオプション無しで起動?)
Debian上のtomcatから接続しようとすると/var/log/tomcat4/catalina.outに
Something unusual has occured to cause the driver to fail. Please report this exception: Exception: java.security.Access
ControlException: access denied (java.net.SocketPermission 192.168.0.2:5432 connect,resolve)
Stack Trace:
java.security.AccessControlException: access denied (java.net.SocketPermission 192.168.0.2:5432 connect,resolve)
ってなことがログされておりました
試しに-securityオプション無しにtomcatを起動したところ接続できました
しかし今はテスト中ですが後に公開サーバ上での運用を予定してるので
可能であれば-securityオプション付きで起動したtomcat上で運用したいと思っています
そこでcatalina.policyのコメントアウトされていた部分をちょっといじって
grant codeBase "file:/home/hoge/fugaServlet/WEB-INF/lib/postgresql.jar!/-" {
permission java.net.SocketPermission "192.168.0.2:5432", "connect";
};
とか書いてみたのですが変わらずアクセスできませんでした
この辺の設定ってどうしたらいいのでしょうか?
ちなみにWebアプリは~/以下に置いてありserver.xmlに設定追加して動作はしています
0347デフォルトの名無しさん
NGNG■ このスレッドは過去ログ倉庫に格納されています