トップページ⇒tech
984コメント322KB

TOMCAT

■ このスレッドは過去ログ倉庫に格納されています
0001デフォルトの名無しさんNGNG
JavaServletを使いたいと思いTOMCATをインストール
しようと思ったんすけど、うまく動きません。ネットで
調べまくって手順も大丈夫なはずなんだけど。

環境
Win2000Pro、Tomcat3.2.3
自宅のWin98SEで同じようにやったら動いた。

Win2000では

C:\tomcat\bin>tomcat run
Including all jars in c:\tomcat\lib in your CLASSPATH.

Using CLASSPATH: c:\tomcat\classes;c:\tomcat\lib\ant.jar;c:\tomcat\lib\jasper.ja
r;c:\tomcat\lib\jaxp.jar;c:\tomcat\lib\parser.jar;c:\tomcat\lib\servlet.jar;c:\t
omcat\lib\webserver.jar;c:\tomcat\classes;c:\tomcat\lib\ant.jar;c:\tomcat\lib\ja
sper.jar;c:\tomcat\lib\jaxp.jar;c:\tomcat\lib\parser.jar;c:\tomcat\lib\servlet.j
ar;c:\tomcat\lib\webserver.jar;c:\tomcat\lib\servlet.jar;c:\jdk1.3\lib\tools.jar
;c:\jdk1.3\lib\tools.jar

Exception in thread "main" java.lang.NoSuchMethodError
at org.apache.tomcat.startup.Tomcat.getConfigFile(Tomcat.java:116)
at org.apache.tomcat.startup.Tomcat.execute(Tomcat.java:141)
at org.apache.tomcat.startup.Tomcat.main(Tomcat.java:163)
C:\tomcat\bin>

こういうエラーが出ます。パスもJAVA_HOME、TOMCAT_HOME通した。
クラスパスも通ってるはず。なでしょう?
0236デフォルトの名無しさんNGNG
Tomcatの4.1.12入れたんだけど
管理画面が出来て良い感じになってるね。
0237233NGNG
>>235

そうしないと、ダメみたいね。
squidポートを換えるのは簡単だが、Windowsクライアントの設定変更
が結構めんどうっぽい(泣)

透過型串にしとけばよかったなぁ‥‥
0238デフォルトの名無しさんNGNG
TOMCATのポート変更しろよ...
0239デフォルトの名無しさんNGNG
俺も最初 Tomcat がデフォルト 8080 と知ったときは アフォ かと思った。
0240233NGNG
>>238

今日、TOMCAT初体験なんで‥‥‥‥
squidの方、変えちゃったYO

my_web_server:8080で、TOMCAT起動に成功しました〜!
0241デフォルトの名無しさんNGNG
tomcat/conf/web.xmlで8080を検索して、好きな番号に変更しろや。
0242デフォルトの名無しさんNGNG
違うだろ
0243デフォルトの名無しさんNGNG
tomcat/conf/server.xmlで8080を検索して、好きな番号に変更しろや。
0244233NGNG
>>241

まぁ、それはsquidの変更やっちゃったんで、パスさせて


mod_webappのコンパイルでけつまづいてましゅ。
なんだよAPRソースって?

>>233のとおり、参考にしてんのは日経Linuxの9月号で、付録のCD-ROM
から、jakarta-tomcat-4.0.4.tar.gz、jakarta-tomcat-connectors-4.0.2-01-src.tar.gz
を使ってる。まぁ、せっかく付いてきたし、上手く動いたらバージョンアップしよう
と思ったんだが、jakarta-tomcat-connectors-4.0.2-01-src/webappのconfigure
がダメじゃん。

 なんかAPRソースがいるとかメッセージでてるし、jakarta-tomcatにもそんな
ことが書いてるんだけど、日経linuxの記事にゃ書いてない。

 ほんとにこの記者、これでコンパイルできだんだろうか?

 参ったなぁ。
0245デフォルトの名無しさんNGNG
俺はさっさとあきらめて Tomcat 3 + mod_jk に戻した。
0246デフォルトの名無しさんNGNG
俺も mod_jk 派
0247233NGNG
>>246

mod_jk って、4.0.4でも使える?
明日、試してみるつもりなんだけど‥‥‥
0248デフォルトの名無しさんNGNG
tomcatで
WebサーバーのルートにIndex.jspを
どうやっておけばいいの?
/test/index.jspとかはいけるんですが・・・

0249デフォルトの名無しさんNGNG
あんたのweb.xml次第だろ
0250デフォルトの名無しさんNGNG
http://server-name/index.jsp → $TOMCAT_HOME/webapps/ROOT/index.jsp
0251233NGNG
おはよ〜

なんかデキちゃったよ(藁)

jakarta-tomcat-4.1.12.tar.gz と jakarta-tomcat-connectors-4.1.12-src.tar.gz
をダウンロードして、jakarta-tomcat-4.1.12.tar.gzを展開。
jakarta-tomcat-connectors-4.1.12-src.tar.gzも展開して、configureしたら、
makeが通って、mod_webapp.soがデキちゃったと‥‥‥

さぁ、これからこれを、Apacheに組み込んでみよ〜っと。

何が出るかな?何が出るかな?エラーかな?OKかな?どきどき‥‥‥
0252233NGNG

WebApp: Error 404
(File: /src/jakarta-tomcat-connectors-4.1.12-src/webapp/lib/wa_request.c Line: 205)
Web-application not yet deployed

だってさ。

これって.Apache+tomcat が起動はしてるって事なのか、それとも起動しても
いないのか‥‥‥
0253233NGNG
>>252

ごめん!Apacheんとこ、コメントアウトしてあった!!
おお〜、起動したぞ!起動したぞ!Tomcat!
0254デフォルトの名無しさんNGNG
ひとり熱いな
0255デフォルトの名無しさんNGNG
>>253
おめ
0256デフォルトの名無しさんNGNG
>>253
うむ、人柱ご苦労。

by THE 他力本願
0257デフォルトの名無しさんNGNG
で、日本語POSTはどうなのよ
0258勉強不足NGNG
TOMCAT設定してるんですけど、TOMCAT立ち上げてもMS-DOS画面がすぐに消えてしまいます。
何でなんでしょう?
ちなみに環境はWIN98、tomcat3.2.4、apacheと連結させています。

0259デフォルトの名無しさんNGNG
>>258
server.xmlかweb.xmlが駄目くさい。
よく確認しる。
0260 NGNG
>>258
エクスプローラからstartup.batダブルクリックしてるでしょ?
じゃなくて、DOS窓開いて、tomcat\bin\にcdして、
startup.bat
って入力してごらん。

ほ〜ら、すぐに終了する原因が分かった!
0261デフォルトの名無しさんNGNG
>>260
多分それやっても無理。tomcat.bat start を直接実行しないことには。
0262勉強不足NGNG
回答ありがとうございます。
>>260
DOS窓からやってるんですけどねぇ・・・・?Microsoft(R) Windows 98
(C)Copyright Microsoft Corp 1981-1999.

C:\>SET TOMCAT_HOME=C:\jakarta-tomcat-3.2.4

C:\>SET JAVA_HOME=C:\jdk1.3.1

C:\>
C:\>cd "c:\jakarta-tomcat-3.2.4"

C:\jakarta-tomcat-3.2.4>bin\startup
Unable to set CLASSPATH dynamically.
Note: To set the CLASSPATH dynamically on Win9x systems
only DOS 8.3 names may be used in TOMCAT_HOME!
Setting your CLASSPATH statically.

Using CLASSPATH: C:\jakarta-tomcat-3.2.4\classes;C:\jakarta-tomcat-3.2.4\lib\ant
.jar;C:\jakarta-tomcat-3.2.4\lib\jasper.jar;C:\jakarta-tomcat-3.2.4\lib\jaxp.jar
;C:\jakarta-tomcat-3.2.4\lib\servlet.jar;C:\jakarta-tomcat-3.2.4\lib\webserver.j
ar;C:\jdk1.3.1\lib\tools.jar

Starting Tomcat in new window
C:\jakarta-tomcat-3.2.4>

とゆう画面出てるのに、tomcatのDOS窓はチラッと出て閉じるんですよ。

0263デフォルトの名無しさんNGNG
>>262
bin\startup の代わりに bin\tomcat.bat run とか打ってみろ。
CATALINA_HOME の設定とかも必要かもしれんが。
0264デフォルトの名無しさんNGNG
>>262
すまん、catalina.bat だったかもしれん。
0265デフォルトの名無しさんNGNG
> Unable to set CLASSPATH dynamically.
> Note: To set the CLASSPATH dynamically on Win9x systems
> only DOS 8.3 names may be used in TOMCAT_HOME!

このメッセージが気になるけど、Win9x+3.2.4だといつも出るの?>他の人
0266勉強不足NGNG
凄い、当たり前の質問なんですけど、導入法ってバージョンによって違うんですよね?
ネットで調べたら、3.2.1だとインストール方法が全く違う・・・。
0267デフォルトの名無しさんNGNG
つか、なんで今更そんな古いバージョンを...
0268勉強不足NGNG
なんか、色々やったら動きました!!
ありがとうございました!!
>>365
クラスパスの設定法を
set TOMCAT_HOME=C:\JAKART~1.4
SET JAVA_HOME=C:\JDK13~1.1
の様にしたら解決しました。
どうやらそれが問題だった様です。ありがとうございました!!
0269デフォルトの名無しさんNGNG



( ゚д゚)ポカーン
( ゚д゚)ンポカーン
( ゚д゚)チンポカーン!!
0270デフォルトの名無しさんNGNG
Windows2000ServerSP3で、
TOMCAT4.1.12とApache1.3.27をCoyoteを使い連携させようと思うのですが、
Apache側の設定の仕方がわかりません。
(TOMCAT4.1はデフォルトで持っているんですよね?)
知っている方教えて下さい。おながいします。
0271デフォルトの名無しさんNGNG
Tomcatで、ディレクトリ一覧を表示させなくする設定ってどうするぽ?
バージョンは1.4です。
0272デフォルトの名無しさんNGNG
>>271
間違った、バージョン4です。
0273デフォルトの名無しさんNGNG
>>271
>>221

過去ログ嫁
0274デフォルトの名無しさんNGNG
猫って、カーソル追っかけてくる、アレ?
0275デフォルトの名無しさんNGNG
Tomcat、4.0系から4.1.12にしたんだけど、何?この監理機能って?
ユーザー登録とか、どうやんの?
0276デフォルトの名無しさんNGNG
別に使わなくてもいいやん
0277275NGNG
>>276
分かんなかったら黙っててね。使ってみたいから聞いてんの。
0278デフォルトの名無しさんNGNG
クス
0279デフォルトの名無しさんNGNG
>>277
ドキュメントは読んだのか?
0280デフォルトの名無しさんNGNG
>>275
とりあえず、tomcat-users.xmlにrole="admin"のユーザを追記してからだな。
あとは見た目でいじれるでしょ。
0281277NGNG
>>275
どーも、サンクス! ログイン出来ました。
0282277NGNG
まちがった、
>>280 でした。
0283デフォルトの名無しさんNGNG
tomcat ってなに?
0284デフォルトの名無しさんNGNG
簡易httpサーバ + サーブレットコンテナ + JSPコンテナ
0285デフォルトの名無しさんNGNG
私的メモ

Tomcat4.1.12で使って入門書の通りHelloWorldを実行したければ
conf/web.xmlをinvokerで検索してコメントアウトを解除せよ。

これにいきなりはまったよ・・・前途多難

0286デフォルトの名無しさんNGNG
セキュリティ上の理由でデフォルト無効になったんだよ
0287デフォルトの名無しさんNGNG
>>286
そうなんだよね〜
初めてなんではまっちゃったよ・・・
0288デフォルトの名無しさんNGNG
フラレ気分でロックンロール、だけの一発屋だったね。
0289デフォルトの名無しさんNGNG
今年のK-1グランプリはもういただいたも同然ですね
0290デフォルトの名無しさんNGNG
Apache1.3.27とTomcat4.1.12を連携させようとしてるんですがうまくいかないのだす。

WebApp Library Configurationを見ると

Application Name          "examples"
Root URL Path             "/examples/"
Local Deployment Path   No local deployment path
Configuration Details     "Application ID: -1"
Connection                  "conn" (details)
Deployed                     FALSE

ってなってて、ダメポいんですが
解決方法わかりませんか?
0291デフォルトの名無しさんNGNG
>>290
俺も Tomcat 4 + mod_app は何度も挑戦してすべて失敗に終わった。
mod_jk 使っとけ。
0292251NGNG
>>290
>>291

俺、成功したんだけど‥‥‥

これってもしかして、Apache2.0だから?
0293デフォルトの名無しさんNGNG
>>292
漏れもできたよ。(Apache1.3.27+Tomcat4.1.12+mod_webapp)
でも>>286を知らんくてしばらくなやんだが。

>>290
>>286のことはちゃんとおさえてるよね?
0294290NGNG
おさえてる。

Apache\error.logをみてみたら
[error] Connection "conn" cannot connect
[error] Cannot open connection "conn"
ってなってるな〜。
0295デフォルトの名無しさんNGNG
>>294
server.xmlでコネクタが有効になってないのでは?
0296293NGNG
とりあえず漏れがうまくいったやつを書いとく。VineLinux2.6R1。

1. autoconf2.5xをインストール(autoconf25で入れたみた。configure --program-suffix=25)
2. Antをインストール
3. # export JAVA_HOME=JDKのホーム
4. http://www.apache.org/dist/apr/ からapr-0.9.1.tar.gzを落とす。
 # pwd
 /tmp
 # tar zxvf apr-0.9.1.tar.gz
 # cd apr-0.9.1
 # ./buildconf
4. http://jakarta.apache.org/builds/jakarta-tomcat-4.0/release/v4.1.12/src/ からjakarta-tomcat-connectors-4.1.12-src.tar.gz を落とす。
 # pwd
 /tmp
 # tar zxvf jakarta-tomcat-connectors-4.1.12-src.tar.gz
 # cd jakarta-tomcat-connectors-4.1.12-src/webapp
 # cp -p support/buildconf.sh support/buildconf25.sh
 support/buildconf25.shのautoconfをautoconf25へ全置換
 # support/buildconf25.sh
 # ./configure --with-apr=/tmp/apr-0.9.1
 # make
 # cp -p apache-1.3/mod_webapp.so /etc/httpd/modules
5. /etc/httpd/conf/httpd.confにその辺のサイトにしたがって追記。
6. /etc/tomcat/server.xmlのコメントになってる<Service name="Tomcat-Apache">を活かす。
0297293NGNG
追加。
環境はApache 1.3.27/Tomcat4.1.12/mod_webapp。

手順の5とか6はぐぐること。
0298デフォルトの名無しさんNGNG
Linux で tomcat 4以降(4.0 でも 4.1 でもいい)を、apache と連携させようと
しているんだけど、tomcat 4 以降は、mod_webapp と mod_jk のどちらを
使えばいいの?(jakarta 側としては、今後どちらを使っていけばいいといっているの?)

あとmod_webapp の作り方は、過去ログや
http://www.t3.rim.or.jp/~yoko-k-h/java/servlet/engines/tomcat4.0.1.html
を見れば載ってるけど、tomcat 4 系列用の mod_jk.so はどうやって作ればいいの?
3系列のバイナリは
http://jakarta.apache.org/builds/jakarta-tomcat/release/v3.2.3/bin/linux/i386/
とかにあるけど、
4系列のディレクトリの下においてないし.....

最近の事情に詳しい方、教えてください。
0299298NGNG
あ、原田さんのところに書いてある方法、ちょっとふるいね。
>>296 の方法じゃないとダメみたい。
0300デフォルトの名無しさんNGNG
Tomcatむかーし使ったきりなんだけど、昔はApacheとTomcatを個別にインストールして手動で連携する必要があった。
(Tomcat単体でもWEBサーバーとして機能するが推奨されなかった)

この状況は今日もかわっていないか?そろそろ何らかの形で統合された?
0301デフォルトの名無しさんNGNG
>>298
jakarta-tomcat-connectors-4.1.12-src.tar.gzを落としたあと、

# tar zxvf jakarta-tomcat-connectors-4.1.12-src.tar.gz
# cd jakarta-tomcat-connectors-4.1.12-src/jk/native
# ./buildconf.sh
# ./configure --with-apxs=/usr/sbin/apxs
# make
# cp -p apache-1.3/mod_jk.so /etc/httpd/modules

あとは適当にmod_jk.confなり作れ。
しかし、>>296の環境にこれを追加しただけなのにマッピングされたパスが全部403になるや。
面倒だからそのままだけど。
0302293NGNG
Struts試してみようと思ってはまったこと。
理屈わかる人いたらフォローよろしく。

 VineLinux2.6R1/Apache 1.3.27/Tomcat4.1.12/mod_webapp/Struts1.0.2

1.よくある解説サイトStruts付属のドキュメントにあるようにwarをwebappsディレクトリに入れてもデプロイされない。
 8080経由でも404 Not Foundになる。(理由はちゃんと見てないが、catalina.outにエラーは出る)

 これを回避するには明示的にserver.xmlに<Context>を追加すればよい。
   <Context path="/struts-example" docBase="/var/tomcat4/webapps/struts-example.war" debug="0"
         reloadable="false" crossContext="true">
   </Context>
 こんな感じ。追加する箇所は適当に判断。

2. <Context>を<Service name="Tomcat-Standalone">のほうへ追加すると8080からは見れるけどApache経由だと未デプロイになる。
 (warではなく、ディレクトリをそのままwebappsにおいた場合はTomcat-Standalone側でもデプロイされていたのはなぜだろう?)
 初期状態のserver.xmlには<Service name="Tomcat-Apache">の下に<Host>がないのでこれを追加しる。
 そのあとで1.の<Context>を追加する。


ディレクトリをwarにまとめないままのときとwarにまとめたときで挙動が違ったので戸惑いますた。
0303293NGNG
Struts試してみようと思ってはまったこと。
理屈わかる人いたらフォローよろしく。

 VineLinux2.6R1/Apache 1.3.27/Tomcat4.1.12/mod_webapp/Struts1.0.2

1.よくある解説サイトStruts付属のドキュメントにあるようにwarをwebappsディレクトリに入れてもデプロイされない。
 8080経由でも404 Not Foundになる。(理由はちゃんと見てないが、catalina.outにエラーは出る)

 これを回避するには明示的にserver.xmlに<Context>を追加すればよい。
   <Context path="/struts-example" docBase="/var/tomcat4/webapps/struts-example.war" debug="0"
         reloadable="false" crossContext="true">
   </Context>
 こんな感じ。追加する箇所は適当に判断。

2. <Context>を<Service name="Tomcat-Standalone">のほうへ追加すると8080からは見れるけどApache経由だと未デプロイになる。
 (warではなく、ディレクトリをそのままwebappsにおいた場合はTomcat-Standalone側でもデプロイされていたのはなぜだろう?)
 初期状態のserver.xmlには<Service name="Tomcat-Apache">の下に<Host>がないのでこれを追加しる。
 そのあとで1.の<Context>を追加する。


ディレクトリをwarにまとめないままのときとwarにまとめたときで挙動が違ったので戸惑いますた。
0304293NGNG
げ。二重書き込みスマソ。
0305デフォルトの名無しさんNGNG
TOMCAT 4.1はJSPコンパイラがShiftJISに対応していないのですか?
みんなどうやって日本語表示やってます?
0306デフォルトの名無しさんNGNG
>>305
ぜんぜんしらんけど、単にデフォルトエンコーディング使っていたのを
外部設定に変更しただけじゃないの?デフォルトがUTF-8で。
追加設定調べたらあるかもよ。

JavaソースコードをShift_JISで書くのやめるほうがよさそう
だが。配置時にAnt使ってnative2ascii通すだけだし。
0307デフォルトの名無しさんNGNG
素朴な質問、サーバーサイドJavaを実務じゃなくて趣味でやってる人います?
Apache、TOMCATそれぞれ色々バージョンもあるし、バグもあるみたいだし
設定も相当大変に思えるのですが、趣味でやってる人はどうやって覚えました?

私は趣味でクライアントサイド+携帯のJavaを2年程やっており、Javaそのものはそこそこわかっているつもりですが・・
0308デフォルトの名無しさんNGNG
>>307
本で覚えました
0309デフォルトの名無しさんNGNG
>>307
身体で覚えました
0310デフォルトの名無しさんNGNG
>>307
趣味でやってますけど、Apache 2.0.43+mod_jk2 2.0.1+Tomcat 4.1.12 を
インストールしてみると、すんなり動きましたよ。
0311デフォルトの名無しさんNGNG
趣味というか卒検でTomcat + Axisで遊んでます。
0312デフォルトの名無しさんNGNG
TOMCAT3.3で簡単なjsp↓
<HTML><BODY><%= new java.util.Date()%></BODY></HTML>
を作ったところ以下のエラーがでます。これはなんでしょう?
ちなみにTOMCAT4ではうまくいったのですが・・

2002-11-27 01:00:38 - Ctx(/bbs) : Exception in R( /bbs + /test.jsp + null) - org.apache.jasper.JasperException: Unable to compile
at org.apache.tomcat.facade.JasperLiaison.javac(JspInterceptor.java:898)
at org.apache.tomcat.facade.JasperLiaison.processJspFile(JspInterceptor.java:733)
at org.apache.tomcat.facade.JspInterceptor.requestMap(JspInterceptor.java:506)
at org.apache.tomcat.core.ContextManager.processRequest(ContextManager.java:968)
at org.apache.tomcat.core.ContextManager.internalService(ContextManager.java:875)
at org.apache.tomcat.core.ContextManager.service(ContextManager.java:833)
at org.apache.tomcat.modules.server.Http10Interceptor.processConnection(Http10Interceptor.java:176)
at org.apache.tomcat.util.net.TcpWorkerThread.runIt(PoolTcpEndpoint.java:494)
at org.apache.tomcat.util.threads.ThreadPool$ControlRunnable.run(ThreadPool.java:516)
at java.lang.Thread.run(Thread.java:536)
0313デフォルトの名無しさんNGNG
%= new
0314デフォルトの名無しさんNGNG
TOMCAPだけでコネクションプール使える方法ってないでしょうか?
0315デフォルトの名無しさんNGNG
TOMCAT 4.1.x 以降ならデフォルトで実装持ってる
0316デフォルトの名無しさんNGNG
>>315
http://jakarta.apache.org/tomcat/tomcat-4.1-doc/jndi-datasource-examples-howto.html

ありがとう、ここに詳しくありました。
4.1.12を使うことにします。
0317デフォルトの名無しさんNGNG
Apache とTomcat4.1.12の連携でmod_webappを作成しようとしています。
296さんの記述を参考にし、
./configure --with-apr=/tmp/apr-0.9.1
まではできたのですが、
makeでエラーが出てしまいます。

BUILD FAILED
file:/tmp/jakarta-tomcat-connectors-4.1.12-src/webapp/build.xml:198: java.lang.ClassNotFoundException: org.apache.tools.ant.taskdefs.optional.TraXLiaison

というものですが、antのクラスが見えてないのでしょうか?
antはパッケージでインストールしました。バージョンは1.5.1です。
0318デフォルトの名無しさんNGNG
WinXP JDK1.4.0_03 Apache Tomcat/4.1.12-LE-jdk14
インストールしてlocahost:8080にアクセス、
TOMCATのページが表示されたので成功だ!とおもいきや
[STOP TOMCAT]してもlocalhost:8080にアクセスできるじゃあありませんか・・

どうやってTOMCAT止めるんですか?
0319デフォルトの名無しさんNGNG
>>318
サービスとして組み込んでないか?
開発中アレやると大変なことに・・・。
0320デフォルトの名無しさんNGNG
>>319
どうやったら「サービスとして組み込む」ことになるのですか?

普通にインストールしただけのはずなのですが・・
途中 2000・XP only のチェックボックスをクリックしましたが、これが原因?
0321デフォルトの名無しさんNGNG
>>319
・・みたいですね、できました、ありがとうございます
0322デフォルトの名無しさんNGNG
214の書いてるエラー、うちでも出るんだけど。
なんでか、だれか知らない?
0323デフォルトの名無しさんNGNG
>>318
もう解決したようだが net stop "Apache Tomcat" だな。
0324296NGNG
>>317
export ANT_HOME=Antのインストールディレクトリ
してからやってみましょう。

./configure --with-apr=/tmp/apr-0.9.1 --without--ant(記憶あいまい)
でもmakeはとおると思うけど、なんかはまった気がするんだよな。
--without-antは違うかもしれん。
./configure --helpでそれっぽいスイッチ探してください。

0325317NGNG
>>324
ありがとうございます。
今日は営業で出っ放しだったので帰ったらもういちど試してみます。
0326デフォルトの名無しさんNGNG
winですが、トムキャット使うならIISより
アパッチの方が良いのでしょうか?
0327名無しさん@EmacsNGNG
>>326
IISかapacheかより、winかwin以外かの方が重要
0328デフォルトの名無しさんNGNG
グラサンがでかい
0329デフォルトの名無しさんNGNG
>>328
玄人指向?
0330デフォルトの名無しさんNGNG
Linuxで4.1.2を動かした場合、
デフォルトの文字コードは何になる?
0331330NGNG
あ、POSTメソッドで受け取った値の事ね。
0332デフォルトの名無しさんNGNG
>>331
受け取った値の文字コードは送り側に依存しますが?
0333330NGNG
>>332
UNICODEに自動変換されたりしないんですか?
0334デフォルトの名無しさんNGNG
>>333
されないと思うけど?
0335デフォルトの名無しさんNGNG
Tomcat 4.1.16 Beta Released
■ このスレッドは過去ログ倉庫に格納されています