TOMCAT
■ このスレッドは過去ログ倉庫に格納されています
0001デフォルトの名無しさん
NGNGしようと思ったんすけど、うまく動きません。ネットで
調べまくって手順も大丈夫なはずなんだけど。
環境
Win2000Pro、Tomcat3.2.3
自宅のWin98SEで同じようにやったら動いた。
Win2000では
C:\tomcat\bin>tomcat run
Including all jars in c:\tomcat\lib in your CLASSPATH.
Using CLASSPATH: c:\tomcat\classes;c:\tomcat\lib\ant.jar;c:\tomcat\lib\jasper.ja
r;c:\tomcat\lib\jaxp.jar;c:\tomcat\lib\parser.jar;c:\tomcat\lib\servlet.jar;c:\t
omcat\lib\webserver.jar;c:\tomcat\classes;c:\tomcat\lib\ant.jar;c:\tomcat\lib\ja
sper.jar;c:\tomcat\lib\jaxp.jar;c:\tomcat\lib\parser.jar;c:\tomcat\lib\servlet.j
ar;c:\tomcat\lib\webserver.jar;c:\tomcat\lib\servlet.jar;c:\jdk1.3\lib\tools.jar
;c:\jdk1.3\lib\tools.jar
Exception in thread "main" java.lang.NoSuchMethodError
at org.apache.tomcat.startup.Tomcat.getConfigFile(Tomcat.java:116)
at org.apache.tomcat.startup.Tomcat.execute(Tomcat.java:141)
at org.apache.tomcat.startup.Tomcat.main(Tomcat.java:163)
C:\tomcat\bin>
こういうエラーが出ます。パスもJAVA_HOME、TOMCAT_HOME通した。
クラスパスも通ってるはず。なでしょう?
0207デフォルトの名無しさん
NGNG0208デフォルトの名無しさん
NGNG>コネクション死んだときにただのclose()だとプールに戻るだけで延々死んだ
>接続を繰り返し渡されるので鬱になった。
そんなことはない。
DBCPはObjectPool#borrowObject()とObjectPool#returnObject()時に
生きているかチェックできる。
さらに、別スレッドでpooling中のものが生きているかもチェックできる。
ただし、DBCPの開始時に初期pool数を設定できないのは激しく鬱。
0209デフォルトの名無しさん
NGNG立ち上がらなくなるんですがなぜですか?
ちなみにWinXPです。これじゃディレクトリ増やせない。。。
0210デフォルトの名無しさん
NGNG0211206
NGNGあー、確かに JDBCリソースにvalidationQuery定義しとけば borrowの
タイミングで接続の妥当性チェックできるんだね。(returnの時はできない模様)
下手にreallyClose自分で呼んじゃうとPool Exhaust引き起こすようだ
0212デフォルトの名無しさん
NGNG0213デフォルトの名無しさん
NGNGおいらは古いのでやっとります。
Apache 1.3.26
J2SE 1.3.1_04
Tomcat 4.0.4
Struts 1.0.2
0214デフォルトの名無しさん
NGNGWEB-INF/libにtldファイルを置くんだけども、
2002-09-26 12:04:26 ContextConfig[/testApp] Exception processing TLD at resource path /WEB-INF/dbtags.tld
javax.servlet.ServletException: Exception processing TLD at resource path /WEB-INF/dbtags.tld
at org.apache.catalina.startup.ContextConfig.tldScanTld(ContextConfig.java:1010)
at org.apache.catalina.startup.ContextConfig.tldScan(ContextConfig.java:870)
(以下略)
とかいうふうになってしまうよ。4.0系は大丈夫なのにね。
環境はWin2K/jdk1.3.1_01/Tomcat4.1.12。
0215デフォルトの名無しさん
NGNG0216デフォルトの名無しさん
NGNGsunのservlet研修で使われてるのをしってる
みんなはservlet配置した後かならずweb.xml書きかえるの?
俺はめんどいからしないけど
0217デフォルトの名無しさん
NGNGhttp://host/hoge/などにアクセスされた場合、index.htmlなどが置いてないとディレクトリ内の
ファイル一覧が表示されてしまいます。
これを禁止するにはどこを設定すればよいのでしょう?
ApacheだとOption indexesとかだと思うんですが…
0218Linus
NGNG「全然 Write it Once, Run Anywhereじゃねーじゃん!」とぼやいて、いろいろ調べても
"WARファイルを/webappsに置け"としか書いていない。
さて、どこがいけないんでしょう?ちなみにTomcat自体は正常に動作しております。
環境は以下のとおりです。
RedHat 7.3
J2SDK1.4.1FCS
tomcat4.1.10(rpm)
もちろん最終的には解決したんだけどみんなにこの問題を共有したいのさ。
0219デフォルトの名無しさん
NGNG0220Linus
NGNGあたり
こんなのに1時間悩んだ俺はかなり厨房です。
0221デフォルトの名無しさん
NGNGdefault サーブレットで提供されてるリソースだったら
init-param の listings を false にすれ ($TOMCAT_HOME/conf/web.xml)
0222217
NGNGできますた!!
大感謝 m(_ _)m
これで個人情報流出せずに済みます。
0223デフォルトの名無しさん
NGNGlistingをfalse=個人情報を守る
という図式はうそだぞ。
listingしてなくてもファイルは取得できるからな。
0224222
NGNGはい、個人情報流出うんぬんは冗談です。
基本的にはDBでデータ持っているんで、リスティングされても実害は無かったんですが、
クライアントに対する印象が悪くなるといかんと思いまして。
0225デフォルトの名無しさん
NGNG0226デフォルトの名無しさん
NGNG一般ユーザーの使っている別のメインサーバのファイルをautofsで
Webサーバにマウントして、apacheのmod_userと同様に http://hostname/~hoge/*.jsp
と言う具合に公開できるようにとserver.xmlに
<Listener className="org.apache.catalina.startup.UserConfig"
directoryName="public_html"
homeBase="/home"
userClass="org.apache.catalina.startup.HomesUserDatabase"/>
と加えたんですが、NFSでマウントしているユーザーは
Error initializing resources: Document base /home/hoge/public_html doesnot exist or is not a readable directory
と言う感じでエラーを出して利用することができません。
(apacheからはNFSのユーザーのファイルでも問題なく利用できている)
だれか、対策を知っている人教えていただけないでしょうか?
ちなみにOSは両方ともSolarisです
0227名無しさん@Emacs
NGNGJavaのプロセスからファイルにアクセスする場合は、
そのプロセスの権限でしかアクセスできませんが
0228デフォルトの名無しさん
NGNGサーブレットを動かすたびにlogs配下のcatalina.outファイルに
too many initiarized
というメッセージが書き込まれます。何のことなのか良く分からないのですが
知ってる方がいたら教えてください。
0229デフォルトの名無しさん
NGNG1. ソース版をダウンロード
2. "too many initialized" で検索
3. ヒットした前後で何をやっているか調べる
0230デフォルトの名無しさん
NGNG4.1.x 系についてはまだ開発中とのこと。
とにかく invoker は disable しとけ>all
0231デフォルトの名無しさん
NGNGなんか無くても動いてんだけど
0232デフォルトの名無しさん
NGNG自作ライブラリを更新した場合、tomcatも再起動しないと
更新が反映されないようです。
beans、jspはそのまま使えるのですが。
そういうものなんでしょうか?
0233はじめてなの
NGNG参考書は、日経Linuxの9月号。「Apache2.0を使ったWebサイトの構築
と運用」
応援よろしく!
0234233
NGNGSquid で8080使ってるぞ。どうしよう
とりあえず、現状のままやってみて、ダメならSquidのポート換えるか
0235デフォルトの名無しさん
NGNG代えればいいじゃん、ポート…
0236デフォルトの名無しさん
NGNG管理画面が出来て良い感じになってるね。
0237233
NGNGそうしないと、ダメみたいね。
squidポートを換えるのは簡単だが、Windowsクライアントの設定変更
が結構めんどうっぽい(泣)
透過型串にしとけばよかったなぁ‥‥
0238デフォルトの名無しさん
NGNG0239デフォルトの名無しさん
NGNG0240233
NGNG今日、TOMCAT初体験なんで‥‥‥‥
squidの方、変えちゃったYO
my_web_server:8080で、TOMCAT起動に成功しました〜!
0241デフォルトの名無しさん
NGNG0242デフォルトの名無しさん
NGNG0243デフォルトの名無しさん
NGNG0244233
NGNGまぁ、それはsquidの変更やっちゃったんで、パスさせて
mod_webappのコンパイルでけつまづいてましゅ。
なんだよAPRソースって?
>>233のとおり、参考にしてんのは日経Linuxの9月号で、付録のCD-ROM
から、jakarta-tomcat-4.0.4.tar.gz、jakarta-tomcat-connectors-4.0.2-01-src.tar.gz
を使ってる。まぁ、せっかく付いてきたし、上手く動いたらバージョンアップしよう
と思ったんだが、jakarta-tomcat-connectors-4.0.2-01-src/webappのconfigure
がダメじゃん。
なんかAPRソースがいるとかメッセージでてるし、jakarta-tomcatにもそんな
ことが書いてるんだけど、日経linuxの記事にゃ書いてない。
ほんとにこの記者、これでコンパイルできだんだろうか?
参ったなぁ。
0245デフォルトの名無しさん
NGNG0246デフォルトの名無しさん
NGNG0247233
NGNGmod_jk って、4.0.4でも使える?
明日、試してみるつもりなんだけど‥‥‥
0248デフォルトの名無しさん
NGNGWebサーバーのルートにIndex.jspを
どうやっておけばいいの?
/test/index.jspとかはいけるんですが・・・
0249デフォルトの名無しさん
NGNG0250デフォルトの名無しさん
NGNG0251233
NGNGなんかデキちゃったよ(藁)
jakarta-tomcat-4.1.12.tar.gz と jakarta-tomcat-connectors-4.1.12-src.tar.gz
をダウンロードして、jakarta-tomcat-4.1.12.tar.gzを展開。
jakarta-tomcat-connectors-4.1.12-src.tar.gzも展開して、configureしたら、
makeが通って、mod_webapp.soがデキちゃったと‥‥‥
さぁ、これからこれを、Apacheに組み込んでみよ〜っと。
何が出るかな?何が出るかな?エラーかな?OKかな?どきどき‥‥‥
0252233
NGNGWebApp: Error 404
(File: /src/jakarta-tomcat-connectors-4.1.12-src/webapp/lib/wa_request.c Line: 205)
Web-application not yet deployed
だってさ。
これって.Apache+tomcat が起動はしてるって事なのか、それとも起動しても
いないのか‥‥‥
0253233
NGNGごめん!Apacheんとこ、コメントアウトしてあった!!
おお〜、起動したぞ!起動したぞ!Tomcat!
0254デフォルトの名無しさん
NGNG0255デフォルトの名無しさん
NGNGおめ
0256デフォルトの名無しさん
NGNGうむ、人柱ご苦労。
by THE 他力本願
0257デフォルトの名無しさん
NGNG0258勉強不足
NGNG何でなんでしょう?
ちなみに環境はWIN98、tomcat3.2.4、apacheと連結させています。
0259デフォルトの名無しさん
NGNGserver.xmlかweb.xmlが駄目くさい。
よく確認しる。
エクスプローラからstartup.batダブルクリックしてるでしょ?
じゃなくて、DOS窓開いて、tomcat\bin\にcdして、
startup.bat
って入力してごらん。
ほ〜ら、すぐに終了する原因が分かった!
0261デフォルトの名無しさん
NGNG多分それやっても無理。tomcat.bat start を直接実行しないことには。
0262勉強不足
NGNG>>260
DOS窓からやってるんですけどねぇ・・・・?Microsoft(R) Windows 98
(C)Copyright Microsoft Corp 1981-1999.
C:\>SET TOMCAT_HOME=C:\jakarta-tomcat-3.2.4
C:\>SET JAVA_HOME=C:\jdk1.3.1
C:\>
C:\>cd "c:\jakarta-tomcat-3.2.4"
C:\jakarta-tomcat-3.2.4>bin\startup
Unable to set CLASSPATH dynamically.
Note: To set the CLASSPATH dynamically on Win9x systems
only DOS 8.3 names may be used in TOMCAT_HOME!
Setting your CLASSPATH statically.
Using CLASSPATH: C:\jakarta-tomcat-3.2.4\classes;C:\jakarta-tomcat-3.2.4\lib\ant
.jar;C:\jakarta-tomcat-3.2.4\lib\jasper.jar;C:\jakarta-tomcat-3.2.4\lib\jaxp.jar
;C:\jakarta-tomcat-3.2.4\lib\servlet.jar;C:\jakarta-tomcat-3.2.4\lib\webserver.j
ar;C:\jdk1.3.1\lib\tools.jar
Starting Tomcat in new window
C:\jakarta-tomcat-3.2.4>
とゆう画面出てるのに、tomcatのDOS窓はチラッと出て閉じるんですよ。
0263デフォルトの名無しさん
NGNGbin\startup の代わりに bin\tomcat.bat run とか打ってみろ。
CATALINA_HOME の設定とかも必要かもしれんが。
0264デフォルトの名無しさん
NGNGすまん、catalina.bat だったかもしれん。
0265デフォルトの名無しさん
NGNG> Note: To set the CLASSPATH dynamically on Win9x systems
> only DOS 8.3 names may be used in TOMCAT_HOME!
このメッセージが気になるけど、Win9x+3.2.4だといつも出るの?>他の人
0266勉強不足
NGNGネットで調べたら、3.2.1だとインストール方法が全く違う・・・。
0267デフォルトの名無しさん
NGNG0268勉強不足
NGNGありがとうございました!!
>>365
クラスパスの設定法を
set TOMCAT_HOME=C:\JAKART~1.4
SET JAVA_HOME=C:\JDK13~1.1
の様にしたら解決しました。
どうやらそれが問題だった様です。ありがとうございました!!
0269デフォルトの名無しさん
NGNG( ゚д゚)ポカーン
( ゚д゚)ンポカーン
( ゚д゚)チンポカーン!!
0270デフォルトの名無しさん
NGNGTOMCAT4.1.12とApache1.3.27をCoyoteを使い連携させようと思うのですが、
Apache側の設定の仕方がわかりません。
(TOMCAT4.1はデフォルトで持っているんですよね?)
知っている方教えて下さい。おながいします。
0271デフォルトの名無しさん
NGNGバージョンは1.4です。
0272デフォルトの名無しさん
NGNG間違った、バージョン4です。
0273デフォルトの名無しさん
NGNG>>221
過去ログ嫁
0274デフォルトの名無しさん
NGNG0275デフォルトの名無しさん
NGNGユーザー登録とか、どうやんの?
0276デフォルトの名無しさん
NGNG0277275
NGNG分かんなかったら黙っててね。使ってみたいから聞いてんの。
0278デフォルトの名無しさん
NGNG0279デフォルトの名無しさん
NGNGドキュメントは読んだのか?
0280デフォルトの名無しさん
NGNGとりあえず、tomcat-users.xmlにrole="admin"のユーザを追記してからだな。
あとは見た目でいじれるでしょ。
0281277
NGNGどーも、サンクス! ログイン出来ました。
0282277
NGNG>>280 でした。
0283デフォルトの名無しさん
NGNG0284デフォルトの名無しさん
NGNG0285デフォルトの名無しさん
NGNGTomcat4.1.12で使って入門書の通りHelloWorldを実行したければ
conf/web.xmlをinvokerで検索してコメントアウトを解除せよ。
これにいきなりはまったよ・・・前途多難
0286デフォルトの名無しさん
NGNG0287デフォルトの名無しさん
NGNGそうなんだよね〜
初めてなんではまっちゃったよ・・・
0288デフォルトの名無しさん
NGNG0289デフォルトの名無しさん
NGNG0290デフォルトの名無しさん
NGNGWebApp Library Configurationを見ると
Application Name "examples"
Root URL Path "/examples/"
Local Deployment Path No local deployment path
Configuration Details "Application ID: -1"
Connection "conn" (details)
Deployed FALSE
ってなってて、ダメポいんですが
解決方法わかりませんか?
0291デフォルトの名無しさん
NGNG俺も Tomcat 4 + mod_app は何度も挑戦してすべて失敗に終わった。
mod_jk 使っとけ。
0293デフォルトの名無しさん
NGNG漏れもできたよ。(Apache1.3.27+Tomcat4.1.12+mod_webapp)
でも>>286を知らんくてしばらくなやんだが。
>>290
>>286のことはちゃんとおさえてるよね?
0294290
NGNGApache\error.logをみてみたら
[error] Connection "conn" cannot connect
[error] Cannot open connection "conn"
ってなってるな〜。
0295デフォルトの名無しさん
NGNGserver.xmlでコネクタが有効になってないのでは?
0296293
NGNG1. autoconf2.5xをインストール(autoconf25で入れたみた。configure --program-suffix=25)
2. Antをインストール
3. # export JAVA_HOME=JDKのホーム
4. http://www.apache.org/dist/apr/ からapr-0.9.1.tar.gzを落とす。
# pwd
/tmp
# tar zxvf apr-0.9.1.tar.gz
# cd apr-0.9.1
# ./buildconf
4. http://jakarta.apache.org/builds/jakarta-tomcat-4.0/release/v4.1.12/src/ からjakarta-tomcat-connectors-4.1.12-src.tar.gz を落とす。
# pwd
/tmp
# tar zxvf jakarta-tomcat-connectors-4.1.12-src.tar.gz
# cd jakarta-tomcat-connectors-4.1.12-src/webapp
# cp -p support/buildconf.sh support/buildconf25.sh
support/buildconf25.shのautoconfをautoconf25へ全置換
# support/buildconf25.sh
# ./configure --with-apr=/tmp/apr-0.9.1
# make
# cp -p apache-1.3/mod_webapp.so /etc/httpd/modules
5. /etc/httpd/conf/httpd.confにその辺のサイトにしたがって追記。
6. /etc/tomcat/server.xmlのコメントになってる<Service name="Tomcat-Apache">を活かす。
0297293
NGNG環境はApache 1.3.27/Tomcat4.1.12/mod_webapp。
手順の5とか6はぐぐること。
0298デフォルトの名無しさん
NGNGしているんだけど、tomcat 4 以降は、mod_webapp と mod_jk のどちらを
使えばいいの?(jakarta 側としては、今後どちらを使っていけばいいといっているの?)
あとmod_webapp の作り方は、過去ログや
http://www.t3.rim.or.jp/~yoko-k-h/java/servlet/engines/tomcat4.0.1.html
を見れば載ってるけど、tomcat 4 系列用の mod_jk.so はどうやって作ればいいの?
3系列のバイナリは
http://jakarta.apache.org/builds/jakarta-tomcat/release/v3.2.3/bin/linux/i386/
とかにあるけど、
4系列のディレクトリの下においてないし.....
最近の事情に詳しい方、教えてください。
0300デフォルトの名無しさん
NGNG(Tomcat単体でもWEBサーバーとして機能するが推奨されなかった)
この状況は今日もかわっていないか?そろそろ何らかの形で統合された?
0301デフォルトの名無しさん
NGNGjakarta-tomcat-connectors-4.1.12-src.tar.gzを落としたあと、
# tar zxvf jakarta-tomcat-connectors-4.1.12-src.tar.gz
# cd jakarta-tomcat-connectors-4.1.12-src/jk/native
# ./buildconf.sh
# ./configure --with-apxs=/usr/sbin/apxs
# make
# cp -p apache-1.3/mod_jk.so /etc/httpd/modules
あとは適当にmod_jk.confなり作れ。
しかし、>>296の環境にこれを追加しただけなのにマッピングされたパスが全部403になるや。
面倒だからそのままだけど。
0302293
NGNG理屈わかる人いたらフォローよろしく。
VineLinux2.6R1/Apache 1.3.27/Tomcat4.1.12/mod_webapp/Struts1.0.2
1.よくある解説サイトStruts付属のドキュメントにあるようにwarをwebappsディレクトリに入れてもデプロイされない。
8080経由でも404 Not Foundになる。(理由はちゃんと見てないが、catalina.outにエラーは出る)
これを回避するには明示的にserver.xmlに<Context>を追加すればよい。
<Context path="/struts-example" docBase="/var/tomcat4/webapps/struts-example.war" debug="0"
reloadable="false" crossContext="true">
</Context>
こんな感じ。追加する箇所は適当に判断。
2. <Context>を<Service name="Tomcat-Standalone">のほうへ追加すると8080からは見れるけどApache経由だと未デプロイになる。
(warではなく、ディレクトリをそのままwebappsにおいた場合はTomcat-Standalone側でもデプロイされていたのはなぜだろう?)
初期状態のserver.xmlには<Service name="Tomcat-Apache">の下に<Host>がないのでこれを追加しる。
そのあとで1.の<Context>を追加する。
ディレクトリをwarにまとめないままのときとwarにまとめたときで挙動が違ったので戸惑いますた。
0303293
NGNG理屈わかる人いたらフォローよろしく。
VineLinux2.6R1/Apache 1.3.27/Tomcat4.1.12/mod_webapp/Struts1.0.2
1.よくある解説サイトStruts付属のドキュメントにあるようにwarをwebappsディレクトリに入れてもデプロイされない。
8080経由でも404 Not Foundになる。(理由はちゃんと見てないが、catalina.outにエラーは出る)
これを回避するには明示的にserver.xmlに<Context>を追加すればよい。
<Context path="/struts-example" docBase="/var/tomcat4/webapps/struts-example.war" debug="0"
reloadable="false" crossContext="true">
</Context>
こんな感じ。追加する箇所は適当に判断。
2. <Context>を<Service name="Tomcat-Standalone">のほうへ追加すると8080からは見れるけどApache経由だと未デプロイになる。
(warではなく、ディレクトリをそのままwebappsにおいた場合はTomcat-Standalone側でもデプロイされていたのはなぜだろう?)
初期状態のserver.xmlには<Service name="Tomcat-Apache">の下に<Host>がないのでこれを追加しる。
そのあとで1.の<Context>を追加する。
ディレクトリをwarにまとめないままのときとwarにまとめたときで挙動が違ったので戸惑いますた。
0304293
NGNG0305デフォルトの名無しさん
NGNGみんなどうやって日本語表示やってます?
0306デフォルトの名無しさん
NGNGぜんぜんしらんけど、単にデフォルトエンコーディング使っていたのを
外部設定に変更しただけじゃないの?デフォルトがUTF-8で。
追加設定調べたらあるかもよ。
JavaソースコードをShift_JISで書くのやめるほうがよさそう
だが。配置時にAnt使ってnative2ascii通すだけだし。
0307デフォルトの名無しさん
NGNGApache、TOMCATそれぞれ色々バージョンもあるし、バグもあるみたいだし
設定も相当大変に思えるのですが、趣味でやってる人はどうやって覚えました?
私は趣味でクライアントサイド+携帯のJavaを2年程やっており、Javaそのものはそこそこわかっているつもりですが・・
■ このスレッドは過去ログ倉庫に格納されています