JAVA+JSP+Struts+Tomcat Part3
■ このスレッドは過去ログ倉庫に格納されています
0001965
2006/10/26(木) 20:41:360730デフォルトの名無しさん
2007/04/29(日) 18:03:00ってどのくらいの差なんだろう?
それなりにページビュー多いサイトをTomcatのみで運用してるけど、
今のところ全然問題ない感じ。
実はあんまり変わらないのでは?
0731デフォルトの名無しさん
2007/04/29(日) 18:13:54>「静的コンテンツはTomcatよりApacheのほうが速い」
って昔話じゃないのか?
「Vineが初心者向け」
とかと一緒かと
だいたいAPR使ってる段階でtomcatの方が機能の少ない分早くても不思議じゃないと思うが・・
もっとも検証する程クリティカルな場面に遭遇していないので想像だがな
0733デフォルトの名無しさん
2007/04/29(日) 18:51:15使用しているAPI的には同じなわけだから、ランタイム自体も賢くなってるのかも。
0734デフォルトの名無しさん
2007/04/29(日) 19:19:27glassfishってアプリ鯖とは思えない起動の早さだよな
WebSphereとかOracleASとかBorlandASとか触ってた俺にとって衝撃的だった
ただ、Apacheとの連携はどーすんの?
わからないのでただのリバースプロキシにしてるけど、JPAとJMSくらいしか使わないので
Tomcatでもいいかなと最近また思い始めてる
>>728
勘違いしてないか?
>>731
Vineは今でも日本語資料の豊富さと安定度でお勧めしやすいと思うが
SuseとかRHELとかはサポートは入らないと敷居が高い
つーかSuseはかなり独特だな
0735デフォルトの名無しさん
2007/04/29(日) 20:58:110736デフォルトの名無しさん
2007/04/29(日) 21:12:26glassfishはサーブレットコンテナはtomcatベースだから問題のおき方もtomcatと同じ
0737デフォルトの名無しさん
2007/04/29(日) 23:28:310738デフォルトの名無しさん
2007/04/29(日) 23:37:43Tomcat+Apacheの連携が必要なのは、ロードバランスが必要なときだけ
って考えても問題ないよね?
0739デフォルトの名無しさん
2007/04/29(日) 23:46:070740デフォルトの名無しさん
2007/04/29(日) 23:57:48WEB鯖としては機能が違いすぎる
あとhttpにたいしてhttpsのリクエストやその逆の問題はずっとなおってないから直はやめとけ
0741デフォルトの名無しさん
2007/04/30(月) 00:41:350742デフォルトの名無しさん
2007/04/30(月) 00:45:420743デフォルトの名無しさん
2007/04/30(月) 05:40:26だけどそんな使い方竹刀なら放置で桶
0744デフォルトの名無しさん
2007/04/30(月) 11:57:47Tomcat6.0をインストールしようと思い、前verをアンインストールし、6.0をインストールしようとしたところ、
途中で以下エラーが出てしまいます。どうすればよいでしょうか?
UsingJvm: C:Program Files\Java\jdk1.6.0_01\jre\bin\server\jvm.dll となっているところで
Failed to installTomcat5 service.Checkyour settings and permissions Ignore and....
0745744
2007/04/30(月) 12:01:07Failed to install Tomcat5 、、 → 、、Tomcat6、、
0746デフォルトの名無しさん
2007/04/30(月) 12:03:56OSとは?
それとエラーメッセージはそれで全部?
0747デフォルトの名無しさん
2007/04/30(月) 12:50:140748デフォルトの名無しさん
2007/04/30(月) 15:54:360749744
2007/04/30(月) 17:15:41OSはxpです。
エラーメッセージの続きは、
and continue anyway (not recommended) ?
です。
>>747
最終手段として実行しようと思います。。
>>748
単にzip解凍のみでよいのでしょうか?
0750デフォルトの名無しさん
2007/04/30(月) 17:54:23開発環境は、新バージョンでるたびに入れ替えたり、複数バージョンを同時に使ったりするから、解凍するだけで使えるものがあればそっちのほうがいいと思う。
0751デフォルトの名無しさん
2007/04/30(月) 18:29:39サービスを登録に言ったときに管理者権限がないとかじゃ?
実際インストーラーは使わんし
>>750が普通だよ、たぶん
運用環境としてはserviceにしたいかもsれんがね
0752デフォルトの名無しさん
2007/04/30(月) 18:43:55アンインストールの時、前のサービスを登録解除していないとか。
0753デフォルトの名無しさん
2007/04/30(月) 18:53:33>>749ではないが、
サービスの二重登録ってエラーになるんだ
あんまり、winは使わんのでためになった
0754デフォルトの名無しさん
2007/04/30(月) 19:11:35「権限がおかしい」に一票
0755744
2007/04/30(月) 19:20:16バッチを起動しても動作しません。。
以後、ver入れ替えの際は気をつけます。
>>751,752
そのようです。単に前verのフォルダを削除しただけです、、。
「管理ツール」-「サービス」を見ると前verが残ったままです。
登録解除はどのようにすればよいのでしょうか?
0756デフォルトの名無しさん
2007/04/30(月) 19:38:47それなら初心者向けの説明としては
「古いバージョンをもう一度入れて消す」
0757デフォルトの名無しさん
2007/04/30(月) 19:53:47ってだめなん?
0758デフォルトの名無しさん
2007/04/30(月) 20:08:28だからそれは手遅れ
0759デフォルトの名無しさん
2007/04/30(月) 20:08:47すでにサービスとして動いてるからバッチ起動でダメなんだろ。
0760デフォルトの名無しさん
2007/04/30(月) 20:11:04同じバージョンのzipを、そのフォルダに解凍するとか。
0761デフォルトの名無しさん
2007/04/30(月) 21:02:410762デフォルトの名無しさん
2007/04/30(月) 21:03:200763デフォルトの名無しさん
2007/05/01(火) 15:35:35<message-resources parameter="MessageResources" />
について質問です
MessageResources.propertiesと一緒に他のpropertiesファイルを使用するにはどうすればよいですか?
1.2.9だと同じようにタグ追加すればできたけど、1.3.8だとMessageResources.propertiesすら読み込まなくなってしまいます
0764デフォルトの名無しさん
2007/05/01(火) 21:57:31Webアプリなんかだとファイルの取得が絶対パス指定になったりしてそれぞれの環境に依存してしまうのですが、
ServletContext#getRealPathとか呼べないクラスから読み込みたいときはどうするのがセオリーなのでしょうか。
0765デフォルトの名無しさん
2007/05/01(火) 22:10:060766デフォルトの名無しさん
2007/05/02(水) 02:31:460767763
2007/05/02(水) 09:03:110768デフォルトの名無しさん
2007/05/02(水) 19:59:430769デフォルトの名無しさん
2007/05/02(水) 21:03:26csvファイルに変換したいのだが・・・。
どうしてもcsv変換後は前と(セルの中身)配置が違う。
どうしたらいいんだ〜!誰か・・エレガントな
ロジックをおしえてくれぇぇ!!
読み込みにはPOIを使用してます。
0770デフォルトの名無しさん
2007/05/02(水) 21:07:000771デフォルトの名無しさん
2007/05/03(木) 05:57:570772デフォルトの名無しさん
2007/05/03(木) 23:55:40user.base が"/"文字で始まりません
といったエラーが発生
sturts-configでは
action
<forward name="success" path="user.base" />
<plug-in className="org.apache.struts.tiles.TilesPlugin" >
<set-property property="definitions-config"
value="/WEB-INF/tiles-defs.xml" />
<set-property property="moduleAware" value="true" />
</plug-in>
tiles-defs.xml
<tiles-definitions>
<definition name="user.base" path="/layout.jsp">
</definition>
</tiles-definitions>
web.xmlにも
<init-param>
<param-name>chainConfig</param-name>
<param-value>org/apache/struts/tiles/chain-config.xml</param-value>
</init-param>
を追加したけどわからないっす。
0773772
2007/05/04(金) 11:32:05本当に申し訳ありません
0774デフォルトの名無しさん
2007/05/04(金) 13:33:25Strutsが一段落してから、DIやらSpring、Seasor、AOP…なんつーものがセットで出てきたと思うんだが、
今でもいけてるんか?
さらっと概要を流し読みしたが、努力して覚える価値があるほど、すごいもんなんか?
0775デフォルトの名無しさん
2007/05/04(金) 19:11:13DIもなかなか便利なので、あるなら使いたい。
すごいものじゃないけど、コーディング作業全体が少しずつ楽になるから、トータルではかなりの楽。
今ならEJB3+JSFだな。
0776デフォルトの名無しさん
2007/05/04(金) 19:27:35Strutsと挙げられた記述は競合するものじゃないんじゃない?
0777デフォルトの名無しさん
2007/05/04(金) 20:14:27APサーバのJSF+EJB3のオールインワンで済ませるかの二択だろうな
自由度が高いのは前者・教育コストが低いのは後者
0778デフォルトの名無しさん
2007/05/04(金) 22:04:26フレームワークが推進されているけど、再利用性ってどうよ?
実際、ビジネスロジックの再利用ってしたことある人どれだけいる?
他のプロジェクトや同一業務で流用して、胸をはってコスト削減に寄与したって言える?
薄っぺらいフレームワークとかユーティリティしかできんのだが…
そもそも、部品化されたとしても、それを公開する運用がない…
どうも、再利用に関しては、投資したもの(金、時間、モチベーション)に対する
対価が得られていないような気がする…などと考えてしまう今年のGW。
0779デフォルトの名無しさん
2007/05/04(金) 22:14:42・・・それは主に設計〜実装中の話なんだよ。
案件を超えた再利用
・・・それはパケージ化して横展開してウハウハするか、
・・・さもなければ、みんなの心の中にある(経験、ノウハウの)再利用なんだよw
0780デフォルトの名無しさん
2007/05/04(金) 22:20:31ビジネスロジックは再利用するものではないような。
むしろ、ルールと実装を分離して
業務ルールの変更に迅速に対応できるようにするのが肝かと。
> 薄っぺらいフレームワークとかユーティリティしかできんのだが…
> そもそも、部品化されたとしても、それを公開する運用がない…
だからオプソがあるんだろうw
0781デフォルトの名無しさん
2007/05/04(金) 22:23:19Velocityとかよりも速くてよりPOHPなVIEWがほしいところ
0782デフォルトの名無しさん
2007/05/04(金) 22:26:58ビルドして実行可能にする過程が「生産」だ
などという話もあったが、
実際に多くの人に影響力を与えるのは、
・トップベンダーが強く推す(環境〜ライブラリ)と、
・高い流通性を持ったオープンソースと、
・設計・実装上の問題解決ノウハウ
なのではないか。
と言ってみるテスト
0783デフォルトの名無しさん
2007/05/04(金) 22:44:13PHPみたいなのが相手ならJSPだけで作ればいいだけじゃ?
0784デフォルトの名無しさん
2007/05/04(金) 22:51:24そっか、ビジネスロジックは再利用するもんじゃないのか。
じゃ、再利用とか言ってる人は、何を再利用しろって言うんだ?
779の言うように、プログラム生産物としての再利用ってのはないのか。
0785デフォルトの名無しさん
2007/05/04(金) 23:04:590786デフォルトの名無しさん
2007/05/04(金) 23:10:07俺もちょっと驚いた
Reports: Microsoft Pursuing Yahoo
http://biz.yahoo.com/ap/070504/microsoft_yahoo.html?.v=6
0787デフォルトの名無しさん
2007/05/04(金) 23:28:07Javaの世界に限らんと思うが、設計段階でビジネスロジックを分離できてるシステム
分離できてないシステムがあったとして、分離できてるならフレームワークから
呼び出すだけだし、分離できてなかったら、フレームワークの流儀に従って
分離して、今後の保守性や再利用性を上げるって事だろ。
JSPの頃みたいに、htmlの中にロジック書いたところでグダグダになるだろうしな。
対価が得られていないのは藻前の設計に難があるって事じゃねーの?
0788デフォルトの名無しさん
2007/05/04(金) 23:32:03で、何の再利用性をあげるんだ?
0789デフォルトの名無しさん
2007/05/04(金) 23:41:560790デフォルトの名無しさん
2007/05/04(金) 23:53:530791デフォルトの名無しさん
2007/05/05(土) 00:21:58綺麗にキャッシュできないのは何が原因なんだろう。
JSPのコンパイル後のソースを見る分には同等の速度は難しくないと思うんだが。
0792デフォルトの名無しさん
2007/05/05(土) 03:45:390793デフォルトの名無しさん
2007/05/07(月) 23:15:39特に決裁系とかさ。稟議なんてどこの企業でもやってるビジネスロジック。
SAPみたいにシステムのためにビジネスを変えさせて嵌め込むというのもありと思う。
0794デフォルトの名無しさん
2007/05/08(火) 01:29:51チラシの裏にどうぞ
0795デフォルトの名無しさん
2007/05/10(木) 13:29:27URLEncoder.encode("\uE757", "Windows-31J")
このように書くと、%F9%FC として正しく変換されるのですが
URLEncoder.encode("\uE758", "Windows-31J")
と書くと、%3F となって ? に変換されてしまいます。
これを正しく変換させるにはどうしたらいいのでしょうか?
0796デフォルトの名無しさん
2007/05/10(木) 13:59:37同じWindowsでもmeと2000で表示できたりできなかったりするようなやつだから変換できないのは正しいような
0797795
2007/05/10(木) 15:38:42レスありがとうございます。
外字領域というのがあるんですね。
どうやらその領域だとWindows-31Jが対応してないみたいなので無理みたいですね‥
0798デフォルトの名無しさん
2007/05/11(金) 01:12:17Tomcat上のWebアプリの中で(Javaコードで)、リクエスト転送元のApacheが
動作しているPCのホスト名またはIPアドレスを取得する方法ってあるのでしょうか?
0799デフォルトの名無しさん
2007/05/11(金) 01:31:29ServletRequest#getServerNameでいいんじゃね?
0800798
2007/05/11(金) 08:21:28レスありがとうございます。
ApacheとTomcatが同一マシン上で動作している場合はそれでいいかと思うのですが、
Webサーバマシンとアプリサーバマシンが別々の場合に、リクエスト転送元のWebサーバをWebアプリ内で動的に判別したいのです。
もしかして私の勘違いで、その場合もServletRequest#getServerNameでイケちゃったりするのでしょうか??
0801デフォルトの名無しさん
2007/05/11(金) 08:33:150802デフォルトの名無しさん
2007/05/11(金) 12:19:00やってみなよ。内部で勝手に転送しているだけで
リクエストを受けてるのはApacheがあるほうのサーバ。
逆にTomcatがあるほうのホスト名やIPアドレスを取得するほうが難しいと思う。
0803デフォルトの名無しさん
2007/05/12(土) 00:12:210804デフォルトの名無しさん
2007/05/12(土) 09:11:43んでこんな感じかと思うんですが、
<action path="/practice/example" type="practice.ExampleActionController"
name="plactice_~~" scope="request" validate="true" input="/practice/~~.jsp>
ってなかんじで書くと思うんですが、html/jspのformから.doで呼び出すとき
/plactice/example.doで呼出せるときもあれば、../plactice/example.doでないと
actionが呼出せないときもあり、ちと訳分かりません。そこら辺ご教授ください。
strutsのverは1.3です。
0805デフォルトの名無しさん
2007/05/12(土) 15:26:25本文はmysqlではcontext textと設定しています。
ですが、大型AAなどの長文を入れると、DBに登録されません。
どうすれば上手くいくでしょうか?mysqlのヴァージョンは5です。
0806デフォルトの名無しさん
2007/05/12(土) 18:39:43>、html/jspのformから.doで呼び出すとき
>/plactice/example.doで呼出せるときもあれば
このようにはしないですよ。
strutsタグ html:form を調べてください
0807デフォルトの名無しさん
2007/05/13(日) 10:09:21間違った覚え方をしていたようでしたorz
レスありがとうございました。
0808デフォルトの名無しさん
2007/05/13(日) 18:28:04taglibつかってるかで変わる。
0809デフォルトの名無しさん
2007/05/14(月) 00:39:39現在eclipseでstrutsの環境を構築してるんですが、見ようと思っても、「アクション /HelloWorld
に対応をするマッピングが見つかりません。」っていうエラーがでるんです。
原因を調べようとstruts-config.xmlをクリックしたんですが、「エラーが発生しました。詳細について
はエラーログを参照してください。」と表示されて見ることが出来ません。
ちなみにstruts-IDEをいれて設定しています。お願いします。
0810デフォルトの名無しさん
2007/05/14(月) 10:09:22htmlコンテンツアクセス率が高いサイト(*.doに対して8割ほど)なんですけど。
0811デフォルトの名無しさん
2007/05/14(月) 10:18:580812デフォルトの名無しさん
2007/05/14(月) 11:47:05管理ツールとかSSLとかTomcatのHTTPコネクタの問題とかをなくせる
いまやmod_jkいらないし設定もシンプルだし
0813デフォルトの名無しさん
2007/05/14(月) 12:17:210814デフォルトの名無しさん
2007/05/14(月) 13:14:050815デフォルトの名無しさん
2007/05/14(月) 14:13:490816デフォルトの名無しさん
2007/05/14(月) 14:55:50phpみたくホットデプロイ可能で。
0817デフォルトの名無しさん
2007/05/14(月) 22:42:21Tomcat6じゃないとダメとかじゃなくて?
0818デフォルトの名無しさん
2007/05/14(月) 23:56:22やっとcentos5が出たから乗換中
0819818
2007/05/15(火) 00:11:52静的なコンテンツはapacheにまかすのがいいとして
サイトの管理ってどうやってすんの?
うちは、svnでeclipseのプロジェクトで登録してるけど、
めんどいんで全部tomcatにふってる
build.xml書けばいいだけだけど、
負荷がそれほど大きくない場合だと
tomcatで問題ある?
0820デフォルトの名無しさん
2007/05/15(火) 00:16:49で、apacheの設定でWEB-INFにはアクセスできないようにする。
jkで*.jspのみtomcatへ。そんだけ。build.xmlとか書かなくても良い。
てか俺はantも嫌いなんでスクリプト系はrubyで作ってrakeで実行。
0821デフォルトの名無しさん
2007/05/15(火) 00:29:37ただし、HTTPコネクタに問題があるので、適度にリセットできるような身内でしか使わないのであればまぁ許容範囲
管理ツールつかいたいしな
0822818
2007/05/15(火) 01:06:45http conectorではなくって8009にmod_proxyでふってる(apache2.2)
ただ
>HTTPコネクタに問題があるので、適度にリセットできるよう
はわからん
俺がAPR使ってるからか?
0823デフォルトの名無しさん
2007/05/15(火) 01:14:18これはいろいろと問題が起きる
だからリバースプロキシつかっているならjkでもhttpでも問題は起きない
0824デフォルトの名無しさん
2007/05/15(火) 01:42:11SSL 使うから Apache だろ、とかはもう意味不明。
0825デフォルトの名無しさん
2007/05/15(火) 01:58:090826デフォルトの名無しさん
2007/05/15(火) 03:28:32Alexaで100位以内くらい?
0827デフォルトの名無しさん
2007/05/15(火) 15:03:59どれだけアクセス数少ないんだよ
0828デフォルトの名無しさん
2007/05/15(火) 23:22:52apache<>tomcat間の通信をkeepaliveしたくないorすぐに切断したい
のですが方法をご存知の方はいらっしゃいませんか?
大量にアクセスがあるとkeepaliveでスレッドが埋まってしまって、
その後外部から通信できなくなってしまいます。
workers.properties
worker.ajp13.socket_keepalive=False
server.xml
<Connector port="8009"
keepAliveTimeout="0" keepAliveMaxRequestCount="0" enable-keep-alive="false"
KeepAlive="0"
とかしてみたのですが、さっぱり。
mod_proxy_ajpを使用しても同じ。
処理はすぐに終わっているのですが↓がずらずらと出てしまいます。
tcp 0 0 localhost.localdomain:57595 localhost.localdomain:8009 ESTABLISHED
tcp 0 0 localhost.localdomain:57563 localhost.localdomain:8009 ESTABLISHED
tcp 0 0 localhost.localdomain:8009 localhost.localdomain:57595 ESTABLISHED
tcp 0 0 localhost.localdomain:8009 localhost.localdomain:57563 ESTABLISHED
0829デフォルトの名無しさん
2007/05/21(月) 00:12:12たとえば、
リクエスト → struts-configで、フォワード → ActionForm → validator.xmlの読み込み
→ 検証? → ActionMessage生成 → ActionErrorsへ格納 → validator
→ Messageクラスのインスタンス数が0 → struts-configで、正常画面へフォワード
→ Messageクラスのインスタンス数が > 0 → struts-configで、エラー画面へフォワード
見たいな、strutsとvalidatorの動き?処理の流れ?が、うまく理解できなくて困っています。
言葉で教えていただくのもありがたいのですが、
できればhttp://blog.hide-k.net/archives/images/struts.jpgのような図で解説しているサイトがあれば、
理解しやすいので・・・。
よろしくお願いいたします。
0830デフォルトの名無しさん
2007/05/21(月) 10:34:55もう十分理解できてるじゃん
■ このスレッドは過去ログ倉庫に格納されています