トップページ⇒network
11コメント9KB

NT4.0 IISでSSLでブラウザエラーがでる

■ このスレッドは過去ログ倉庫に格納されています
0001ななしさんNGNG
以下のことで困っている(と聞かれた)ので教えてください。
私は当事者ではないので、下記に書いた情報があいまいかも
しれないですが、できるだけ聞かれた人に力になりたいので、
代わりにここで質問した次第です。

------------------------------------------
 NT4.0 の IIS(4.0だと思うが)でSSL128ビットの暗号化をしたシステムを
つくっているのだが、httpsでアクセスするとブラウザエラーが表示される。
 日本べりサインや、firewallをまかせている某社にも確認したが、
それぞれは問題ないとのこと。NT IISの問題では? と疑っている。

何とか直せないか? とのこと。
------------------------------------------

これだけの情報ではアドバイスしにくいと思いますが、上記のことを
行うにあたって、誰でもよく引っかかりそうな箇所(いわゆるFAQ?)や、
ここを確認しろ、ということを教えていただけるとうれしいです。

よろしくお願いします。

↓つづく
00021NGNG
ブラウザエラーといってもどういうエラーなのか私にもわからないし
(コンテンツがまったく表示されないのか、など)、
環境(ブラウザのバージョン)や障害状況をもっと教えてほしいもの
ですが、私の思い当たること。

・たしか128ビット暗号化は、IE5.01の128ビット暗号化パックをあてた
 ものか、IE5.5でなければならない。
 (上記以外のブラウザでアクセスすると、自動的に56ビットだか40ビットで
 暗号化される。ただしこの場合でもエラーのポップアップが出るわけでは
 ないと記憶している)。
・で、https というものはwebサーバにおかれた証明書とブラウザが持って
 いる証明書?で公開かぎと秘密かぎで通信するわけだが(あってます?
 違ってたらはずかしい)、128ビットに対応した証明書をベリサインから
 取得してwebサーバにおいた場合、どうやらベリサインの証明書は
 新しいもの(?うまく表現できないが)みたいで、
 古いブラウザ(たぶんIE5.5より前とか)は
 その証明書のことを知らないらしく、「本当に正しいのか?」というエラーの
 ポップアップを出す。ただし通信そのものは暗号化されるため、通信の安全性
 が損なわれることはない。
・これを解決するには、新しいIEにアップブレードすればよい。
 逆に、IE5.5でも、ベリサインのルート証明書(CAっていうんだっけ?)を削除
 すれば、同様のことが発生する。

私としては、webサーバにhttpsで接続時にこのようなポップアップが表示される
ことを言っているのかな?とか思うのですが。
0003名無しさんNGNG
マジレス。
たまに管理者もいるみたいだけど、
ここの板だと厨房ばかりだから、プログラムや
プログラマー板の方がなにかしらのレスあると思うよ。
同じような体験をしたSE||PGとか・・・
0004名無しさんNGNG
>>3
ハァ?
128ビットSSLで問題がおきたことないやつばっかりだから、
だれもこたえようがないんじゃない?
0005NTT即死NGNG
116に電話して、テレホが高いと文句を言おう。
こっちは客なんだから文句を聞くのはあたりまえだ。
00061はバカNGNG
簡単なSSL 実装検証としてさ
そのIIS4.0(NT4+OP)を作ったときに
CA も実装してさ、そこで PKCS#10形式のサーバ認証を
やってみたら?

1 みたいな厨房をサポートする
バカが理解できていないことを
簡単にいうと、サーバの FQDN が違うんじゃないの?

申請時:hoge.hogehoge.co.jp
実装時:www.hogehoge.co.jp

になってるとかさ。

もっと勉強しろよ、タコ。二代目吉川になるぞ。
00071はバカNGNG
それと、128bit は中間CAの設定をIISで行わないと
ルートを辿れないからさ。

そんなことも知らない消防なのかな。

バッカだね。
00081はバカNGNG
>>2

そもそもヒアリングが不十分なのは、1 が SSL を
理解してないからだね。理解してないバカにサポートを
頼むユーザはもっとバカ。

まるで、吉川へ Bind を聞くのと同じようなことだ。
000912001/06/25(月) 03:05ID:IgmtAXrA
なんか1はバカとか言われまくってますが、そのバカです。
解決しました。(もうレスはついていないだろうと思って、しばらく
このスレッドはチェックしていませんでした)。
原因はこれでした。
http://www.microsoft.com/JAPAN/support/kb/articles/J051/9/22.htm
サーバマシンにIE5.01をインストールしていたためでした。

ちなみにこんなページもあります。
(googleでここをまず見つけて、ここからたどりました)。
http://digitalid.verisign.co.jp/server/help/operation.html

以上、お騒がせしました。レスを下さった方、
どうもありがとうございました。
以下、つけたし。

>簡単にいうと、サーバの FQDN が違うんじゃないの?
>
>申請時:hoge.hogehoge.co.jp
>実装時:www.hogehoge.co.jp
>
>になってるとかさ。

これくらいは確認してます。

>そもそもヒアリングが不十分なのは、1 が SSL を
>理解してないからだね。理解してないバカにサポートを
>頼むユーザはもっとバカ。

ここらへんは甘んじて受け止めたいと思います。
0010anonymous@ YahooBB219030048098.bbtec.net02/08/08 14:24ID:???
       __                     __
     / ̄   ̄\               / ̄   ̄\
    /         \            /       从ヽ
   {         从ヽ             { ノノノノノノノノ ハ )
   lノノノソノノノノノ ハ )             lノノノソ‐・‐  ‐・‐|
    ヽ6リ      l  次も勝ちます  ヽ6リ   .!,  ノ
     ヽゝ、  〜ノ  応援よろしく!  ヽゝ、 Θ /  
   , .-‐ll\    「》 、             , .-‐ll\    「》 、
   /ヽ:::::::::: ̄ヽ〃:::::::ヽ          /ヽ:::::::::: ̄ヽ〃:::::::ヽ
  /::::::l:::<>::::::::::◎:r:::l         /::::::l::<>:::::::::::::◎:r:::l
  〈:::::::::l:::=:::::京セラ:::l:::::|        〈::::::::l:::=::::京セラ::::::::l:::::|
     :::::::::::::::10:::::::             ::::::::::::::::::::9:::::::::
0011anonymous@ YahooBB219030048098.bbtec.net02/08/08 14:24ID:???
       __                     __
     / ̄   ̄\               / ̄   ̄\
    /         \            /       从ヽ
   {         从ヽ             { ノノノノノノノノ ハ )
   lノノノソノノノノノ ハ )           lノノノソ‐・‐  ‐・‐|
    ヽ6リ      l  次も勝ちます  ヽ6リ   .!,  ノ
     ヽゝ、  〜ノ  応援よろしく!  ヽゝ、 Θ /  
   , .-‐ll\    「》 、             , .-‐ll\    「》 、
   /ヽ:::::::::: ̄ヽ〃:::::::ヽ          /ヽ:::::::::: ̄ヽ〃:::::::ヽ
  /::::::l:::<>::::::::::◎:r:::l         /::::::l::<>:::::::::::::◎:r:::l
  〈:::::::::l:::=:::::京セラ:::l:::::|        〈::::::::l:::=::::京セラ::::::::l:::::|
     :::::::::::::::10:::::::             ::::::::::::::::::::9:::::::::
■ このスレッドは過去ログ倉庫に格納されています