トップページ⇒linux
1001コメント310KB

CentOS part 19 【RHEL Clone】

■ このスレッドは過去ログ倉庫に格納されています
0001login:Penguin2009/05/04(月) 21:19:31ID:pK3sC7x6
CentOSはRed Hat Enterprise Linuxより同社の商標を削除して再コンパイルしたRHEL Cloneです。
Red Hatと無関係なコミュニティが無償配布しておりRed Hatのブランドとサポートはありません。
Fedora Core 6≒RHEL 5≒CentOS 5です。
FC 6やRHEL 5用のノウハウや野良RPMはCentOS 5でほぼ通用します。

前スレ CentOS part 18 【RHEL Clone】
http://pc11.2ch.net/test/read.cgi/linux/1238392436/

CentOS (The Community ENTerprise Operating System)
http://www.centos.org/
CentOS 配布ミラーサーバ
http://www.centos.org/modules/tinycontent/index.php?id=13
RPMforge (サードパーティのリポジトリ)
https://rpmrepo.org/RPMforge
Wikipedia CentOS
http://ja.wikipedia.org/wiki/CentOS
0133login:Penguin2009/05/08(金) 14:03:29ID:u/L8dKWd
>>132
っていうか、GUIで「勉強」はないわ
0134login:Penguin2009/05/08(金) 14:14:36ID:+krwnygd
このスレには定期的に基地外がわくんですね
0135デムパゆんゆん2009/05/08(金) 14:33:31ID:zixm/nFi
>>132
フェドラなりセントスなりインスコ本を一冊買え
話はそれからだ。 質問はインシデント制になっておる
一質問は5インシデント
0136login:Penguin2009/05/08(金) 14:50:43ID:50X1/SdI
>>132
一般的に言って、Linuxの設定変更は/etcの下などにある設定ファイルをテキストエディタで
編集するか、コマンドラインで設定コマンドを実行する。

それでは初心者に難しいし、ベテランでもタイプミスする可能性があるので、手軽に設定できる
ようにGUIツールが存在するが、普通GUIツールで設定できるのは主要な機能だけで、細かい
チューニングがしたければ、設定ファイルをエディタで編集する必要がある。

GUIツールで設定を済ませたくて、しかもCentOSよりもFedoraに付属するGUIツールのほうが
優れていると思ったのなら、Fedoraを使えばいい。

だが、勉強が目的ならGUIに頼ってちゃだめ。
0137login:Penguin2009/05/08(金) 14:53:55ID:gIDrHRnX
>>136
ツールがどうこうでFedoraかCentOSを選ぶようなもんじゃねぇだろwww
0138デムパゆんゆん2009/05/08(金) 14:57:58ID:zixm/nFi
>>137
部長 selinux陣営は過去の反省から
GUIツールの改良に邁進しております
ツールで選ぶのもまた一興
フェドラは革新が進んでおりますが
セント君はいっこうに改良がバックポートされません
セントスに正義の鉄くいを
0139login:Penguin2009/05/08(金) 14:58:59ID:u/L8dKWd
関係ないけど、仕事でSELinuxなんて使ったことないな
0140login:Penguin2009/05/08(金) 15:01:06ID:12vZl4Iq
>>138
6Betaで遊べや
0141login:Penguin2009/05/08(金) 15:01:09ID:gIDrHRnX
たとえ欲しいツールがあったところで、平均寿命9ヶ月でお亡くなりになるFedoraが、CentOSを選ぼうとした奴が代わりに選べるわけがない。
せいぜい欲しい部分だけソースからパクるくらいだろ。
0142login:Penguin2009/05/08(金) 15:15:25ID:3+ymODU3
>>132
> Fedoraのようにできる(そうなっているのが本来当然)ならどこがおかしいのか

「Fedoraのようにできる(そうなっているのが本来当然)」ってのがおかしい
0143login:Penguin2009/05/08(金) 15:51:35ID:aShtNKLs
darcsだけfedoraからもってきたい
0144login:Penguin2009/05/08(金) 16:10:30ID:xGCu71CE
>>123
その程度の知識でソースインストールするというのは
諸刃の剣な気がするけどな。

そこまでバージョンアップしないといけない不具合とか
修正とかあったっけ?

野良リポジトリが使えればいいと思ったんだけど
rpmforge は 2.2.3-22.el5.centos
utterramblings は 2.2.8-jason.3
で2.2.11は無いなぁ・・・
01451242009/05/08(金) 16:48:02ID:qnGiMVke
なるほど、たくさんの意見ありがとうございました
ポリシーをGUIで簡単操作できるPolicyEditorってのがあるので
これを使おうかなと思ってたんですが、こんなのさわってる人いないんでしょうか
http://seedit.sourceforge.net/ja/index.html
手持ちのCentOS本があまり詳しくないので聞きましたが、新しい本買おうかな
0146login:Penguin2009/05/08(金) 16:53:17ID:aShtNKLs
system-config-[foo|bar]
で大概の設定がGUIでできるなんて素敵すぎます
0147login:Penguin2009/05/08(金) 17:06:55ID:u/L8dKWd
>>145
Linuxの勉強したいなら、GUIは捨てること

これ鉄則。
Windowsから入ると、「古臭い」とか間違ったイメージ持ちがちだけど
runlevel5で運用してるような(まともな)サーバは存在しないから。
0148login:Penguin2009/05/08(金) 17:30:48ID:P08iWODs
>>145
素晴らしいことに日本語のマニュアルまで充実してるみたいだし、
自分が何の目的でSELinuxを使うかの用途にあっているのなら、
まず使えばいいんじゃね。

「勉強」なんだし、目標と、まして手段まであるのなら
他人がどうのより、やってみるのが早いと思う。
01491242009/05/08(金) 18:00:08ID:qnGiMVke
>>147
すみません、もうちょっと聞きたいんですが
それだと、レンタルサーバーにあるコントロールパネルなんか使わないってことでしょうか?
多数の商用利用をされてるレンタルサーバがコンパネあるので
みんなこれ使ってるのかなと思ってたんですが。。
0150login:Penguin2009/05/08(金) 18:11:05ID:gIDrHRnX
>>149
ケースバイケース。
ってか、専用サーバならコントロールパネルなんか無いことがほとんど。
コントロールパネルがあるのは中身がお仕着せの状態で弄れないバーチャルホストが多い。
簡単なUIがある代わりに簡単なことしか弄れない。
好き放題弄れる専用サーバだと、ちょっと弄ればコントロールパネルなんか機能しなくなるからね。
0151login:Penguin2009/05/08(金) 18:14:34ID:xGCu71CE
コンパネがあるようなレン鯖を使っている所は
お仕着せだから逆に勉強する必要無いと思うぞ。

設定に不備があったらコンパネのバグだろうし。

ちょっと手のこんだことしようとしたら、
インストール終わりました。sshできます。
あと頑張って、みたいな感じだよ?
0152login:Penguin2009/05/08(金) 18:18:42ID:u/L8dKWd
>>149
SSHで何から何までやる。それ以外に使うことがあるのは、
どうしようもない障害が起きたときに、電源スイッチ押して貰うための電話だな。

コントロールパネルなんて、シェアサーバ(非root)なんじゃない?
シェアサーバなんかじゃろくに何も出来ないよ。

何をするかによるけど、ちゃんとしたサービスを運用するなら
仮想でもいいから、専用サーバ。
01531522009/05/08(金) 18:26:25ID:u/L8dKWd
たぶんイメージ掴めないと思うので、蛇足で説明すると、

俺は開発系なんだが、プログラミングですらSSHでする
サーバーにSSHで接続して、そのターミナル画面上で。
ApacheやDBの設定/起動、も当然同じターミナル画面。
つまり、何から何までSSH。

ついでに言うと、あまりにも当たり前なことを書きすぎて俺今恥ずかしい。
それくらいCUI。
01541242009/05/08(金) 18:33:14ID:qnGiMVke
度々ありがとうございます。
そうなんですか、専用サーバーは難しそうだと思って某有名VPSサービスを
候補に考えてました。
コンパネあるけどそれに頼りきりだと不安だからそこそこコマンドで操作できるようになろう、と。
「そこそこ」の範囲がわからなくて、「はじめてのCentOS5」(秀和システム)って本終わったら
とりあえず良いかなって気分だったんですが、全然ダメぽいですね。。

ともかく頑張ります ありがとうございました
01551242009/05/08(金) 18:37:18ID:qnGiMVke
>>153
ローカルで書いたプログラムをFTPでうpなんてしないってことですね?
凄いですね、、
そこまでバキバキのプログラマや管理者目指してる訳ではないので逆に
OKラインがわからず…
ともかく今の本終わってもの足りないところが見えたらそこもやります、ありがとう
0156login:Penguin2009/05/08(金) 18:39:01ID:1511OjU4
Linux 初めて触ってから 5 年位経つけど GUI ってインストール時のみしか使った事無い。
yum したとき依存パッケージの先頭に X ってあると頭痛する。
# ImageMagick あたりだったかな…

GUI は M$ の OS だけで良いわ
0157login:Penguin2009/05/08(金) 18:43:27ID:1511OjU4
>>155
プログラムかけなくても shell くらい書けるようにならないと駄目なんでガンバw

$ man bash
これ一通り目を通しておくと勉強なる。
0158login:Penguin2009/05/08(金) 19:26:47ID:RNjlyMME
>156
おっと、Solarisの悪口は(以下略
0159login:Penguin2009/05/08(金) 19:31:29ID:gIDrHRnX
CDEwww
0160login:Penguin2009/05/08(金) 19:33:15ID:nIWMMHf1
>>157
スクリプトは書いても、shellはかかないw
0161デムパゆんゆん2009/05/08(金) 19:45:32ID:zixm/nFi
>>145
seeditの中の人の日記
ttp://d.hatena.ne.jp/himainu/
selinux自体知らないと宝の持ち腐れでアル
0162login:Penguin2009/05/08(金) 19:55:39ID:1511OjU4
>>160
略しすぎ?w
シェルスクリプトって口頭だと「シェル書く」とか職場じゃいってる。
0163login:Penguin2009/05/08(金) 19:57:46ID:gIDrHRnX
古い人はそう言う。
0164 ◆Zsh/ladOX. 2009/05/08(金) 20:50:55ID:8Vvvqb2O
Selinuxっていえば5.2→5.3にして今日初めてsamba起動したら
WinXPから/homeが見えなくなってた。
smb.confとsmb.conf.rpmnew
を見比べてsetseboolをごにょごにょして見れるようなった。
0165login:Penguin2009/05/08(金) 21:55:01ID:d1Q4fATK
>>161
日立システムのかなり優秀な社員ってことなんだろうけど
そういう人でもGUIつかってるってことですよね
まあ、詳しく知らずに使ってる自分とは意味がちがうかー
0166login:Penguin2009/05/08(金) 22:00:30ID:u/L8dKWd
開発するのと、自分が使うのは別でしょ

Linuxの裾野を広げるためにGUIの改善、充実は必要なわけで
0167login:Penguin2009/05/08(金) 22:07:35ID:d1Q4fATK
現状でGUIの利用が推奨されない理由って、xWindowが重いってことと、
GUIの管理機能が充実してないからってこと?
0168デムパゆんゆん2009/05/08(金) 22:14:56ID:zixm/nFi
>>165
優秀とかでもなく誰だって楽したいし
よ〜しパパCUIでがんがっちゃうぞ〜
再起動して真っ青になったりとか あれ目から汁が
seeditにかぎらずselinuxのポリシツール
SELinux Trouble Shooting Tool もssh対応してたとは思う。
茨の道へいらっしゃ〜い。
0169デムパゆんゆん2009/05/08(金) 22:16:43ID:zixm/nFi
>>165
ttp://www.atmarkit.co.jp/fsecurity/
selinuxはこっちのほうが充実してるがな 若干古いけど
0170login:Penguin2009/05/08(金) 22:19:22ID:u/L8dKWd
>>167
勉強する必要があるLinux は サーバ用途だから

ってのに尽きるんじゃないかな。
デスクトップ用途を否定するわけじゃないけど、現状やっぱり他OSに劣るし
「WindowsXPの操作を勉強する」とも普通言わないよね
0171login:Penguin2009/05/08(金) 22:31:46ID:dZzOID4L
Xの裏側で動いてるコマンドを見れたら勉強になるのにな。
gnomeの音消しやら何やらしてたとき、「これってドコのconfよ?」って思った。
0172login:Penguin2009/05/08(金) 22:34:50ID:d1Q4fATK
なるほどね〜
ほんとに度々ありがとうございました
0173login:Penguin2009/05/08(金) 22:42:31ID:RNjlyMME
>170
サーバ用途で使うことを考えたら、なんとかzfsが(FUSEでなく)入らないかなぁ。
0174 ◆Zsh/ladOX. 2009/05/08(金) 23:01:52ID:8Vvvqb2O
>>171
ちょっと思いつくのは
> gnomeの音消しやら何やらしてた
これの前に
ps -ef > /tmp/before
これの作業中に
ps -ef > /tmp/after
とかしてbeforeとafterの
diff取ってみることかな。
0175login:Penguin2009/05/09(土) 02:02:12ID:xhgAYkg5
>>174
> ps -ef > /tmp/before
なるほど。
こういうのも先に勉強してないと思いつかないよねw


0176login:Penguin2009/05/09(土) 02:17:25ID:myF6BIOc
ps auxw っしょ?
0177login:Penguin2009/05/09(土) 02:23:00ID:f/nSUJrD
ps auxwww っしょ
0178login:Penguin2009/05/09(土) 07:03:05ID:ddZdsb9x
ps -efww 俺愛用。
気分乗らないときとかはwが増えてく
0179login:Penguin2009/05/09(土) 08:02:06ID:fy181Vku
で、草大杉って怒られるんだなw
0180login:Penguin2009/05/09(土) 08:32:00ID:ddZdsb9x
混じれ酢しておくと
aux BSD
-ef UNIX,POSIX
となっていて、Linuxはどっちも対応している。
Linuxはどっちも使えるので最初に触ったマシンが
どっちかってだけだと思うよ。
俺の場合Linux,AIX,HP-UXなどだったので
-ef を体が覚えてるw
0181login:Penguin2009/05/09(土) 08:45:39ID:Pkh/Urnc
あれ?
ps -awxf って少数派?
0182login:Penguin2009/05/09(土) 09:26:50ID:ddZdsb9x
>>181
そのオプション構成初めてみた。
コマンド打ってみろよ、警告でてるぞwww

$ cat /etc/redhat-release
CentOS release 4.7 (Final)
$ ps -awxf > /dev/null
Warning: bad syntax, perhaps a bogus '-'? See /usr/share/doc/procps-3.2.3/FAQ
0183login:Penguin2009/05/09(土) 09:41:01ID:ddZdsb9x
BSD形式かそうじゃないかは
ハイフンのあり無しで判別してるみたいだな。
混ぜて使うなって

下記>>181と同じ様な結果ね。

POSIX形式: ps -efH
e 全てのプロセス
f 詳細
H tree形式

BSD形式: ps axjf
  ax 全てのプロセス
j ジョブ制御フォーマット
  f tree形式
0184login:Penguin2009/05/09(土) 13:37:53ID:zaoJJY6H
今日から俺、
ps auxwwf
にする
0185login:Penguin2009/05/09(土) 13:46:49ID:T19Jk7N9
↑覚えにくい。

ps fax u www
0186login:Penguin2009/05/10(日) 10:49:28ID:6+N7LRz5
5.3使ってます。windowsからSSHで接続したいんですがうまくいきません
使ってるクライアントのソフトはPuTTY 0.6verって奴です。
CentOSがわでifconfigで出てくるipアドレスを対象にしてるんですが、やり方間違ってるでしょうか?
サーバ側でやっておくべき設定とかありますか?
0187login:Penguin2009/05/10(日) 10:54:15ID:9e2MC4Rl
間違ってる。
ない。
0188login:Penguin2009/05/10(日) 10:55:00ID:6+N7LRz5
>>186です
エラーは、
「ネットワークエラー 接続がタイムアウトしました」と言われます
対象のipアドレスにpingは通るんですけどね
0189login:Penguin2009/05/10(日) 11:02:16ID:YaPbe1vZ
>>188
IPアドレスが間違ってなくてIP以下の層がまともに動いてるなら
TCP層でファイアウォールとか?
0190login:Penguin2009/05/10(日) 11:06:00ID:sG1krsbo
>>188
ps aux |grep sshd
sshdが起動してるか確認

iptables -L
変なルールが設定されてないか確認
0191login:Penguin2009/05/10(日) 11:12:31ID:6+N7LRz5
>>189
ありがとうございます

>>190
>ps aux |grep sshdで
root 3408 0.0 0.0 7128 1016 ? Ss 08:12 0:00 /usr/sbin/sshd
root 27944 0.0 0.0 3912 676 pts/1 R+ 19:08 0:00 grep sshd
と出ました

iptablesは以下です
ACCEPT all -- anywhere anywhere
ACCEPT tcp -- anywhere anywhere state NEW tcp dpt:ssh
01921912009/05/10(日) 11:18:48ID:6+N7LRz5
ipアドレスがサーバ側が172.18.16131で、
クライアント側が192.168.0.5です
これも問題あるんでしょうか?
0193login:Penguin2009/05/10(日) 11:23:26ID:SRu8jRFL
>>192
それは無理
同じセグメントにするか、ルータで二つのネットワークをつなげろ
0194login:Penguin2009/05/10(日) 11:31:38ID:6+N7LRz5
>>193
わかりました
ありがとうございます!
0195login:Penguin2009/05/10(日) 11:31:38ID:sG1krsbo
同じセグメントっつーか、
同じセグメントかつ同じネットワークアドレスね
0196login:Penguin2009/05/10(日) 12:15:20ID:SRu8jRFL
>>195
セグメントであってると思うが・・
そのための手段として例えば同一HUBで
同一ネットワークアドレスを設定する

すまん重箱の隅突付きだが、元ネットワーク屋なので
書いておく。
0197login:Penguin2009/05/10(日) 12:16:41ID:sG1krsbo
>>196
本当に元ネットワーク屋かい?

同じセグメントに、複数のネットワークが混在してても問題はないぜ?
通常、1セグメント1ネットワークアドレスなだけで。
0198login:Penguin2009/05/10(日) 12:19:28ID:7Ou11Cud
どうでも良すぎるw
0199login:Penguin2009/05/10(日) 12:23:42ID:SRu8jRFL
>>197
5年くらい前にCCNP持ってたけど、今何もわからんので自信なす。
今必死に考えてる。
結果セグメントじゃなくて同一ネットワークだな。
すまん。
0200login:Penguin2009/05/10(日) 12:23:48ID:qKnjpAw7
スレ違い
0201login:Penguin2009/05/10(日) 13:02:09ID:7Ou11Cud
CCNPってそんなレベルなんだな。
まぁ、ベンダー試験になんか興味ないけど。
0202login:Penguin2009/05/10(日) 13:50:57ID:Vy3954C0
そっちのベクトルに疑問もつおまえにビックリだよ
もってたとしたら表現がおかしい
0203login:Penguin2009/05/10(日) 13:58:41ID:BAhUwgdu
みんなひまだな。
0204login:Penguin2009/05/10(日) 15:00:37ID:23RRhEub
ping通るならL3で接続されてるんじゃないの?
wrapperではじかれてるとかないよな?
0205login:Penguin2009/05/10(日) 15:28:52ID:QQmPQcBX
日曜日だからみんな暇なのかね。

仮想PCか実サーバなのかとかも書いた方が良いよ。
ネットワーク図とか書いてくれた方がさらにいいかな。

実マシン2台でHUB経由で繋げてIPがそれだと
たしかに駄目ぽ。

pingとかうったコマンドは
コピペである程度結果を晒してくれた方がいい。

中途半端に通りましたって言われても
別の所に打ってる可能性だってあるしなぁ。
0206login:Penguin2009/05/10(日) 15:35:24ID:sG1krsbo
HubがL3-SwitchingHUBだったりして

ないな
0207login:Penguin2009/05/10(日) 19:29:40ID:TH/39Oj/
yum は、 
ユム?
ヤム?
0208login:Penguin2009/05/10(日) 19:44:51ID:d5u5bYNq
イウム だろ
0209login:Penguin2009/05/10(日) 19:48:01ID:qKnjpAw7
ワイユーエム
0210login:Penguin2009/05/10(日) 20:47:55ID:zwPWpE2w
L3-SwitchingHUBなんてイワンだろ。
0211login:Penguin2009/05/10(日) 21:01:29ID:sG1krsbo
>>210
普通はL3スイッチだけど、>>205のHUBに対しての冗談だから勘弁してよ
0212login:Penguin2009/05/11(月) 01:43:01ID:hCvwXxbX
なんでCentOSって鯖用途によくつかわれるの
0213login:Penguin2009/05/11(月) 01:47:40ID:yz4DU7Yd
>>212
まぁ、元をたどればRedHatだしな

RedHat等の後ろ盾は欲しいけど、金は無い、という貧乏人ご用達のディス鳥です
0214login:Penguin2009/05/11(月) 02:06:10ID:4v770GQ1
サポート(期待)期間も7年とフリーのものの中では最も長いしな。
7年後にcentosがあるのかどうか怪しいがな。
0215login:Penguin2009/05/11(月) 02:27:33ID:c69TkjwM
>>214
CentOSが没落してたら他のRHELクローンのリポジトリに乗り換えって感じかな。
02161912009/05/11(月) 02:35:45ID:MiQcdKWb
ネットワークとIPアドレスを変更しようと以下のようにしたんですが正常に動作しませんでした。。
↓ [root@localhost ~]# vi /etc/sysconfig/network-scripts/ifcfg-eth0を編集
# Advanced Micro Devices [AMD] 79c970 [PCnet32 LANCE]
DEVICE=eth0
BOOTPROTO=static
BROADCAST=192.168.0.255
IPADDR=192.168.0.10
NETMASK=255.255.255.0
NETWORK=192.168.0.0
#HWADDR=00:0C:29:12:CC:51
ONBOOT=yes


↓ ipconfigの結果
eth0  Link encap:Ethernet HWaddr 00:0C:29:12:CC:51
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:72 errors:72 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:6624 (6.4 KiB) TX bytes:0 (0.0 b)
Interrupt:67 Base address:0x2024

どこがおかしいんでしょうか? すみません、気が向いた方、教えてくれると嬉しいです
これはMAC上のVMで動いている仮想OSなんですが、MACから通っていたPING(対象はDHCPルータで設定されてたアドレス)も
通らなくなってしまいました
PING 172.16.18.131 (172.16.18.131): 56 data bytes
ping: sendto: No route to host
ping: sendto: Host is down
0217login:Penguin2009/05/11(月) 02:41:51ID:pGQBidS2
Nat modeとかbridgeとかその辺切り替えないとダメなんじゃない
0218login:Penguin2009/05/11(月) 09:03:45ID:yJXOCo+c
5.3にしてからlvm系のコマンドを使うと
leaked on lvcreate invocation.
のように表示さて、パフォーマンスも凄く悪いのですが、これって解決方法無いのでしょうか・・・
0219login:Penguin2009/05/11(月) 10:18:59ID:1vrOfnlj
だいぶむかしに
5.0を5.1に上げたらopenLDAPのデータが飛んでえらいことになったけど
今なら上げてもちゃんとデータ移行もしてくれるんだろうか
02201912009/05/11(月) 11:19:02ID:MiQcdKWb
>>217
なんとか接続できました
ありがとうございました
0221login:Penguin2009/05/12(火) 01:07:55ID:ILphGbuk
Lttngというのを入れてみたくなったのですが
これを当てればいいのですかね?
http://ltt.polymtl.ca/files/lttng/patch-2.6.18-lttng-0.6.41.tar.bz2
0222login:Penguin2009/05/12(火) 11:04:20ID:ziouUBgf
yumでntpを入れて
server ntp.nict.jp
を指定しました。
serviceコマンドでstartしているのですが、ntpq -pで確認しても
いつまでたっても同期しません。
pingでもdigでも引けているのでネットワーク的には繋がっているのですが
どのようにすれば同期してくれるのでしょうか?
環境はCentOS5.3でntp-4.2.2p1-9.el5.centos.1です。
0223login:Penguin2009/05/12(火) 11:13:27ID:mM/usZ5Z
>>222
質問するなら conf の内容と ntpq -p したときの結果くらい貼ってみては?
0224login:Penguin2009/05/12(火) 11:16:19ID:9//BdTRm
>>222
待ってればそのうち同期するけど、ずれが大きいと時間かかる(ハズ)なので
まずはいったん強制的にあわせる。

service ntpd stop
ntpdate -b ntp.nict.jp
service ntpd start
0225login:Penguin2009/05/12(火) 12:08:04ID:hChEfS+w
>>222
ついでに
/var/log/message あたりにntpのログも出てると思うんだけどどうかね?
02262222009/05/12(火) 12:52:54ID:ziouUBgf
>>223
conf内容は下記になります。
restrict ntp.nict.jp
restrict ntp.jst.mfeed.ad.jp
restrict 127.0.0.1

server ntp.nict.jp
server ntp.jst.mfeed.ad.jp

driftfile /var/lib/ntp/drift
ntpq -pの結果は
remote refid st t when poll reach delay offset jitter
==============================================================================
ntp-a2.nict.go. .INIT. 16 u - 64 0 0.000 0.000 0.000
ntp1.jst.mfeed. ***.***.***.* 2 u 20 64 377 20.863 -104528 157323.
となります。
0227login:Penguin2009/05/12(火) 12:54:50ID:9//BdTRm
まあ、騙されたと思って、>>223をやってみてくれ
0228login:Penguin2009/05/12(火) 12:55:47ID:9//BdTRm
あ、>>224か
0229login:Penguin2009/05/12(火) 12:56:20ID:yLw+nx2g
restrictに
ntp[1-3].jst.mfeed.ad.jp
を追加する。

それはそうと、stratumが混ざってるのはOK?
0230login:Penguin2009/05/12(火) 12:59:09ID:xIacyLnH
>>226
$ nslookup ntp.nict.jp
Server: 192.168.11.1
Address: 192.168.11.1#53

Non-authoritative answer:
Name: ntp.nict.jp
Address: 133.243.238.243
Name: ntp.nict.jp
Address: 133.243.238.244
Name: ntp.nict.jp
Address: 133.243.238.163
Name: ntp.nict.jp
Address: 133.243.238.164

繋がる奴と繋がらない奴があるもよう。
0231login:Penguin2009/05/12(火) 13:10:11ID:BTb6ucmx
Fedoraでやったときの話だけれど、時刻のズレが大きいと同期してくれなかった
から、手動で近い時刻にしたら、正常に同期してくれたような気がする。
0232login:Penguin2009/05/12(火) 13:14:02ID:yLw+nx2g
ここでNTP話を続けるのもなんだが、
ntp-a2nict.go.jp, ntp-a3.nict.go.jp: RFC1769, RFC2030
ntp-b2.nict.go.jp, ntp-b2.nict.go.jp: RFC1119, RFC1305, RFC1769
(nict.jpではなくnict.go.jp)
準拠らしい。
■ このスレッドは過去ログ倉庫に格納されています