Fedora (Core) 総合スレッド Part 42
■ このスレッドは過去ログ倉庫に格納されています
0001login:Penguin
2008/06/24(火) 23:48:33ID:xNmQjmzEFedora 総合スレッド Part 41
http://pc11.2ch.net/test/read.cgi/linux/1210690706/
●Fedora公式
http://fedoraproject.org/wiki/
●ダウンロード
http://torrent.fedoraproject.org/
http://mirrors.fedoraproject.org/publiclist/Fedora/
●FAQ
Fedoraで自宅サーバー構築
http://fedorasrv.com/
Fedora インストール個人的ノート
http://tmcosmos.org/linux/fedora/
The Unofficial Fedora FAQ 日本語版
http://fedorafaq.yanbaru.dyndns.org/
Fedora 2ch FAQ
http://www12.atwiki.jp/linux2ch/pages/91.html#id_6aa24643
0651login:Penguin
2008/09/22(月) 23:57:30ID:6OHSRA+10652login:Penguin
2008/09/23(火) 00:07:21ID:BvDGjuI+0653login:Penguin
2008/09/23(火) 00:25:41ID:FdDQYrF5それでした。 ありがとうございます
0654login:Penguin
2008/09/23(火) 01:12:52ID:4lgP/ldGjuju とは違うけど、これやってみた?
カーネルコンパイルは必要ない。
http://www.kinodv.org/article/view/162/1/13/
0655login:Penguin
2008/09/23(火) 01:42:10ID:6ST11ffhsambaでファイルサーバとして使っているんだけど、
Windows XPのマイネットワークにFedora Core9のホスト名がどうしても現れない。
Fedora Core5のときは、ちゃんとホスト名見えていたんだけど・・・
あと、試しに、Fedora Core8を入れてもダメだった。
結局、Windows XPからは
\\[Fedora Core9のIPアドレス]でアクセスしているけど、なんとかホスト名を出す方法ないかなあ。
というのは、REGZAからは、どうやらホスト名が見えていないと、録画先として指定できないっぽい。
この件について、ググってみたけど、答えは見つからず。
鍵はブラウジングと名前解決になると思うけど。
0656login:Penguin
2008/09/23(火) 01:55:48ID:XhCu5BUp0657login:Penguin
2008/09/23(火) 02:37:09ID:jB7R5Z3dそもそもfedora側の「ネットワーク」で自ホスト見えてる?
定番だが、ホスト名設定(/etc/hostsとかsmb.confのnetbios nameとか)
firewall、SELinuxあたりかなぁ。
0658login:Penguin
2008/09/23(火) 05:39:44ID:YvSp2cxFDVDに焼かないとじゃないと動かないかも?
0659login:Penguin
2008/09/23(火) 05:41:16ID:Edu1SyD6nmbが動いてないんじゃないの?
0660login:Penguin
2008/09/23(火) 09:11:32ID:hu6GunCU10がでるの待ったほうがいいですか?
0661login:Penguin
2008/09/23(火) 09:38:12ID:91FY8lJi0662login:Penguin
2008/09/23(火) 09:47:05ID:C60vinDu最近のデフォルトでデスクトップ環境付きのLinuxは
覚えることが多すぎる
0663655
2008/09/23(火) 10:10:24ID:6ST11ffhおかげさまで解決しました。
結論から言うと、nmbが起動していませんでした。
以前は、/etc/init.d/smb startとすると、
smb と nmb が起動していましたが、Fedora Core8ではsmbしか
起動してきません。
結局、nmbdを起動したら、WindowsXPからホスト名が見えるようになりました。
0664login:Penguin
2008/09/23(火) 12:45:13ID:JYHHhh7f勉強ならUbuntuの方がインターネット上の情報も書籍も多いよ。
0665login:Penguin
2008/09/23(火) 12:47:58ID:zWLDox9t何を勉強したいのかだな。
とりあえずデスクトップ用途ならUbuntu
サーバ用途ならCentOS
Fedoraは最新機能を使いたい場合の人柱って感じがするからな。
ある程度Linux分かってないと辛いと思うぞ。
0666login:Penguin
2008/09/23(火) 13:14:14ID:jB7R5Z3dFedora避けるならCentOSも避けたほうがいい。
CentOSは使い勝手は結局「古い(新機能の使えない劣化版)Fedora」だ。
運用ではなく学習ならサーバでもubuntu(server版)押しとく。
正直今Fedoraはお進めできないが、それは人柱うんぬんではなくて
リポなどでいろいろトラブルがあって今ごたごたしているからだ。
実はdebianなんかは必死に宣伝しているが
開発コミュニティの参加者はdebianに匹敵するかそれ以上いるようだ。日本でも2ちゃんでも。
(なぜかfedoraコミュニティではそういうのは互いに暗黙のうちに秘密にする傾向があるみたい。
社用とか会社員が多くて名前を出せない場合が多いのかもな)、そういう前提があって、
安定指向な人には不評なようだが、updateが頻繁さが有効な場合もある。
現に、先週あった2chのクッキー変更仕様にともなうjdの改修対応などは
fedoraが最速だった。2ちゃんに文句書いとけば2、3日後に
知らんうちに直っていたりすることもあったりする。
fedoraにするならごたごたが落ち着くまでもう少し待つというのもありだ。
とりあえずubuntuあたりでいいんじゃね?
0667login:Penguin
2008/09/23(火) 13:28:25ID:Cm+ORuVgやだよ。
0668login:Penguin
2008/09/23(火) 13:37:42ID:QidOUMSy0669login:Penguin
2008/09/23(火) 13:55:48ID:QVxq3kpi臭!なんかクサ!
近寄らないで
0670login:Penguin
2008/09/23(火) 17:11:43ID:pPCphV+iさすがダミアン
0671login:Penguin
2008/09/23(火) 17:23:49ID:Psvc3scZIME2000よりかしこくていいな
0672login:Penguin
2008/09/23(火) 17:29:19ID:umThbyvxttp://www.kmc.gr.jp/proj/winanthy/
0673login:Penguin
2008/09/23(火) 17:58:40ID:2TX5UeqQIntelのHPからライセンスキー取得とファイルのダウンロードができたのでFedora8に入れてみた
compat-libstdc++-33入れないとインストールでlibstdc++.so.5がないと言われるので
これを入れてからインストールを実行するとうまくいく
0674login:Penguin
2008/09/23(火) 18:15:16ID:Ax8cm7mH日本の開発コミュはdebianの方が多いよ。
まぁdebianとubuntuの日本コミュが連携していくって話があるけど。
最初fedoraにORCA入れようと思ったけど挫折w
0676login:Penguin
2008/09/23(火) 22:36:11ID:Psvc3scZまさかあるとは思わなかったw、使ってみる。ありがとう!
0677login:Penguin
2008/09/24(水) 10:24:52ID:ZMNTIDGnttps://www.redhat.com/archives/fedora-devel-list/2008-September/msg01938.html
0678login:Penguin
2008/09/24(水) 11:05:09ID:uaZYlSJmvmware-any-any-update117dを使ってmakeは通ったのだけれど、
ゲストPCを起動しようとすると、
下記メッセージが表示されてさっぱり動きません.
どうすればいいんでしょうか。
The process exited with an error:
vmxvmdb:Index name being generated from config file
POST[no connection]: Version mismatch with vmmon module: expecting 138.0, got 168.0
You have an incorrect version of the `vmmon' kernel module.
Try reinstaling VMware Server.
0679login:Penguin
2008/09/24(水) 12:29:13ID:ZMNTIDGn0680login:Penguin
2008/09/24(水) 13:00:58ID:lGDqq3hpもう一週間アップデート出さないつもりかな?
0681login:Penguin
2008/09/24(水) 13:16:12ID:69IfVllpアップデートの頻度も減るんだけど、9は違う意味で
アップデートが来ないよー。
RedHatLinux時代の9はいい出来だったんだけどなあ。
0682login:Penguin
2008/09/24(水) 13:36:05ID:lGDqq3hp侵入の原因も公表されてないし
0683login:Penguin
2008/09/24(水) 14:34:49ID:QgJbF8Raさっきdist-f{9,8}-updatesのtag付けの通知が来てたから、
今日か明日にはpushされそう
0684login:Penguin
2008/09/24(水) 14:55:27ID:lGDqq3hp開発優先ということなんだろうけど
0685login:Penguin
2008/09/24(水) 16:41:16ID:ZMNTIDGnべつにF9のアップデートが詰ってるとか感じないけどな、
いつもこんな感じだから。
0686login:Penguin
2008/09/25(木) 00:37:35ID:HT6UTHdB0687login:Penguin
2008/09/25(木) 02:09:25ID:JsuNjEPOノートパッドのようなもので書き込んだ文章をコピーすると大丈夫です。
いったい何が起こったのでしょうか。
0688login:Penguin
2008/09/25(木) 12:45:25ID:eP+XbDKW俺もこうなるわ。だれか解決策plz
再インストールしても結果は同じになります。
ログ全部載せるとこんな感じ。
これが繰り返しでてる。
/var/log/vmware/vmware-serverd.log
[msg.vmmonPosix.badVersion] Version mismatch with vmmon module: expecting 138.0, got 168.0.
[msg.vmmonPosix.badDriver] You have an incorrect version of the `vmmon' kernel module.
Try reinstalling VMware Server.
[localized] Version mismatch with vmmon module: expecting 138.0, got 168.0.
You have an incorrect version of the `vmmon' kernel module.
Try reinstalling VMware Server.
----------------------------------------
Msg_Post: Version mismatch with vmmon module: expecting 138.0, got 168.0.
You have an incorrect version of the `vmmon' kernel module.
Try reinstalling VMware Server.
Msg_Post: Error
[msg.vmmonPosix.initFailed] Failed to initialize monitor device.
[localized] Failed to initialize monitor device.
----------------------------------------
Msg_Post: Failed to initialize monitor device.
http://www1.pm.tokushima-u.ac.jp/~kohda/linux/doc/vmware.html
ここの情報を参考にしようと思いましたが、既に修正済みでした。
0689login:Penguin
2008/09/25(木) 12:56:43ID:yg9nXAqdttps://www.redhat.com/archives/fedora-list/2008-September/msg01423.html
ttps://www.redhat.com/archives/fedora-list/2008-September/msg01554.html
0691login:Penguin
2008/09/25(木) 23:50:20ID:DzrI4g4pそんなら、JDでも使えばいいじゃん
どうせ、v2cを使い始めてそんなに時間がたってないんだろ
釣られてやるよ
0692login:Penguin
2008/09/26(金) 00:05:34ID:W9l0nClu仕方なく独自で rawhide のをビルドしました。
てか、あと 2 か月の寿命。koji にしてみっか。
0693login:Penguin
2008/09/26(金) 03:41:58ID:QI1JpPNb本家(mozillla)のバイナリ落としてきて使えばいいじゃん。そのまま動くよ。2との併存も可だし。
漏れはあんま大差ないしプラグインが動かないやつがあるから2使ってるけど。
firefox3対応はF9からだね。
0694login:Penguin
2008/09/26(金) 11:59:58ID:53/5rXYWに挙がってる日本のミラーって、
http://mirrors.fedoraproject.org/publiclist/
にある全ての日本のミラーサーバが並ぶわけじゃないの?
まだアップデートされていないjaistがトップにくるせいで、いつまでたってもアップデートの知らせがこない。
まぁ、手動でfedora-update-newkey.repoを書き換えればいいのだが…。
てか、山形大はまずくね?
0695login:Penguin
2008/09/26(金) 12:35:53ID:XgVKNEXu0696login:Penguin
2008/09/26(金) 12:42:43ID:XgVKNEXuどうなっちゃったんだろ?
0697login:Penguin
2008/09/26(金) 12:44:02ID:XgVKNEXu何度かリロードしてると順番は変わるみたい
0698login:Penguin
2008/09/26(金) 12:54:12ID:53/5rXYWjaist, kddikabs固定
Using Internet2ってのが気になる。
0699login:Penguin
2008/09/26(金) 12:54:50ID:1lNdL50l昔のように廃品でこっそりミラーしてた
ところとかはもう止めてるんじゃないかな。
0700login:Penguin
2008/09/26(金) 13:17:24ID:XgVKNEXu127.0.0.1 ftp.jaist.ac.jp
を入れた
0701login:Penguin
2008/09/26(金) 13:24:50ID:53/5rXYWおぉ、すばらしい!!
サンクス
0702login:Penguin
2008/09/26(金) 15:57:54ID:4u00LlKf以下のようなエラーが出なかったのに,
今日同じ src.rpm をリビルドした rpm では,
以下のようなエラーが出た.
エラー: アーカイブの伸長に失敗: ファイル /usr/lib64/firefox-3.0.2/firefox;48dc8784: cpio: MD5 チェックサムが適合しません。
なんで?
こんなエラー出たの初めてやなー.
0704login:Penguin
2008/09/26(金) 16:44:18ID:53/5rXYWHDD寿命間近
0705login:Penguin
2008/09/26(金) 16:49:02ID:DQSmZdpT24時間稼働させてるマシンが、不意に無反応に(pingは通るがsshその他全部ダメ)
その他にもupdateが有ったし絶対では無いが、logも残さず逝く
とりあえず2.6.25.14-108に戻して様子見中
0706login:Penguin
2008/09/26(金) 16:51:49ID:4u00LlKfえ?そんなことってありうる?
まだ半年も使ってないハードディスクなんだけど….
0707login:Penguin
2008/09/26(金) 16:54:49ID:XgVKNEXu普通にありうる
0708login:Penguin
2008/09/26(金) 16:56:49ID:XgVKNEXuもう2.6.26.5-45.fc9が出てるから試してみれ
0709login:Penguin
2008/09/26(金) 16:58:21ID:1lNdL50l0710login:Penguin
2008/09/26(金) 16:58:30ID:q+cnPasR0711login:Penguin
2008/09/26(金) 17:11:37ID:XgVKNEXuもう-47がビルドされてる
0712login:Penguin
2008/09/26(金) 17:46:47ID:DQSmZdpTあらま、週末にまた試してみます
0713login:Penguin
2008/09/26(金) 18:06:23ID:VGHQtN5+0714login:Penguin
2008/09/26(金) 18:08:22ID:iEbubCtgmd5ハッシュを出したら、毎回結果が変化してしまって
当てにならなくなってしまった
同じファイルに対するmd5sumの結果が変わるなんてありえるんだろうか
100kbとかのファイルに対して実行すると毎回同じ値なんだけど
容量の関係だろうか
誰か同じような現象を知っている人いませんか
0715login:Penguin
2008/09/26(金) 18:16:29ID:XgVKNEXuちょっと上に同じような現象報告してる奴が居るわけだが
どっちにしろハードウェアの問題だろ
買い換えろ
0716login:Penguin
2008/09/26(金) 18:30:26ID:iEbubCtg読み取りが失敗してるってことか?
0717login:Penguin
2008/09/26(金) 18:36:43ID:1lNdL50lx86_64 + 4GB over MEM ですか?
iommuあたりでぐぐってみる。
0718702
2008/09/26(金) 19:27:36ID:4u00LlKfそうなんです.Fedora 8 (x86_64) なんですが,
/usr/lib64/firefox-3.0.2/firefox に入るべき
firefox の md5sum が変わっているんです.
ここ 2, 3 日でなんか関連する更新ってありましたか?
0719login:Penguin
2008/09/26(金) 19:43:48ID:4u00LlKfというのは嘘でした m(_ _)m
% md5sum /home/oppai_pub/rpm/RPMS/x86_64/firefox-3.0.2-2.fc8uls.x86_64.rpm
6e6cfbf71dcd77b642cfe56a2279d49e /home/oppai_pub/rpm/RPMS/x86_64/firefox-3.0.2-2.fc8uls.x86_64.rpm
% md5sum /home/oppai_pub/rpm/BUILD/firefox-3.0.2/mozilla/dist/firefox/firefox
606f4982ec43ca8a55426baa0e886748 /home/oppai_pub/rpm/BUILD/firefox-3.0.2/mozilla/dist/firefox/firefox
% md5sum /home/oppai_pub/rpm/RPMS/x86_64/firefox-3.0.2-2.fc8uls.x86_64.rpm
60bf7066d44c57adf42f359c1dcdc363 /home/oppai_pub/rpm/RPMS/x86_64/firefox-3.0.2-2.fc8uls.x86_64.rpm
md5sum /home/oppai_pub/rpm/BUILD/firefox-3.0.2/mozilla/dist/firefox/firefox
606f4982ec43ca8a55426baa0e886748 /home/oppai_pub/rpm/BUILD/firefox-3.0.2/mozilla/dist/firefox/firefox
それにしても,>>702 の原因が不明です.
0720login:Penguin
2008/09/26(金) 19:43:56ID:XgVKNEXuprelinkだな
0721702
2008/09/26(金) 19:57:03ID:4u00LlKfprelink error: unpacking of archive failed on file fedora cpio: MD5 sum mismatch
くらいでぐぐって,
いくつもひっかかったけど,ここらへんを参考にしました.
http://vijayk.blogspot.com/2005/08/cpio-md5-sum-mismatch-on-rpms-created.html
0722login:Penguin
2008/09/27(土) 00:09:10ID:+ooN11re0723login:Penguin
2008/09/28(日) 14:58:53ID:vOs7tkpMなにゆえふぇどらは
くそふぇどら
うぷのむべやま
はっぱふみふみ
0724login:Penguin
2008/09/28(日) 19:11:18ID:HoF15aTU0725login:Penguin
2008/09/29(月) 03:10:06ID:lfZLEZFV0726login:Penguin
2008/09/29(月) 15:18:46ID:L4lBHZ6Lopenchromeはまたバグってるんだな
0727login:Penguin
2008/09/29(月) 15:51:47ID:L4lBHZ6L0728login:Penguin
2008/09/29(月) 15:58:11ID:L4lBHZ6Lこれ5月に報告されてたのにまだ治ってなかったのか
0729login:Penguin
2008/09/30(火) 09:01:30ID:7DeFMFdLよかったね。ようやくkernel updateした。kmodのnvidiaがやっとおちてきた。
0730login:Penguin
2008/09/30(火) 23:16:23ID:wAF+oyXdrhgbが失敗するようになってテキストブートになってしまったのは俺だけ?
0731login:Penguin
2008/09/30(火) 23:19:33ID:1Z/Imlv1https://www.redhat.com/archives/fedora-announce-list/2008-September/msg00016.html
0732login:Penguin
2008/09/30(火) 23:37:06ID:vgDx9YaJ俺も
updates-testingの何かでそうなるっぽい
rhgbなんて要らないし、どうせF10では無くなるから気にしない
0733login:Penguin
2008/10/01(水) 00:00:36ID:vgDx9YaJFedoraのtorrentはシードが極細すぎて使い物にならんな
0734login:Penguin
2008/10/01(水) 09:02:01ID:RVoM83SS情報ありがとう。これで寝れる。
0735login:Penguin
2008/10/01(水) 09:03:13ID:RVoM83SS0736login:Penguin
2008/10/01(水) 15:53:03ID:ErbK8DPnF9の時に指摘されてBugzillaにも入ってるのに
0737login:Penguin
2008/10/01(水) 20:01:38ID:5h5HRq98なんかすごいエラーが出てきた
http://www2.imgup.org/iup699554.jpg
0738login:Penguin
2008/10/01(水) 23:46:01ID:HbUcMkyuなんだか、これをやったのと同じやねwww
sudo su -c "yes '\(^o^)/' > /dev/sda"
0739737
2008/10/02(木) 00:56:38ID:Ylh/YP3o0740login:Penguin
2008/10/02(木) 22:57:26ID:OsjJhKXt背景:
先日、FedoraCore9を使ってファイルサーバを立てました。REGZAの録画に使用しています。
録画するときと、再生するとき意外はファイルサーバは使用しません。
そこで、HDPARMコマンドを使って、一定時間HDDにアクセスしなければ、
回転を停止し、消費電力を抑えるようにしました。
ところが、けっこう頻繁にHDDにアクセスするようで(ログの書き出しか?)
回転開始/停止を繰り返しています。
RAMを1GByte積んでいるので、そのうちの一部をディスクキャッシュとして使い、
HDDへのアクセスを抑えることはできないのでしょうか。
0741login:Penguin
2008/10/02(木) 23:18:51ID:QDsN4Xmpこれ、1時間おきにゴリゴリやるから、抜いた方がいいよ。
0742login:Penguin
2008/10/02(木) 23:21:59ID:oPjFdfEenoflushd
0743740
2008/10/02(木) 23:36:55ID:OsjJhKXtyum-updatedはサービスが起動しないように設定しています。
>>742
noflushdで出来るようですね。
早速、調べてみたら、HDDを壊してしまったという書き込みがボロボロ
出てきて、怖くなってきましたw
noflushdで検索して出てきたHPに、noatimeでマウントしたり、ramdiskに/tmpや
/varを追い出したり、けっこういろんなことを実施する必要があるようです。
もう少し勉強してみます。ありがとうございます。
0744login:Penguin
2008/10/02(木) 23:41:12ID:oPjFdfEe0745740
2008/10/03(金) 00:04:38ID:OsjJhKXt実は、先週は、Liveusb-creater使って、Fedora Core Live 9を
USBメモリにインストールしてみました。
一部のファイルが何故かフラッシュされていない(原因不明)場合があることを
除けば、一応は動きました。
ただ、USBメモリは書き込み回数に上限があります。
したがって、HDDへのアクセスを減らすことと同じように、
なるべく書き込みが起きないように工夫する必要があると思います。
結局は、USBメモリを使う場合も、743に書いたことを調べて行う必要があるのですね。
0746login:Penguin
2008/10/03(金) 00:29:59ID:QnMIgB1Sそんで録画するHDDをマウントして使えばいいんじゃね
0747login:Penguin
2008/10/03(金) 01:11:53ID:v02EdYM5そう言うディストリをUbuntuで作った。
0748login:Penguin
2008/10/03(金) 01:13:56ID:v02EdYM5/tmpと/var/logを/dev/shm以下のディレクトリにバインドマウントするだけで大分違う。
0749login:Penguin
2008/10/03(金) 02:57:26ID:haYHTJXC0750login:Penguin
2008/10/03(金) 10:12:38ID:nPjfDR9O入れた方がいれば使用感を教えてほしいです。
■ このスレッドは過去ログ倉庫に格納されています