Fedora 総合スレッド Part 36
■ このスレッドは過去ログ倉庫に格納されています
0001login:Penguin
2007/06/15(金) 00:35:09ID:AJpytCKSFedoraはGUIが充実しており、Linux初心者の方もとっつきやすいようですが、
あくまで実験的な試みの集合体であります。
動かないと泣く前に、最低でもFAQサイトには目を通しましょう。
●前スレ
Fedora 総合スレッド Part 35
http://pc11.2ch.net/test/read.cgi/linux/1178700625/
***** 公式サイトとか *****
●インスコ前にこのあたりには目を通しましょう
Fedora Project
http://fedora.redhat.com/
http://fedoraproject.org/wiki/
Fedora JP Project
http://fedora.jp/
2ch Linux Beginners
http://linux2ch.is.land.to/
Fedora 2ch FAQ
http://linux2ch.is.land.to/index.php?InstallationFedoraCoreFAQs
The Unofficial Fedora FAQ 日本語版
http://fedorafaq.yanbaru.dyndns.org/
0101login:Penguin
2007/06/20(水) 12:52:42ID:wX22ogGy>>100
/etc/fstab
LABEL=/ / ext3 defaults 1 1
LABEL=/backup /backup ext3 defaults 1 2
LABEL=/boot /boot ext3 defaults 1 2
none /dev/pts devpts gid=5,mode=620 0 0
none /dev/shm tmpfs defaults 0 0
none /proc proc defaults 0 0
none /sys sysfs defaults 0 0
/dev/hdb2 swap swap defaults 0 0
こんな感じになっていて
/dev/disk/by-label
lrwxrwxrwx 1 root root 10 6月 1 09:03 backup -> ../../hdb1
lrwxrwxrwx 1 root root 10 6月 1 09:03 boot -> ../../hda1
こんな感じのラベルになっていました。
0102login:Penguin
2007/06/20(水) 21:04:04ID:6sl0O6mH「依存コンポーネント」のエラーで
「システムには現在1MBのRAMがあります。・・・
インストールには1024MBのRAMが必要・・・」
というエラーが出力され、インストールできません。
Fedora自体は正しくメモリを認識おり
メモリは2G(1G X 2)あるので問題ないはずなのですが・・
ためしにメモリを1枚抜いたら、「現在0MBのRAM」となりました。
回避方法を、ご存知の方はご教授ください。
0103login:Penguin
2007/06/21(木) 02:37:50ID:Tnhxy15Lまずどうしてメモリが認識されてると思うのか説明してくれ
0104login:Penguin
2007/06/21(木) 04:59:30ID:nWNkVwQbいや、oracleの事はもっとわからんけど
0105login:Penguin
2007/06/21(木) 05:37:00ID:j5cmTTRS0106なおったちゃん
2007/06/21(木) 08:20:53ID:MwNVm1IFおぉ、昨日で直ったよ(^_^)/
ランレベル3でログインして・・・
yum -y groupinstall "X Window System"
yum -y groupinstall "'GNOME Desktop Environment"
って、やったら直った。う〜ん、FC6からF7にアップグレードした時
一部が失敗していたみたいです(^^;)
0107login:Penguin
2007/06/21(木) 17:17:47ID:VubktOj9起動時にローカルファイルシステムがマウントできねえぞ( ゚Д゚)ゴルァ!!ってなって
そっから先進まないんだけど仕様?
0108login:Penguin
2007/06/21(木) 17:20:09ID:FjwRd2/Y0109login:Penguin
2007/06/21(木) 20:10:14ID:K6cbOmVcお前には使えないのか。
0110login:Penguin
2007/06/21(木) 21:00:55ID:gAYniaoWいろいろいじってたら、おかしくなった
0111login:Penguin
2007/06/21(木) 22:20:57ID:BheZvTJs0112login:Penguin
2007/06/22(金) 00:04:51ID:8z+gn77Rインストール後、Starting udev で止まってしまいます…どうやって回避?
0113login:Penguin
2007/06/22(金) 12:14:39ID:wyByJFVnブートパラメータいじってみそ.
acpi=off apm=off 等
0114login:Penguin
2007/06/22(金) 17:31:18ID:QSlVmKveFedoraって本当に良いですね
0115login:Penguin
2007/06/22(金) 18:02:17ID:FExbU2ZH0116login:Penguin
2007/06/22(金) 18:58:19ID:IknEhI900117login:Penguin
2007/06/22(金) 21:12:13ID:FExbU2ZH妻にバージョンアップすると簡単にはそうはできなくなるという罠がある。
経験者は語る。
0118login:Penguin
2007/06/22(金) 21:19:19ID:KhupPilYそのまま復旧しないんだけど、何が原因だろう。。
ネットワーク再起動してもダメ。。
0119login:Penguin
2007/06/22(金) 21:32:26ID:w+HgYXpOバージョンアップおめ。
保守が大変かもしれないが、まあそれも楽しみのうちだろう。
ところでセキュリティ・パッチはちゃんと当ててる?
0120login:Penguin
2007/06/22(金) 21:45:34ID:FExbU2ZH落ちるというのがなんだかわかんない。
>>119
トンクス。
保守は結婚記念日のオプション追加購入になるかも。
0121login:Penguin
2007/06/22(金) 21:54:08ID:3DKlZQpg逆に最初だけ繋がるってのは何が起きてるの、あるいはどうして繋がったと分かるの?
0122login:Penguin
2007/06/22(金) 21:56:46ID:KhupPilY落ちる=つながらなくなる です。。
>>121
最初はFirefoxでWebページが見れるんです。
けど、1、2ページ閲覧してると、突然見れなくなる。
Firefox以外でも同じ。yum updateも途中で止まる。。
再起動するまでネットワーク復旧せず。。
FC7リリース直後から今までずっとはまってます。
助けてくだちい。。
0123login:Penguin
2007/06/22(金) 22:18:47ID:xzY0m79V確認事項:
1)落ちた状態でIP直指定でPINGが通るか
2)IPv6、SeLinuxの有効/無効
3)落ちた状態でルーターへのPINGは通るか
4)F7うpデート前は同様の問題は無かったか
起動したら速攻でgnome-terminal開いてrootになって
tail -f /var/log/messages
でログ眺めてたら?
0125122
2007/06/22(金) 22:43:56ID:KhupPilYyum update かけてみたら、ネットワークが落ちる瞬間に、
こんなエラーが出たです。
exception Emask (以下略
パーツ構成が悪いんですかね?
G965のマザーなんですが。
>>123
1)ダメです
2)どちらもダメでした
3)通りません
4)新規インストールです
0126login:Penguin
2007/06/22(金) 23:14:35ID:RdiW3Blg0127login:Penguin
2007/06/22(金) 23:19:29ID:xzY0m79V1)もし予備のLANカードがあれば試す
2)F7固有の問題なのかKnoppixで再現実験する
0128login:Penguin
2007/06/23(土) 00:25:28ID:KFwfQ6LSありがとうございます。
今度試してみます。
0129login:Penguin
2007/06/23(土) 20:56:26ID:yyyL4yxcわいの場合は G965M-FI をこうて改造したんやけど、
オンボード Realtek RTL8110SC の奴、Linuxに対応してなく
CG-LAPCIGTR って奴、こうたら、つながった
ですわ、ではでは
0130login:Penguin
2007/06/23(土) 23:14:37ID:KI1wSWOt0131login:Penguin
2007/06/24(日) 03:07:01ID:YjWuR4MOHTTPとTOMCAT5を連系させようと、「Fedora-Core-1-i386.tar.gz」
を入れた所、起動しなくなってしまいました。
設定は全て戻して、mod_jk2等も削除しました。
/etc/init.d/httpd start
を実行しても[失敗]と表示されてしまい、起動できません。
何が原因か困っています。原因調査の方法などわかるかたいましたらご教示願います。
0132login:Penguin
2007/06/24(日) 11:11:30ID:7ipphfmF0133login:Penguin
2007/06/24(日) 11:17:54ID:ILEzwEFW0134login:Penguin
2007/06/24(日) 11:31:27ID:RDmj92HS自分で決めたじゃない
0135気まぐれアナスイ
2007/06/24(日) 11:53:27ID:rJfXAOHw理解できますか?
0136login:Penguin
2007/06/24(日) 12:03:07ID:c8vKgFZpさっさと再インストール
0137132
2007/06/24(日) 12:03:32ID:7ipphfmFエラーログすら見ようとしない人が多いのを嘆いています。
見ない人に限ってログのファイル名を知らない。
見ない人に限ってどこにあるかを知らない。
見ない人に限って tail -f を知らない。
そんな傾向があるかと。
viが使えない人に限ってエディタを使わないでファイルを作成する方法を知らないみたいな。
0138login:Penguin
2007/06/24(日) 12:07:32ID:RDmj92HS0139login:Penguin
2007/06/24(日) 14:50:12ID:tSG2p7V+ソース落としてきてrpmbuildでパッチ当てるところでエラーが出てしまう。
2.6.21-1.3228.fc7
みんなは普通にできてる?
0140login:Penguin
2007/06/24(日) 14:53:27ID:Jj0ItxHBなんか、わざとやってるっぽい。
0141login:Penguin
2007/06/24(日) 15:04:03ID:tSG2p7V+0142login:Penguin
2007/06/24(日) 15:08:08ID:4UJhtSy0休日を利用して半年ほど常時稼動していたFC5のサーバをとめて、FC6にアップデートしました。
まぁそう簡単に全部は動かないだろうといくらか覚悟していたのですが、
dig, host, nslookup など、ことごとく動かなくなっており何もできない状況です。
コマンドを打つとどれも
> dig: error while loading shared libraries: libdns.so.22: cannot open shared object file: No such file or directory
のようなエラーを返してきますが、 /usr/lib/ の下には libdns.so.22 と libdns.so.22.1.0 が存在しています。
何か手がかりをお持ちの方はアドバイスいただけないでしょうか?
0143login:Penguin
2007/06/24(日) 15:11:22ID:uYbYrBXMようわからんけど、カーネルの再構築をやってほしくないみたい。
なんかの条件でそうなるような感じ。
0144login:Penguin
2007/06/24(日) 15:19:19ID:tSG2p7V+( ゚д゚)なんやそら?
ソースだしといて、そういうのありなんか。
0145login:Penguin
2007/06/24(日) 15:24:20ID:uYbYrBXMbugzillaに文句言えば
0146login:Penguin
2007/06/24(日) 15:25:59ID:d4LDbbL70147login:Penguin
2007/06/24(日) 15:29:40ID:c8vKgFZp/sbin/ldconfig
0148login:Penguin
2007/06/24(日) 15:32:32ID:kYpzcXaT0149login:Penguin
2007/06/24(日) 15:34:02ID:1MeYx1ny入れた方がいいよ。
0150login:Penguin
2007/06/24(日) 15:36:05ID:c8vKgFZpいったん6を経由してから7にあげるほうがいい。
0151login:Penguin
2007/06/24(日) 15:36:59ID:4UJhtSy0レスありがとうございます。もちろん ldconfig はやってみたんです。(結果は変わらず、でした)
ところで /etc/ld.so.conf には include ld.so.conf.d/*.conf と書いてあって、
実際にそのディレクトリには mysql と qt 用のライブラリを有効にする設定ファイルしかありませんでした。
/usr/lib の下のライブラリを有効にする設定はどこなのだろう。
なにか見当違いな発言をしていたらご指摘ください。あらためます。
0152login:Penguin
2007/06/24(日) 15:39:56ID:kYpzcXaTありがとうございます。
とりあえず、FC6経由でアップグレードしようかと思います。
0153login:Penguin
2007/06/24(日) 15:41:54ID:uYbYrBXMls -al /usr/lib/libdns*
dig、host、nslookup
これらはbind-utilsってのに属してるみたいだが、src.rpmから
再コンパイル、再インスコすれば直る鴨。
0155login:Penguin
2007/06/24(日) 15:59:15ID:c8vKgFZprpm -V bind-libs
でbind-libsパッケージが壊れてないか確認したほうがいい。
それから、アップグレードした後は必ず
yum list extras
や
yum install yum-utils
package-cleanup -d
package-cleanup --problems
を実効して、
アップグレードに失敗したパッケージや重複パッケージが無いか調べろ。
0156login:Penguin
2007/06/24(日) 16:18:25ID:N2fvueVHFedoraとXPをデュアルブートにしようと思ったのですがうまくいきません。
パーティションの状態は、
/dev/sda1にXPを、
/dev/sda2に/bootを、
/dev/sda3にルート(linux)をインストールしています
多分インストールはうまく言ってると思うのですが、
ブートの選択でXPの方を選択すると(Fedoraは起動します)、
A Ploblem has been detected and windows has been shut down to prevent damage to your computer.
~~~~~~~~~~~~~~~~~~~
** STOP: 0x000000ED
のような青いエラー画面が出て、Windowsが立ち上がりません。
何とかアドバイスお願いします。
0157login:Penguin
2007/06/24(日) 16:21:06ID:4UJhtSy0どうもありがとうございます。
155氏のアドバイスどおり、bind-libs(他、依存関係解決のため諸々)のバージョン9.3.4-6(探した限り最新)の
RPMをダウンロードしてアップデートしたところ、ひとまず dig やら nslookup やらは使えるようになりました。
・・・しかしまだyumが動かない。リポジトリのミラーを探せないのはこれが原因じゃなかったのか?ガックリ
ひとまず、最初に質問させていただいた点は解決いたしました。本当にありがとうございました。
0158login:Penguin
2007/06/24(日) 16:24:15ID:c8vKgFZpF7はリポジトリのディレクトリ構成が変わってるよ。
アップグレードすると/etc/yum.repos.d/の下の設定ファイルは入れ替わるはずだけど、
それが合ってないと動かないからチェックしてみれ。
0159login:Penguin
2007/06/24(日) 16:55:14ID:4UJhtSy0confファイルの中身を色々チェックしてたんですが、yumのcacheをクリアしたらあっさりできました。
お恥ずかしい。どうもありがとうございました。
>>156
どんな感じでHDDに空きをつくりましたか?どんな風にパーティションを切りましたか?
OSは何から入れましたか?HDDはRAID構成になっていたりしませんか?
ブートローダはGRUBですか?何ですか?
どんな画面遷移で最終的にブルースクリーンになるのですか?
もう少し詳しく情報を書くと何かレスがつくかも知れません。
0160login:Penguin
2007/06/24(日) 16:57:04ID:1f/ic5CcブルースクリーンはWindowsの方のエラーなハズ
インストしたときにどっか壊したとか?
とりあえず起動ディスク(リカバリディスク)使ってみるといいかも
0161login:Penguin
2007/06/24(日) 17:26:36ID:IWH7y63hXPとデュアルブートにしたいけど なんか怖い
メーカー製でOSは最初から入ってて
リカバリディスクしか ないんですが
もし Windowsを起動できなくった場合でも
リカバリディスクからMBRを復元できますか?
0162login:Penguin
2007/06/24(日) 17:38:12ID:N2fvueVH自作PCなんですorz
fdiskコマンドのdオプションで一度、パティションをすべて削除してから、
Windowsをインストールしました。
そして、Fedoraをインストールし直しました。
パーティションの状態は>>156の通りで、
ブートローダーはGRUBです。
おそらくHDDがダメなんじゃないかなと思ったりもします。。
0163login:Penguin
2007/06/24(日) 18:28:40ID:c8vKgFZp純正MBRに拘らなくても、適当なブートセレクターを使えばいいと思うよ。
0164login:Penguin
2007/06/24(日) 18:32:26ID:/twFL5ajrootnoverify (hdA,B)
chainloader +1
とか書くだけなんだが…
0165login:Penguin
2007/06/24(日) 19:10:55ID:12ZaJFOl仕方ないからUbuntuに移動した俺カナシス
0166login:Penguin
2007/06/24(日) 19:48:43ID:cLSMETOR( ゚∀゚)彡 edora! edora!
⊂彡
0167login:Penguin
2007/06/24(日) 22:43:10ID:S8NWepkS0168login:Penguin
2007/06/24(日) 22:50:52ID:hN29BIe0今までWinxp+apacheで稼働してたのをfera7に変えてから
アクセス2倍になったし。
もうなんかウハウハ。
0169login:Penguin
2007/06/24(日) 22:51:31ID:6rA7Ay7J0170login:Penguin
2007/06/24(日) 22:54:06ID:IMghTNuV0171login:Penguin
2007/06/24(日) 22:57:08ID:12ZaJFOl今ではその彼女と中国語で熱く語り合ってます!!
(58才,会社員)
0172login:Penguin
2007/06/24(日) 23:13:04ID:XGYqZ3Pt0173login:Penguin
2007/06/24(日) 23:43:44ID:1f/ic5Ccテキストモードで強引に入れてからyumで入れればできる
0174173
2007/06/24(日) 23:45:29ID:1f/ic5CcとにかくOSを無理やりでもなんでも入れて、起動後にyumで足りないのを入れればできる
0175login:Penguin
2007/06/24(日) 23:57:52ID:12ZaJFOlテキストインストールでもパッケージが足りないから再起動するかDVDを再読み込みしろとか言われました。
再読み込みをバシバシ選択したのですが効果がありませんでした。
そのまま再起動してyumコマンドを使えばよかったのかもしれませんが精神衛生上あまりよろしくなかったのでUbuntuに流れました。
再インストールする気力が湧かないのでF8あたりでリベンジしようと思ってます。コメントどうも。
0176login:Penguin
2007/06/25(月) 00:42:46ID:SK1TTVMi( ゚∀゚)彡 edora! edora!
⊂彡
0177login:Penguin
2007/06/25(月) 03:32:39ID:uycgxZuk( ゚∀゚)彡 edora! edora!
⊂彡
0178login:Penguin
2007/06/25(月) 09:12:54ID:CLHQYV6g( ゚∀゚)彡 fera! fera!
⊂彡
0179login:Penguin
2007/06/25(月) 09:20:48ID:2gOileUBMBRを変えない方法もある→bootpart
0180login:Penguin
2007/06/25(月) 10:21:45ID:J064Lrfhこのへんのをひとつ用意しておくと便利だよ。
使いかたはググっておくれ。
http://www.allbootdisks.com/Languages/jp/index.html
http://www.bootdisk.com/bootdisk.htm
0181161
2007/06/25(月) 21:55:27ID:e+E0TOCx>>180
ありがとうございます
FDDもない状態なんで・・・・
ちょっと色々としらべてみます
返事遅くなって すいませんorz
0182login:Penguin
2007/06/26(火) 00:18:24ID:xs3oSyvn0183login:Penguin
2007/06/26(火) 00:22:01ID:miPTnQ5J君の脳が重いの?
0184login:Penguin
2007/06/26(火) 00:29:59ID:6evlBE7v0185login:Penguin
2007/06/26(火) 00:32:53ID:Npby6kng0186login:Penguin
2007/06/26(火) 00:35:05ID:zN+86J1h0187login:Penguin
2007/06/26(火) 00:36:30ID:miPTnQ5J貧乏なの?
0188login:Penguin
2007/06/26(火) 00:36:59ID:6evlBE7v0189login:Penguin
2007/06/26(火) 01:02:13ID:xs3oSyvnFedora-7-i386.torrent Fedora 7 i386 2.8G 2007-05-31
Fedora-7-Live-x86_64.torrent Fedora 7 Live x86_64 781M 2007-05-31
Fedora-7-KDE-Live-x86_64.torrent Fedora 7 KDE Live x86_64 833M 2007-05-31
Fedora-7-KDE-Live-i686.torrent Fedora 7 KDE Live i686 688M 2007-05-31
Fedora-7-x86_64.torrent Fedora 7 x86_64 3.4G 2007-05-31
Fedora-7-ppc.torrent Fedora 7 ppc 3.5G 2007-05-31
Fedora-7-Live-i686.torrent Fedora 7 Live i686 701M 2007-05
2.8Gの落とすのが一番いいの?
0190login:Penguin
2007/06/26(火) 01:07:57ID:miPTnQ5JLive落として、必要なものは後で地道に追加する方が早い感じがした。
0191login:Penguin
2007/06/26(火) 01:15:06ID:OrDIpjQP0192login:Penguin
2007/06/26(火) 02:46:45ID:1gNpJz9uボリュームラベルのマウントポイントが勝手に出来るけど
これを/media/dvdとかに固定する方法ないですか?
使ってるのはFedora7です。
0193login:Penguin
2007/06/26(火) 03:08:05ID:miPTnQ5J何でそんなこと聞くの?
0194login:Penguin
2007/06/26(火) 03:45:47ID:1gNpJz9uんー、最終的にはWineでDVDドライブを常時認識できるようにしたい。
今は、CDなりDVDなりを入れた状態なら、マウントポイントを
D:とかに割り当てればメディアの中身がWineから見えるんだけど
メディア入れてなかったりブランクメディアだったりすると
winecfgの自動検出だとドライブ検出してくれないし
手動で追加しようにもパスに何を入れれば良いやら。
/dev/dvdとかは駄目だったし。
で、マウントポイントが固定されてれば上手くいくんじゃないかと考えてみた。
・・・なんか根本的に考え方間違ってますか?
0195login:Penguin
2007/06/26(火) 03:49:10ID:miPTnQ5Jようわからんけど、VMware使ったら?
0196login:Penguin
2007/06/26(火) 04:24:26ID:b2qU9fzhlinuxに対応したLANカードってどこで調べたらいいの?
もしくはお勧めメーカーなんて教えてもらえるとありがたい……
インストールしたんだけどLANカードが古くて対応してなくて
対応したものを買いたいんだけど……
因みにインストールしようとしてるのはRHEL4なんだけど……
0197login:Penguin
2007/06/26(火) 04:25:11ID:5DJ8vpAc0198login:Penguin
2007/06/26(火) 06:08:03ID:Dj5fUUIX192じゃないけど
'part #1' ってボリュームのDVDだと、
ファイルまたはフォルダ /media/part は存在しません
ってエラーメッセージが出るから
0199login:Penguin
2007/06/26(火) 07:32:17ID:QA+CoT9iLANカードが古いせいではなくてディストリが古いせいだと思うが
0200login:Penguin
2007/06/26(火) 07:58:32ID:XX44tYmXなんでこのスレで聞くの?
■ このスレッドは過去ログ倉庫に格納されています